summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-25 11:39:42 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-25 11:39:42 +0000
commit2a1362932a383c1b06495586c9c8ec076d13a960 (patch)
treeeea0486a4d377a276fb74281609f70348ca95e59 /sci-libs/libsvm
parentDrop emacs22icons flag; always install all icons. Remove old cleanup code. (diff)
downloadgentoo-2-2a1362932a383c1b06495586c9c8ec076d13a960.tar.gz
gentoo-2-2a1362932a383c1b06495586c9c8ec076d13a960.tar.bz2
gentoo-2-2a1362932a383c1b06495586c9c8ec076d13a960.zip
Dropped old, correct typo in DESCRIPTION
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libsvm')
-rw-r--r--sci-libs/libsvm/ChangeLog8
-rw-r--r--sci-libs/libsvm/libsvm-3.0.ebuild74
-rw-r--r--sci-libs/libsvm/libsvm-3.1.ebuild88
-rw-r--r--sci-libs/libsvm/libsvm-3.11.ebuild6
-rw-r--r--sci-libs/libsvm/metadata.xml10
5 files changed, 14 insertions, 172 deletions
diff --git a/sci-libs/libsvm/ChangeLog b/sci-libs/libsvm/ChangeLog
index 21305ba0af57..aef3d987240c 100644
--- a/sci-libs/libsvm/ChangeLog
+++ b/sci-libs/libsvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libsvm
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.24 2011/12/29 19:52:41 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.25 2012/03/25 11:39:42 jlec Exp $
+
+ 25 Mar 2012; Justin Lecher <jlec@gentoo.org> -libsvm-3.0.ebuild,
+ -libsvm-3.1.ebuild, libsvm-3.11.ebuild, metadata.xml:
+ Dropped old, correct typo in DESCRIPTION
*libsvm-3.11 (29 Dec 2011)
diff --git a/sci-libs/libsvm/libsvm-3.0.ebuild b/sci-libs/libsvm/libsvm-3.0.ebuild
deleted file mode 100644
index eb9722e193b3..000000000000
--- a/sci-libs/libsvm/libsvm-3.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.0.ebuild,v 1.1 2010/12/02 19:46:11 bicatali Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils java-pkg-opt-2 python
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="java python tools"
-
-DEPEND="java? ( >=virtual/jdk-1.4 )"
-RDEPEND="${DEPEND}
- tools? ( sci-visualization/gnuplot )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-makefile.patch
- sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
- || die "Failed to fix paths in python files"
- if use java; then
- local JAVAC_FLAGS="$(java-pkg_javac-args)"
- sed -i \
- -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
- Makefile || die "Failed to fix java makefile"
- fi
-}
-
-src_compile() {
- emake || die "emake failed"
- if use java ; then
- emake -C java || die "emake for java modules failed"
- fi
-}
-
-src_install() {
- dobin svm-train svm-predict svm-scale \
- || die "failed to install binaries"
- dolib.so *.so* || die "failed to install library"
- insinto /usr/include
- doins svm.h || die
- dohtml FAQ.html || die
- dodoc README
-
- if use tools; then
- for t in tools/*.py; do
- newbin ${t} svm-$(basename ${t} .py) || die "install tools failes"
- done
- newdoc tools/README README.tools
- insinto /usr/share/doc/${PF}
- doins heart_scale || die
- doins -r svm-toy || die
- fi
-
- if use python ; then
- installation() {
- insinto $(python_get_sitedir)
- doins python/*.py || die "python modules install failed"
- }
- python_execute_function installation
- newdoc python/README README.python
- fi
-
- if use java; then
- java-pkg_dojar java/libsvm.jar
- dohtml java/test_applet.html
- fi
-}
diff --git a/sci-libs/libsvm/libsvm-3.1.ebuild b/sci-libs/libsvm/libsvm-3.1.ebuild
deleted file mode 100644
index ffa8d3ee625f..000000000000
--- a/sci-libs/libsvm/libsvm-3.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.1.ebuild,v 1.1 2011/08/09 04:46:36 bicatali Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils java-pkg-opt-2 python flag-o-matic toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Mahcines"
-HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="java openmp python tools"
-
-DEPEND="java? ( >=virtual/jdk-1.4 )"
-RDEPEND="${DEPEND}
- tools? ( sci-visualization/gnuplot )"
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- die "Need an OpenMP capable compiler"
- else
- append-ldflags -fopenmp
- append-cxxflags -fopenmp
- fi
- append-cxxflags -DOPENMP
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/3.0-makefile.patch
- epatch "${FILESDIR}"/${PV}-openmp.patch
- sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
- || die "Failed to fix paths in python files"
- if use java; then
- local JAVAC_FLAGS="$(java-pkg_javac-args)"
- sed -i \
- -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
- Makefile || die "Failed to fix java makefile"
- fi
-}
-
-src_compile() {
- emake || die "emake failed"
- if use java ; then
- emake -C java || die "emake for java modules failed"
- fi
-}
-
-src_install() {
- dobin svm-train svm-predict svm-scale \
- || die "failed to install binaries"
- dolib.so *.so* || die "failed to install library"
- insinto /usr/include
- doins svm.h || die
- dohtml FAQ.html || die
- dodoc README
-
- if use tools; then
- for t in tools/*.py; do
- newbin ${t} svm-$(basename ${t} .py) || die "install tools failes"
- done
- newdoc tools/README README.tools
- insinto /usr/share/doc/${PF}
- doins heart_scale || die
- doins -r svm-toy || die
- fi
-
- if use python ; then
- installation() {
- insinto $(python_get_sitedir)
- doins python/*.py || die "python modules install failed"
- }
- python_execute_function installation
- newdoc python/README README.python
- fi
-
- if use java; then
- java-pkg_dojar java/libsvm.jar
- dohtml java/test_applet.html
- fi
-}
diff --git a/sci-libs/libsvm/libsvm-3.11.ebuild b/sci-libs/libsvm/libsvm-3.11.ebuild
index dc80273597c3..db0de490b78d 100644
--- a/sci-libs/libsvm/libsvm-3.11.ebuild
+++ b/sci-libs/libsvm/libsvm-3.11.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.11.ebuild,v 1.1 2011/12/29 19:52:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.11.ebuild,v 1.2 2012/03/25 11:39:42 jlec Exp $
EAPI="4"
SUPPORT_PYTHON_ABIS="1"
inherit eutils java-pkg-opt-2 python flag-o-matic toolchain-funcs
-DESCRIPTION="Library for Support Vector Mahcines"
+DESCRIPTION="Library for Support Vector Machines"
HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
diff --git a/sci-libs/libsvm/metadata.xml b/sci-libs/libsvm/metadata.xml
index 27b4207dccd1..a30bae157f5b 100644
--- a/sci-libs/libsvm/metadata.xml
+++ b/sci-libs/libsvm/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The LIBSVM library is used to calculate Support Vector Machine
optimizations with a great variety of options. It includes
one-class, two-class, multiclass, regression-mode, and probablistic
output functionality. It is primarily of interest to machine-learning
researchers and artificial intelligence application developers.
</longdescription>
-<use>
- <flag name='tools'>Install python based tool scripts</flag>
-</use>
+ <use>
+ <flag name="tools">Install python based tool scripts</flag>
+ </use>
</pkgmetadata>