summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-04 11:51:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-04 11:51:35 +0000
commitb9bc3cdc86158b5cb8f72451c80f8759e575d2fa (patch)
tree5feb94fd377f6e8fbd67e505cb372c6e6f0933df /sci-libs/libqalculate
parentVersion bump, bug #207570 (diff)
downloadgentoo-2-b9bc3cdc86158b5cb8f72451c80f8759e575d2fa.tar.gz
gentoo-2-b9bc3cdc86158b5cb8f72451c80f8759e575d2fa.tar.bz2
gentoo-2-b9bc3cdc86158b5cb8f72451c80f8759e575d2fa.zip
Added patches to allow compilation against cln-1.2 (see bug #208527).
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/ChangeLog11
-rw-r--r--sci-libs/libqalculate/files/libqalculate-0.9.6-cl_abort.patch20
-rw-r--r--sci-libs/libqalculate/files/libqalculate-0.9.6-cln-config.patch171
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.6-r1.ebuild52
4 files changed, 252 insertions, 2 deletions
diff --git a/sci-libs/libqalculate/ChangeLog b/sci-libs/libqalculate/ChangeLog
index 42d7ffceae37..5440976450ce 100644
--- a/sci-libs/libqalculate/ChangeLog
+++ b/sci-libs/libqalculate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libqalculate
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/ChangeLog,v 1.24 2007/10/19 20:14:56 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/ChangeLog,v 1.25 2008/02/04 11:51:34 markusle Exp $
+
+*libqalculate-0.9.6-r1 (02 Feb 2008)
+
+ 02 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/libqalculate-0.9.6-cl_abort.patch,
+ +files/libqalculate-0.9.6-cln-config.patch, +libqalculate-0.9.6-r1.ebuild:
+ Added patches to allow compilation against cln-1.2 (see bug #208527).
19 Oct 2007; nixnut <nixnut@gentoo.org> libqalculate-0.9.6.ebuild:
Stable on ppc wrt bug 193455
diff --git a/sci-libs/libqalculate/files/libqalculate-0.9.6-cl_abort.patch b/sci-libs/libqalculate/files/libqalculate-0.9.6-cl_abort.patch
new file mode 100644
index 000000000000..74a0c9dc0117
--- /dev/null
+++ b/sci-libs/libqalculate/files/libqalculate-0.9.6-cl_abort.patch
@@ -0,0 +1,20 @@
+diff -Naur libqalculate-0.9.6/libqalculate/Number.cc libqalculate-0.9.6.new1/libqalculate/Number.cc
+--- libqalculate-0.9.6/libqalculate/Number.cc 2007-05-18 04:03:22.000000000 -0400
++++ libqalculate-0.9.6.new1/libqalculate/Number.cc 2008-02-02 11:06:15.000000000 -0500
+@@ -28,6 +28,7 @@
+
+ using namespace cln;
+
++/*
+ void cln::cl_abort() {
+ CALCULATOR->error(true, "CLN Error: see terminal output (probably too large or small floating point number)", NULL);
+ if(CALCULATOR->busy()) {
+@@ -36,7 +37,7 @@
+ exit(0);
+ }
+ }
+-
++*/
+ string printCL_I(cl_I integ, int base = 10, bool display_sign = true, BaseDisplay base_display = BASE_DISPLAY_NORMAL, bool lower_case = false) {
+ if(base == BASE_ROMAN_NUMERALS) {
+ if(!zerop(integ) && integ < 10000 && integ > -10000) {
diff --git a/sci-libs/libqalculate/files/libqalculate-0.9.6-cln-config.patch b/sci-libs/libqalculate/files/libqalculate-0.9.6-cln-config.patch
new file mode 100644
index 000000000000..d0e4d9bedcdc
--- /dev/null
+++ b/sci-libs/libqalculate/files/libqalculate-0.9.6-cln-config.patch
@@ -0,0 +1,171 @@
+diff -Naur libqalculate-0.9.6/aclocal.m4 libqalculate-0.9.6.new/aclocal.m4
+--- libqalculate-0.9.6/aclocal.m4 2007-06-17 04:45:44.000000000 -0400
++++ libqalculate-0.9.6.new/aclocal.m4 2008-02-02 11:04:21.000000000 -0500
+@@ -7836,146 +7836,27 @@
+ [dnl
+ dnl Get the cppflags and libraries from the cln-config script
+ dnl
+-AC_ARG_WITH(cln-prefix,[ --with-cln-prefix=PFX Prefix where CLN is installed (optional)],
+- cln_config_prefix="$withval", cln_config_prefix="")
+-AC_ARG_WITH(cln-exec-prefix,[ --with-cln-exec-prefix=PFX Exec prefix where CLN is installed (optional)],
+- cln_config_exec_prefix="$withval", cln_config_exec_prefix="")
+-AC_ARG_ENABLE(clntest, [ --disable-clntest Do not try to compile and run a test CLN program],
+- , enable_clntest=yes)
+-
+-if test x$cln_config_exec_prefix != x ; then
+- cln_config_args="$cln_config_args --exec-prefix=$cln_config_exec_prefix"
+- if test x${CLN_CONFIG+set} != xset ; then
+- CLN_CONFIG=$cln_config_exec_prefix/bin/cln-config
+- fi
+-fi
+-if test x$cln_config_prefix != x ; then
+- cln_config_args="$cln_config_args --prefix=$cln_config_prefix"
+- if test x${CLN_CONFIG+set} != xset ; then
+- CLN_CONFIG=$cln_config_prefix/bin/cln-config
+- fi
+-fi
+
+-AC_PATH_PROG(CLN_CONFIG, cln-config, no)
++AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+ cln_min_version=ifelse([$1], ,1.1.0,$1)
+ AC_MSG_CHECKING(for CLN - version >= $cln_min_version)
+-if test "$CLN_CONFIG" = "no" ; then
++if test "$PKG_CONFIG" = "no" ; then
+ AC_MSG_RESULT(no)
+- echo "*** The cln-config script installed by CLN could not be found"
+- echo "*** If CLN was installed in PREFIX, make sure PREFIX/bin is in"
+- echo "*** your path, or set the CLN_CONFIG environment variable to the"
+- echo "*** full path to cln-config."
++ echo "*** could not find pkg-config"
+ ifelse([$3], , :, [$3])
+ else
+ dnl Parse required version and the result of cln-config.
+- cln_min_major_version=`echo $cln_min_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+- cln_min_minor_version=`echo $cln_min_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+- cln_min_micro_version=`echo $cln_min_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+- CLN_CPPFLAGS=`$CLN_CONFIG $cln_config_args --cppflags`
+- CLN_LIBS=`$CLN_CONFIG $cln_config_args --libs`
+- cln_config_version=`$CLN_CONFIG $cln_config_args --version`
+- cln_config_major_version=`echo $cln_config_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+- cln_config_minor_version=`echo $cln_config_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+- cln_config_micro_version=`echo $cln_config_version | \
+- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+-dnl Check if the installed CLN is sufficiently new according to cln-config.
+- if test \( $cln_config_major_version -lt $cln_min_major_version \) -o \
+- \( $cln_config_major_version -eq $cln_min_major_version -a $cln_config_minor_version -lt $cln_min_minor_version \) -o \
+- \( $cln_config_major_version -eq $cln_min_major_version -a $cln_config_minor_version -eq $cln_min_minor_version -a $cln_config_micro_version -lt $cln_min_micro_version \); then
+- echo -e "\n*** 'cln-config --version' returned $cln_config_major_version.$cln_config_minor_version.$cln_config_micro_version, but the minimum version"
+- echo "*** of CLN required is $cln_min_major_version.$cln_min_minor_version.$cln_min_micro_version. If cln-config is correct, then it is"
+- echo "*** best to upgrade to the required version."
+- echo "*** If cln-config was wrong, set the environment variable CLN_CONFIG"
+- echo "*** to point to the correct copy of cln-config, and remove the file"
+- echo "*** config.cache before re-running configure."
+- ifelse([$3], , :, [$3])
++ if $PKG_CONFIG cln --atleast-version=${cln_min_version}; then
++ echo "Found cln >= ${cln_min_version}"
++ CLN_CPPFLAGS=`$PKG_CONFIG cln --cflags`
++ CLN_LIBS=`$PKG_CONFIG cln --libs`
+ else
+-dnl The versions match so far. Now do a sanity check: Does the result of cln-config
+-dnl match the version of the headers and the version built into the library, too?
+- no_cln=""
+- if test "x$enable_clntest" = "xyes" ; then
+- ac_save_CPPFLAGS="$CPPFLAGS"
+- ac_save_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
+- LIBS="$LIBS $CLN_LIBS"
+- rm -f conf.clntest
+- AC_TRY_RUN([
+-#include <stdio.h>
+-#include <string.h>
+-#include <cln/version.h>
+-
+-/* we do not #include <stdlib.h> because autoconf in C++ mode inserts a
+- prototype for exit() that conflicts with the one in stdlib.h */
+-extern "C" int system(const char *);
+-
+-int main(void)
+-{
+- system("touch conf.clntest");
+-
+- if ((CL_VERSION_MAJOR != $cln_config_major_version) ||
+- (CL_VERSION_MINOR != $cln_config_minor_version) ||
+- (CL_VERSION_PATCHLEVEL != $cln_config_micro_version)) {
+- printf("\n*** 'cln-config --version' returned %d.%d.%d, but the header file I found\n", $cln_config_major_version, $cln_config_minor_version, $cln_config_micro_version);
+- printf("*** corresponds to %d.%d.%d. This mismatch suggests your installation of CLN\n", CL_VERSION_MAJOR, CL_VERSION_MINOR, CL_VERSION_PATCHLEVEL);
+- printf("*** is corrupted or you have specified some wrong -I compiler flags.\n");
+- printf("*** Please inquire and consider reinstalling CLN.\n");
+- return 1;
+- }
+- if ((cln::version_major != $cln_config_major_version) ||
+- (cln::version_minor != $cln_config_minor_version) ||
+- (cln::version_patchlevel != $cln_config_micro_version)) {
+- printf("\n*** 'cln-config --version' returned %d.%d.%d, but the library I found\n", $cln_config_major_version, $cln_config_minor_version, $cln_config_micro_version);
+- printf("*** corresponds to %d.%d.%d. This mismatch suggests your installation of CLN\n", cln::version_major, cln::version_minor, cln::version_patchlevel);
+- printf("*** is corrupted or you have specified some wrong -L compiler flags.\n");
+- printf("*** Please inquire and consider reinstalling CLN.\n");
+- return 1;
+- }
+- return 0;
+-}
+-],, no_cln=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+- CPPFLAGS="$ac_save_CPPFLAGS"
+- LIBS="$ac_save_LIBS"
+- fi
+- if test "x$no_cln" = x ; then
+- AC_MSG_RESULT([yes, $cln_config_version])
+- ifelse([$2], , :, [$2])
+- else
+- AC_MSG_RESULT(no)
+- if test ! -f conf.clntest ; then
+- echo "*** Could not run CLN test program, checking why..."
+- CPPFLAGS="$CFLAGS $CLN_CPPFLAGS"
+- LIBS="$LIBS $CLN_LIBS"
+- AC_TRY_LINK([
+-#include <stdio.h>
+-#include <cln/version.h>
+-], [ return 0; ],
+- [ echo "*** The test program compiled, but did not run. This usually means"
+- echo "*** that the run-time linker is not finding CLN or finding the wrong"
+- echo "*** version of CLN. If it is not finding CLN, you'll need to set your"
+- echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+- echo "*** to the installed location. Also, make sure you have run ldconfig if that"
+- echo "*** is required on your system."],
+- [ echo "*** The test program failed to compile or link. See the file config.log for the"
+- echo "*** exact error that occured. This usually means CLN was incorrectly installed"
+- echo "*** or that you have moved CLN since it was installed. In the latter case, you"
+- echo "*** may want to edit the cln-config script: $CLN_CONFIG." ])
+- CPPFLAGS="$ac_save_CPPFLAGS"
+- LIBS="$ac_save_LIBS"
+- fi
+- CLN_CPPFLAGS=""
+- CLN_LIBS=""
+- ifelse([$3], , :, [$3])
+- fi
++ echo "ERROR: cln >= ${cln_min_version} not found"
++ ifelse([$3], , :, [$3])
+ fi
+ fi
+ AC_SUBST(CLN_CPPFLAGS)
+ AC_SUBST(CLN_LIBS)
+-rm -f conf.clntest
+ ])
+
+ # pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
+diff -Naur libqalculate-0.9.6/src/Makefile.in libqalculate-0.9.6.new/src/Makefile.in
+--- libqalculate-0.9.6/src/Makefile.in 2007-06-17 04:45:49.000000000 -0400
++++ libqalculate-0.9.6.new/src/Makefile.in 2008-02-02 11:37:48.000000000 -0500
+@@ -117,7 +117,7 @@
+ INTLTOOL_XML_RULE = @INTLTOOL_XML_RULE@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ @CLN_LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_QALCULATE = @LN_QALCULATE@
+ LN_S = @LN_S@
diff --git a/sci-libs/libqalculate/libqalculate-0.9.6-r1.ebuild b/sci-libs/libqalculate/libqalculate-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..a966a21b8880
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/libqalculate-0.9.6-r1.ebuild,v 1.1 2008/02/04 11:51:34 markusle Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A modern multi-purpose calculator library"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="readline"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+COMMON_DEPEND=">=sci-libs/cln-1.1
+ dev-libs/libxml2
+ >=dev-libs/glib-2.4
+ sys-libs/zlib
+ readline? ( sys-libs/readline )"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ dev-util/intltool
+ sys-devel/gettext"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sci-visualization/gnuplot-3.7
+ net-misc/wget"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-check-fix.patch
+ epatch "${FILESDIR}"/${P}-cl_abort.patch
+ epatch "${FILESDIR}"/${P}-cln-config.patch
+ eautoconf
+}
+
+src_compile() {
+ # The CLN test is buggy and will often fail though an appropriate version
+ # of the library is installed.
+ CONFIG="$(use_with readline) --disable-clntest"
+ econf ${CONFIG} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die "Installation failed."
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ dodoc ${DOCS} || die "Documentation installation failed."
+}