summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:31:16 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:31:16 +0000
commit5a021a5f5173386d8e93a095796c98fa60879ff7 (patch)
treeabdd3722429cb9db3c67d0ee9df346d0ef11c808 /sci-libs/libctl
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-5a021a5f5173386d8e93a095796c98fa60879ff7.tar.gz
gentoo-2-5a021a5f5173386d8e93a095796c98fa60879ff7.tar.bz2
gentoo-2-5a021a5f5173386d8e93a095796c98fa60879ff7.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libctl')
-rw-r--r--sci-libs/libctl/ChangeLog8
-rw-r--r--sci-libs/libctl/libctl-3.0.3.ebuild18
-rw-r--r--sci-libs/libctl/libctl-3.1.ebuild19
3 files changed, 26 insertions, 19 deletions
diff --git a/sci-libs/libctl/ChangeLog b/sci-libs/libctl/ChangeLog
index 81a4e5475445..6d37323f94d4 100644
--- a/sci-libs/libctl/ChangeLog
+++ b/sci-libs/libctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libctl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/ChangeLog,v 1.14 2010/12/02 10:39:39 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/ChangeLog,v 1.15 2011/06/21 08:31:16 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> libctl-3.0.3.ebuild,
+ libctl-3.1.ebuild:
+ Added fortran-2.eclass support
02 Dec 2010; Justin Lecher <jlec@gentoo.org> libctl-3.1.ebuild:
Fix DEPs for guile; #346695
diff --git a/sci-libs/libctl/libctl-3.0.3.ebuild b/sci-libs/libctl/libctl-3.0.3.ebuild
index 6474162e40fa..9092e937c5b0 100644
--- a/sci-libs/libctl/libctl-3.0.3.ebuild
+++ b/sci-libs/libctl/libctl-3.0.3.ebuild
@@ -1,26 +1,28 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/libctl-3.0.3.ebuild,v 1.2 2008/11/08 18:58:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/libctl-3.0.3.ebuild,v 1.3 2011/06/21 08:31:16 jlec Exp $
-DESCRIPTION="Guile-based library implementing flexible control files for scientific simulations"
-SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+inherit fortran-2
+
+DESCRIPTION="Guile-based library for scientific simulations"
HOMEPAGE="http://ab-initio.mit.edu/libctl/"
+SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 x86"
-
-SLOT="0"
IUSE="examples"
DEPEND=">=dev-scheme/guile-1.6"
+RDEPEND="${DEPEND}"
src_compile() {
- econf --enable-shared || die "econf failed"
+ econf --enable-shared
emake || die "emake failed"
}
src_install() {
einstall || die "einstall failed"
- dodoc NEWS AUTHORS COPYRIGHT ChangeLog
+ dodoc NEWS AUTHORS ChangeLog
use examples && doins -r examples
}
diff --git a/sci-libs/libctl/libctl-3.1.ebuild b/sci-libs/libctl/libctl-3.1.ebuild
index 66f7ab46b711..5ee329500f57 100644
--- a/sci-libs/libctl/libctl-3.1.ebuild
+++ b/sci-libs/libctl/libctl-3.1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/libctl-3.1.ebuild,v 1.2 2010/12/02 10:39:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libctl/libctl-3.1.ebuild,v 1.3 2011/06/21 08:31:16 jlec Exp $
-EAPI=2
+EAPI=4
+
+inherit fortran-2
DESCRIPTION="Guile-based library for scientific simulations"
-SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
HOMEPAGE="http://ab-initio.mit.edu/libctl/"
+SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
-SLOT="0"
IUSE="debug doc examples"
DEPEND="
@@ -25,14 +27,13 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake failed"
- dodoc NEWS AUTHORS COPYRIGHT ChangeLog
+ default
if use doc; then
- dohtml doc/* || die
+ dohtml doc/*
fi
if use examples; then
insinto /usr/share/doc/${PF}/examples
cd examples
- doins Makefile.am README *.c *.h *.ctl *scm || die
+ doins Makefile.am README *.c *.h *.ctl *scm
fi
}