summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-17 07:51:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-17 07:51:20 +0000
commit489f42f488b5491e37c74a5a7ece13b12e68289b (patch)
treea56740e19da2a8c98465ec15cc9e7b3c9fed564e /sci-libs/itpp
parentBump (diff)
downloadgentoo-2-489f42f488b5491e37c74a5a7ece13b12e68289b.tar.gz
gentoo-2-489f42f488b5491e37c74a5a7ece13b12e68289b.tar.bz2
gentoo-2-489f42f488b5491e37c74a5a7ece13b12e68289b.zip
sci-libs/itpp: revbump, because stable automake do not like AM_PROG_AR, #426402
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog7
-rw-r--r--sci-libs/itpp/itpp-4.2-r2.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 503cfb616c2c..4ab8a8f6214b 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.113 2012/07/15 10:39:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.114 2012/07/17 07:51:20 jlec Exp $
+
+*itpp-4.2-r2 (17 Jul 2012)
+
+ 17 Jul 2012; Justin Lecher <jlec@gentoo.org> +itpp-4.2-r2.ebuild:
+ revbump, because stable automake do not like AM_PROG_AR, #426402
15 Jul 2012; Justin Lecher <jlec@gentoo.org> itpp-4.2-r1.ebuild,
files/itpp-4.2-automake-1.12.patch:
diff --git a/sci-libs/itpp/itpp-4.2-r2.ebuild b/sci-libs/itpp/itpp-4.2-r2.ebuild
new file mode 100644
index 000000000000..97b075e38d65
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.2-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r2.ebuild,v 1.1 2012/07/17 07:51:20 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="blas debug doc fftw lapack minimal static-libs"
+
+RDEPEND="
+ blas? ( virtual/blas lapack? ( virtual/lapack ) )
+ !minimal? ( fftw? ( >=sci-libs/fftw-3 ) )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.11.1
+ blas? ( virtual/pkgconfig )
+ doc? ( app-doc/doxygen virtual/latex-base )
+ lapack? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
+ "${FILESDIR}"/${P}-fastica-correct-dim.patch
+ "${FILESDIR}"/${P}-test-fftw.patch
+ )
+
+src_prepare() {
+ # turn off performance critical debug code
+ use debug || append-cppflags -DNDEBUG
+ sed \
+ -e 's:-pipe::g' \
+ -e 's:-Werror::g' \
+ -i configure* || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local blasconf="no"
+ use blas && blasconf="$(pkg-config --libs blas)"
+ local lapackconf="no"
+ use lapack && lapackconf="$(pkg-config --libs blas lapack)"
+
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-shared
+ $(use_enable doc html-doc)
+ $(use_enable debug)
+ $(use_enable !minimal comm)
+ $(use_enable !minimal fixed)
+ $(use_enable !minimal optim)
+ $(use_enable !minimal protocol)
+ $(use_enable !minimal signal)
+ $(use_enable !minimal srccode)
+ $(use_with fftw fft)
+ --with-blas="${blasconf}"
+ --with-lapack="${lapackconf}"
+ )
+ autotools-utils_src_configure
+}