summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-09 16:58:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-09 16:58:04 +0000
commit318317b454be98c42f0fc5f1bf9475e2c07363e5 (patch)
tree1ff0c7d610be02fd93a7e30d7ae243304a30354a /sci-libs/itpp
parentFix from upstream for missing symbol versions in multilib builds #304239. (diff)
downloadgentoo-2-318317b454be98c42f0fc5f1bf9475e2c07363e5.tar.gz
gentoo-2-318317b454be98c42f0fc5f1bf9475e2c07363e5.tar.bz2
gentoo-2-318317b454be98c42f0fc5f1bf9475e2c07363e5.zip
Applied a patch for FastICA from Gert Wollny (bug #370475). Switched to EAPI4. Removed old.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog10
-rw-r--r--sci-libs/itpp/files/itpp-4.0.7-window_test_fail_fix.patch16
-rw-r--r--sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch26
-rw-r--r--sci-libs/itpp/itpp-4.0.7-r1.ebuild58
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild (renamed from sci-libs/itpp/itpp-4.2.ebuild)16
5 files changed, 41 insertions, 85 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 9dade7d95a8e..baa1a4935003 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.98 2011/01/03 01:28:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.99 2011/06/09 16:58:04 bicatali Exp $
+
+*itpp-4.2-r1 (09 Jun 2011)
+
+ 09 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> -itpp-4.0.7-r1.ebuild,
+ -files/itpp-4.0.7-window_test_fail_fix.patch, -itpp-4.2.ebuild,
+ +itpp-4.2-r1.ebuild, +files/itpp-4.2-fastica-correct-dim.patch:
+ Applied a patch for FastICA from Gert Wollny (bug #370475). Switched to
+ EAPI4. Removed old.
03 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org> itpp-4.0.7-r1.ebuild,
+files/itpp-4.0.7-window_test_fail_fix.patch:
diff --git a/sci-libs/itpp/files/itpp-4.0.7-window_test_fail_fix.patch b/sci-libs/itpp/files/itpp-4.0.7-window_test_fail_fix.patch
deleted file mode 100644
index b5e7fc3eece3..000000000000
--- a/sci-libs/itpp/files/itpp-4.0.7-window_test_fail_fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index ce86ee6..c68b98b 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -20,9 +20,9 @@ FIXED_TESTS = fix_test
-
- OPTIM_TESTS = newton_search_test
-
--SIGNAL_TESTS = filter_test source_test window_test
-+SIGNAL_TESTS = filter_test source_test
- SIGNAL_LAP_TESTS = fastica_test poly_test
--SIGNAL_FFT_TESTS = freq_filt_test sigfun_test transforms_test
-+SIGNAL_FFT_TESTS = freq_filt_test sigfun_test transforms_test window_test
- SIGNAL_LAP_FFT_TESTS = filter_design_test
-
- STAT_TESTS = histogram_test
diff --git a/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch b/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch
new file mode 100644
index 000000000000..a852abc5cc4c
--- /dev/null
+++ b/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch
@@ -0,0 +1,26 @@
+diff -ru itpp-4.2/itpp/signal/fastica.cpp itpp-4.2.new//itpp/signal/fastica.cpp
+--- itpp-4.2/itpp/signal/fastica.cpp 2011-06-07 17:47:32.261000884 +0200
++++ itpp-4.2.new//itpp/signal/fastica.cpp 2011-06-07 17:31:25.757000915 +0200
+@@ -147,6 +147,9 @@
+
+ whitenv(mixedSigC, E, diag(D), whitesig, whiteningMatrix, dewhiteningMatrix);
+
++ Dim = whitesig.rows();
++
++ if (numOfIC > Dim) numOfIC = Dim;
+
+ ivec NcFirst = to_ivec(zeros(numOfIC));
+ vec NcVp = D;
+@@ -161,10 +164,6 @@
+ bool result = true;
+ if (PCAonly == false) {
+
+- Dim = whitesig.rows();
+-
+- if (numOfIC > Dim) numOfIC = Dim;
+-
+ result = fpica(whitesig, whiteningMatrix, dewhiteningMatrix, approach, numOfIC, g, finetune, a1, a2, mu, stabilization, epsilon, maxNumIterations, maxFineTune, initState, guess, sampleSize, A, W);
+
+ icasig = W * mixedSig;
+Nur in itpp-4.2/itpp/signal: fastica.cpp.orig.
+Nur in itpp-4.2/itpp/signal: fastica.h.orig.
diff --git a/sci-libs/itpp/itpp-4.0.7-r1.ebuild b/sci-libs/itpp/itpp-4.0.7-r1.ebuild
deleted file mode 100644
index d541c17100c8..000000000000
--- a/sci-libs/itpp/itpp-4.0.7-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.7-r1.ebuild,v 1.2 2011/01/03 01:28:11 bicatali Exp $
-
-EAPI=3
-inherit eutils autotools flag-o-matic
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
-LICENSE="GPL-2"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="blas debug doc fftw lapack minimal static-libs"
-
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3 ) )
- blas? ( virtual/blas lapack? ( virtual/lapack ) )"
-DEPEND="${RDEPEND}
- blas? ( dev-util/pkgconfig )
- lapack? ( dev-util/pkgconfig )
- doc? ( app-doc/doxygen virtual/latex-base )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fastica-fix-endless-loop.patch
- epatch "${FILESDIR}"/${P}-window_test_fail_fix.patch
- eautoreconf
-}
-
-src_configure() {
- # turn off performance critical debug code
- use debug || append-flags -DNDEBUG
- local blasconf="no"
- use blas && blasconf="$(pkg-config --libs blas)"
- local lapackconf="no"
- use lapack && lapackconf="$(pkg-config --libs blas lapack)"
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable doc html-doc) \
- $(use_enable debug) \
- $(use_enable !minimal comm) \
- $(use_enable !minimal fixed) \
- $(use_enable !minimal optim) \
- $(use_enable !minimal protocol) \
- $(use_enable !minimal signal) \
- $(use_enable !minimal srccode) \
- $(use_enable static-libs static) \
- $(use_with fftw fft) \
- --with-blas="${blasconf}" \
- --with-lapack="${lapackconf}"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
- ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO
-}
diff --git a/sci-libs/itpp/itpp-4.2.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index 3a598783f26b..97f71e4e23f8 100644
--- a/sci-libs/itpp/itpp-4.2.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2.ebuild,v 1.1 2010/09/25 18:58:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.1 2011/06/09 16:58:04 bicatali Exp $
-EAPI=3
-inherit flag-o-matic
+EAPI=4
+inherit flag-o-matic eutils
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
LICENSE="GPL-3"
HOMEPAGE="http://itpp.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
+ epatch "${FILESDIR}"/${PN}-4.2-fastica-correct-dim.patch
}
src_configure() {
@@ -48,8 +49,3 @@ src_configure() {
--with-blas="${blasconf}" \
--with-lapack="${lapackconf}"
}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS README
-}