summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-16 10:10:11 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-16 10:10:11 +0000
commit91e5055aafa0eab096934b01683865f08cccf217 (patch)
tree26c6e63dfedcee9c3e63ffc83b9cf0cf9ec42861 /sci-libs/gts
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-91e5055aafa0eab096934b01683865f08cccf217.tar.gz
gentoo-2-91e5055aafa0eab096934b01683865f08cccf217.tar.bz2
gentoo-2-91e5055aafa0eab096934b01683865f08cccf217.zip
Rename /usr/bin/merge -> /usr/bin/gts-merge, #358963
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gts')
-rw-r--r--sci-libs/gts/ChangeLog7
-rw-r--r--sci-libs/gts/gts-20100321-r2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-libs/gts/ChangeLog b/sci-libs/gts/ChangeLog
index a052ac62b739..604444418b60 100644
--- a/sci-libs/gts/ChangeLog
+++ b/sci-libs/gts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gts
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.14 2011/03/02 20:04:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.15 2011/03/16 10:10:11 jlec Exp $
+
+*gts-20100321-r2 (16 Mar 2011)
+
+ 16 Mar 2011; Justin Lecher <jlec@gentoo.org> +gts-20100321-r2.ebuild:
+ Rename /usr/bin/merge -> /usr/bin/gts-merge, #358963
02 Mar 2011; Justin Lecher <jlec@gentoo.org> gts-20081607.ebuild,
gts-20090909.ebuild, gts-20100321-r1.ebuild:
diff --git a/sci-libs/gts/gts-20100321-r2.ebuild b/sci-libs/gts/gts-20100321-r2.ebuild
new file mode 100644
index 000000000000..cfcd69124f81
--- /dev/null
+++ b/sci-libs/gts/gts-20100321-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20100321-r2.ebuild,v 1.1 2011/03/16 10:10:11 jlec Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="GNU Triangulated Surface Library"
+LICENSE="LGPL-2"
+HOMEPAGE="http://gts.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-libs/glib:2
+ !<=sci-chemistry/ccp4-apps-6.1.3-r2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( media-libs/netpbm )"
+
+# tests are failing
+RESTRICT="test"
+
+S="${WORKDIR}"/${PN}-snapshot-100321
+
+src_prepare() {
+ chmod +x test/*/*.sh
+ epatch "${FILESDIR}"/${P}-examples.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ mv "${D}"/usr/bin/{,gts-}split || die
+ mv "${D}"/usr/bin/{,gts-}merge || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c || die "Failed to install examples"
+ fi
+
+ # install additional docs
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+}