summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2014-01-27 00:10:33 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2014-01-27 00:10:33 +0000
commit50fbf1966302056ecd0b189eefe1f66ee4ac93f5 (patch)
tree16f54843280561a4aec9c3c036b2e11b4a201735 /sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch
parentversion bump (diff)
downloadgentoo-2-50fbf1966302056ecd0b189eefe1f66ee4ac93f5.tar.gz
gentoo-2-50fbf1966302056ecd0b189eefe1f66ee4ac93f5.tar.bz2
gentoo-2-50fbf1966302056ecd0b189eefe1f66ee4ac93f5.zip
Fix bug 493236: Depend on Perl conditionally. Thanks Nikoli.
Fix bug 492338: Version bump. Thanks Stephan Litterst. Fix bug 483074: Convert to python-r1 to support multiple Pythons. Thanks Ian Stakenvicius. Fix bug 466114: Append -lisqlite3 to LIBS. Thanks cmuelle8. Fix bug 482888: Modify poppler dependency to have a minimum version (>=0.24.3). Fix bug 490048: Add dev-libs/libpcre and dev-libs/libxml2 to RDEPEND Fix bug 489224: Add sub-slot operator to trigger rebuild when poppler or Perl is updated. Thanks Nikoli. Fix bug 490046: Resolved by sci-libs/gdal version bump. Fix bug 474678: Really include the patch this time. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch')
-rw-r--r--sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch b/sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch
new file mode 100644
index 000000000000..cc89200c526d
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.10.0-ruby-makefile.patch
@@ -0,0 +1,47 @@
+diff -Naurw gdal-1.10.0.orig/swig/ruby/RubyMakefile.mk gdal-1.10.0/swig/ruby/RubyMakefile.mk
+--- gdal-1.10.0.orig/swig/ruby/RubyMakefile.mk 2013-04-24 18:55:26.000000000 +0000
++++ gdal-1.10.0/swig/ruby/RubyMakefile.mk 2013-06-25 23:58:06.464518830 +0000
+@@ -37,13 +37,13 @@
+
+ ifeq ("$(shell uname -s)", "Darwin")
+ RUBY_MODULES=$(RUBY_MODULES_MAC)
+-LDFLAGS += -Xcompiler -bundle -L$(RUBY_LIB_DIR)
+-RUBY_LIB := -l$(RUBY_SO_NAME)
+ else
+ RUBY_MODULES=$(RUBY_MODULES_LIN)
+-LDFLAGS += -Xcompiler -shared -L$(RUBY_LIB_DIR)
+-RUBY_LIB := -l$(RUBY_SO_NAME)
+ endif
++LDFLAGS += -fPIC -DPIC -shared -L$(RUBY_LIB_DIR)
++CFLAGS += -fPIC -DPIC
++CXXFLAGS += -fPIC -DPIC
++RUBY_LIB := -l$(RUBY_SO_NAME)
+
+ build: $(RUBY_MODULES)
+
+@@ -56,10 +56,10 @@
+ veryclean: clean
+ rm -f *_wrap.cpp
+
+-$(INSTALL_DIR):
++$(DESTDIR)$(INSTALL_DIR):
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+
+-install: $(INSTALL_DIR)
++install: $(DESTDIR)$(INSTALL_DIR) $(RUBY_MODULES)
+ for i in $(RUBY_MODULES) ; do $(INSTALL) $$i $(DESTDIR)$(INSTALL_DIR) ; done
+
+ $(RUBY_MODULES_MAC): %.bundle: %_wrap.o
+@@ -69,10 +69,10 @@
+ $(LD) $(LDFLAGS) $(LIBS) $(GDAL_SLIB_LINK) $(RUBY_LIB) $< -o $@
+
+ %.o: %.cpp
+- $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
++ $(CXX) $(CXXFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
+
+ %.o: %.cxx
+- $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
++ $(CXX) $(CXXFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<