summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-26 23:51:45 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-26 23:51:45 +0000
commitf2ed9bb98cef0191346760447afe55790cfaeabd (patch)
treeca8840e96170d29d1270d313fe9177ed8677424c /sci-libs/galib
parentVersion bump. (diff)
downloadgentoo-2-f2ed9bb98cef0191346760447afe55790cfaeabd.tar.gz
gentoo-2-f2ed9bb98cef0191346760447afe55790cfaeabd.tar.bz2
gentoo-2-f2ed9bb98cef0191346760447afe55790cfaeabd.zip
Fixed compile problems with gcc-4.x. This fixes bug #149191.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sci-libs/galib')
-rw-r--r--sci-libs/galib/ChangeLog7
-rw-r--r--sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch23
-rw-r--r--sci-libs/galib/galib-2.4.6.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-libs/galib/ChangeLog b/sci-libs/galib/ChangeLog
index e54240374640..722623d39b4d 100644
--- a/sci-libs/galib/ChangeLog
+++ b/sci-libs/galib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/galib
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.5 2006/04/30 14:59:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.6 2006/09/26 23:51:45 markusle Exp $
+
+ 26 Sep 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/galib-2.4.6-gcc4-gentoo.patch, galib-2.4.6.ebuild:
+ Fixed compile problems with gcc-4.x. Thanks much to Jeno I. Hajdu
+ <jeno.i.hajdu@gmail.com> for his patch. This fixes bug #149191.
30 Apr 2006; Markus Dittrich <markusle@gentoo.org>
+files/galib-2.4.6-makefile.patch, galib-2.4.6.ebuild:
diff --git a/sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch b/sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch
new file mode 100644
index 000000000000..ed2621649eef
--- /dev/null
+++ b/sci-libs/galib/files/galib-2.4.6-gcc4-gentoo.patch
@@ -0,0 +1,23 @@
+diff -Naur galib246/ga/gaconfig.h galib246-new/ga/gaconfig.h
+--- galib246/ga/gaconfig.h 2005-01-31 10:46:09.000000000 -0500
++++ galib246-new/ga/gaconfig.h 2006-09-26 19:38:09.000000000 -0400
+@@ -192,7 +192,9 @@
+
+ // determine the compiler
+ #if defined(__GNUG__) || defined(__GNUC__)
+-#if __GNUC__ == 3
++#if __GNUC__ == 4
++#define GALIB_COMPILER "gcc4"
++#elif __GNUC__ == 3
+ #define GALIB_COMPILER "gcc3"
+ #elif __GNUC__ == 2
+ #define GALIB_COMPILER "gcc2"
+@@ -365,7 +367,7 @@
+ #define GALIB_USE_PID
+ #define GALIB_USE_EMPTY_TEMPLATES
+ #define GALIB_NEED_INSTANTIATION_PREFIX
+-#if __GNUC__ == 3
++#if __GNUC__ >= 3
+ #define GALIB_USE_ANSI_HEADERS
+ #define GALIB_USE_STD_NAMESPACE
+ #define GALIB_USE_COMP_OPERATOR_TEMPLATES
diff --git a/sci-libs/galib/galib-2.4.6.ebuild b/sci-libs/galib/galib-2.4.6.ebuild
index d1230875683e..1273485abba1 100644
--- a/sci-libs/galib/galib-2.4.6.ebuild
+++ b/sci-libs/galib/galib-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.3 2006/04/30 14:59:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.4 2006/09/26 23:51:45 markusle Exp $
inherit eutils
@@ -22,6 +22,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc4-gentoo.patch
}
src_compile() {