summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:10:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:10:40 +0000
commit5ed7285766787fc1f18f4c4a78120fc965f92f51 (patch)
treed5306c713b189173bc121df35b1a56a0080e2cf9 /sci-libs/ccolamd
parentremove use of make profiledbootstrap by ppc64 (diff)
downloadgentoo-2-5ed7285766787fc1f18f4c4a78120fc965f92f51.tar.gz
gentoo-2-5ed7285766787fc1f18f4c4a78120fc965f92f51.tar.bz2
gentoo-2-5ed7285766787fc1f18f4c4a78120fc965f92f51.zip
Initial import. Thanks to Justin Bronder for his work, see bug #173900
(Portage version: 2.1.4)
Diffstat (limited to 'sci-libs/ccolamd')
-rw-r--r--sci-libs/ccolamd/ChangeLog11
-rw-r--r--sci-libs/ccolamd/Manifest5
-rw-r--r--sci-libs/ccolamd/ccolamd-2.7.1.ebuild30
-rw-r--r--sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch60
-rw-r--r--sci-libs/ccolamd/metadata.xml10
5 files changed, 116 insertions, 0 deletions
diff --git a/sci-libs/ccolamd/ChangeLog b/sci-libs/ccolamd/ChangeLog
new file mode 100644
index 000000000000..7501756788a6
--- /dev/null
+++ b/sci-libs/ccolamd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/ccolamd
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ChangeLog,v 1.1 2008/02/05 18:10:40 bicatali Exp $
+
+*ccolamd-2.7.1 (05 Feb 2008)
+
+ 05 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/ccolamd-2.7.1-autotools.patch, +metadata.xml,
+ +ccolamd-2.7.1.ebuild:
+ Initial import. Thanks to Justin Bronder for his work, see bug #173900
+
diff --git a/sci-libs/ccolamd/Manifest b/sci-libs/ccolamd/Manifest
new file mode 100644
index 000000000000..e23dd5aafae6
--- /dev/null
+++ b/sci-libs/ccolamd/Manifest
@@ -0,0 +1,5 @@
+AUX ccolamd-2.7.1-autotools.patch 1790 RMD160 cb6e265651b69a5851f50d118a375e428e81abc9 SHA1 84bb9281cd8ad916012ae1e7b9d2f1228d6758db SHA256 ee87aadb77f0f66e07ef1587df314f4aa07e363bad6d8d890831cf8348349d8f
+DIST CCOLAMD-2.7.1.tar.gz 62591 RMD160 91c0aa53f5d20b75d4754242c2eaaa8750ff299d SHA1 fae4127f72f9409360ebc1f5927c62ad1d8e2a2c SHA256 9fd040484e092d857e5c6678faa91a17397b1057c95881f22a92ac8bf2f1e09c
+EBUILD ccolamd-2.7.1.ebuild 720 RMD160 cc22a5ea941a4ef8ecdcf264b331c93e45d9fe1b SHA1 ea5f21dd1160dda6ee2c84177be1a459caaa6503 SHA256 6e07bf86591944c926116a0e72ab6a1759467f750ed5a495b9d2a057c3491473
+MISC ChangeLog 356 RMD160 c2aa4c91abbc7e8d2b02069ceaa993908549f505 SHA1 3a7b64744a80848b917ccc7896a4dea4b5bb4411 SHA256 96afbb6e07e461489ebfbde41cca0a29a7224ed8b777316310a45e195dd20c08
+MISC metadata.xml 354 RMD160 e57ae37810bac6fe614caa8fedeba4d612b99663 SHA1 0209028db35aace9be5c7012d86cbfac488ff07a SHA256 136b2b2e0b5a4270598253edd7f79dd085bc6693fd109dafc7a98dc92c8b93f7
diff --git a/sci-libs/ccolamd/ccolamd-2.7.1.ebuild b/sci-libs/ccolamd/ccolamd-2.7.1.ebuild
new file mode 100644
index 000000000000..d1d62f000540
--- /dev/null
+++ b/sci-libs/ccolamd/ccolamd-2.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ccolamd-2.7.1.ebuild,v 1.1 2008/02/05 18:10:40 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=CCOLAMD
+DESCRIPTION="Constrained column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ccolamd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}
diff --git a/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch b/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch
new file mode 100644
index 000000000000..6b8b069dec7a
--- /dev/null
+++ b/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch
@@ -0,0 +1,60 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 18:53:56.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Demo Source
++EXTRA_DIST = Doc/ChangeLog README.txt
++include_HEADERS = Include/ccolamd.h
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 18:54:17.000000000 +0000
+@@ -0,0 +1,13 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(ccolamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([
++ Source/Makefile
++ Demo/Makefile
++ Makefile])
++AC_OUTPUT
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 18:53:56.000000000 +0000
+@@ -0,0 +1,10 @@
++AM_CPPFLAGS = -I$(top_builddir)/Include
++lib_LTLIBRARIES = libccolamd.la
++noinst_LTLIBRARIES = libccolamdl.la libccolamdi.la
++
++libccolamdl_la_SOURCES = ccolamd.c
++libccolamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++libccolamdi_la_SOURCES = ccolamd.c
++
++libccolamd_la_SOURCES = ccolamd_global.c
++libccolamd_la_LIBADD = libccolamdl.la libccolamdi.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 18:55:44.000000000 +0000
+@@ -0,0 +1,22 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = \
++ ccolamd_example \
++ ccolamd_l_example
++
++LDADD = $(top_builddir)/Source/libccolamd.la -lm
++ccolamd_example_SOURCES = ccolamd_example.c
++ccolamd_l_example_SOURCES = ccolamd_l_example.c
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $$i.out my_$$i.out; then \
++ echo "Test $$i failed!"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
diff --git a/sci-libs/ccolamd/metadata.xml b/sci-libs/ccolamd/metadata.xml
new file mode 100644
index 000000000000..20c177fb4c71
--- /dev/null
+++ b/sci-libs/ccolamd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CCOLAMD computes an column approximate minimum degree ordering
+ algorithm, (like COLAMD), but it can also be given a set of ordering
+ constraints.
+</longdescription>
+</pkgmetadata>