summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-05 12:45:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-05 12:45:06 +0000
commit5a6fffc38db914dde52499b9aac32a1b78d558b0 (patch)
treea054fe0d50600a1074e22b1228e50256851cbcd9 /sci-libs/cbflib
parentFix tests: Do not fail if remote mounting is not supported (bug #323659) (diff)
downloadgentoo-2-5a6fffc38db914dde52499b9aac32a1b78d558b0.tar.gz
gentoo-2-5a6fffc38db914dde52499b9aac32a1b78d558b0.tar.bz2
gentoo-2-5a6fffc38db914dde52499b9aac32a1b78d558b0.zip
Small python fix
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-libs/cbflib')
-rw-r--r--sci-libs/cbflib/ChangeLog8
-rw-r--r--sci-libs/cbflib/cbflib-0.9.0-r2.ebuild (renamed from sci-libs/cbflib/cbflib-0.9.0-r1.ebuild)13
-rw-r--r--sci-libs/cbflib/files/0.9.0-python.patch10
3 files changed, 29 insertions, 2 deletions
diff --git a/sci-libs/cbflib/ChangeLog b/sci-libs/cbflib/ChangeLog
index 5703eb5ee8e0..dfdd85980649 100644
--- a/sci-libs/cbflib/ChangeLog
+++ b/sci-libs/cbflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cbflib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/ChangeLog,v 1.11 2010/07/05 11:36:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/ChangeLog,v 1.12 2010/07/05 12:45:05 jlec Exp $
+
+*cbflib-0.9.0-r2 (05 Jul 2010)
+
+ 05 Jul 2010; Justin Lecher <jlec@gentoo.org> +files/0.9.0-python.patch,
+ -cbflib-0.9.0-r1.ebuild, +cbflib-0.9.0-r2.ebuild:
+ Small python fix
*cbflib-0.9.0-r1 (05 Jul 2010)
diff --git a/sci-libs/cbflib/cbflib-0.9.0-r1.ebuild b/sci-libs/cbflib/cbflib-0.9.0-r2.ebuild
index f4c0d24d8d47..03bc8d816595 100644
--- a/sci-libs/cbflib/cbflib-0.9.0-r1.ebuild
+++ b/sci-libs/cbflib/cbflib-0.9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/cbflib-0.9.0-r1.ebuild,v 1.1 2010/07/05 11:36:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/cbflib-0.9.0-r2.ebuild,v 1.1 2010/07/05 12:45:05 jlec Exp $
EAPI="3"
@@ -10,6 +10,7 @@ RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils flag-o-matic toolchain-funcs
+PYTHON_MODNAME="pycbf.py"
MY_P1="CBFlib-${PV}"
MY_P2="CBFlib_${PV}"
@@ -35,6 +36,8 @@ S="${WORKDIR}/${MY_P1}"
src_prepare(){
rm -rf Py* drel* dRel* ply*
epatch "${FILESDIR}"/${PV}-Makefile.patch
+ edos2unix pycbf/setup.py
+ epatch "${FILESDIR}"/${PV}-python.patch
cp Makefile_LINUX_gcc42 Makefile
append-fflags -fno-range-check
@@ -83,3 +86,11 @@ src_install() {
distutils_src_install
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sci-libs/cbflib/files/0.9.0-python.patch b/sci-libs/cbflib/files/0.9.0-python.patch
new file mode 100644
index 000000000000..972c252bd861
--- /dev/null
+++ b/sci-libs/cbflib/files/0.9.0-python.patch
@@ -0,0 +1,10 @@
+diff --git a/pycbf/setup.py b/pycbf/setup.py
+index 0763f06..f55a42f 100644
+--- a/pycbf/setup.py
++++ b/pycbf/setup.py
+@@ -14,4 +14,4 @@ e = Extension('_pycbf',
+ include_dirs = ["../include"] )
+
+ # Build it
+-setup(name="_pycbf",ext_modules=[e],)
++setup(name="_pycbf",ext_modules=[e],py_modules=["pycbf"],)