summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-06-20 09:30:27 +0000
committerSlawek Lis <slis@gentoo.org>2014-06-20 09:30:27 +0000
commitb38ce4f6ced16ff1a263169e03dbff6050206200 (patch)
treea64d5509250b42ae36ff3c80897b197cb23c65b5 /sci-libs/Shapely
parentFixed 513950 (diff)
downloadgentoo-2-b38ce4f6ced16ff1a263169e03dbff6050206200.tar.gz
gentoo-2-b38ce4f6ced16ff1a263169e03dbff6050206200.tar.bz2
gentoo-2-b38ce4f6ced16ff1a263169e03dbff6050206200.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/ChangeLog7
-rw-r--r--sci-libs/Shapely/Shapely-1.3.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-libs/Shapely/ChangeLog b/sci-libs/Shapely/ChangeLog
index 7a93ec212f5e..7bf26da22241 100644
--- a/sci-libs/Shapely/ChangeLog
+++ b/sci-libs/Shapely/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/Shapely
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.2 2014/06/20 09:29:34 slis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.3 2014/06/20 09:30:27 slis Exp $
+
+*Shapely-1.3.2 (20 Jun 2014)
+
+ 20 Jun 2014; Sławek Lis <slis@gentoo.org> +Shapely-1.3.2.ebuild:
+ Version bump
20 Jun 2014; Sławek Lis <slis@gentoo.org> +files/setup_unicode.patch,
Shapely-1.3.0.ebuild:
diff --git a/sci-libs/Shapely/Shapely-1.3.2.ebuild b/sci-libs/Shapely/Shapely-1.3.2.ebuild
new file mode 100644
index 000000000000..e2eb044a3f0e
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.2.ebuild,v 1.1 2014/06/20 09:30:27 slis Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ epatch "${FILESDIR}/setup_unicode.patch"
+}
+
+python_test() {
+ esetup.py test
+}