summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-08 12:53:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-08 12:53:15 +0000
commit0501eb2dc0085461812779cdeeccfd483f9329ce (patch)
tree0bd14d12acb1917de8d12d005ba8938ae96723af /sci-libs/Shapely
parentsci-libs/Fiona: Fix SLOTs and dependencies (diff)
downloadgentoo-2-0501eb2dc0085461812779cdeeccfd483f9329ce.tar.gz
gentoo-2-0501eb2dc0085461812779cdeeccfd483f9329ce.tar.bz2
gentoo-2-0501eb2dc0085461812779cdeeccfd483f9329ce.zip
sci-libs/Shapely: Drop obsolete python ABIs
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/ChangeLog8
-rw-r--r--sci-libs/Shapely/Shapely-1.3.0.ebuild20
-rw-r--r--sci-libs/Shapely/Shapely-1.3.2.ebuild16
-rw-r--r--sci-libs/Shapely/Shapely-9999.ebuild23
4 files changed, 27 insertions, 40 deletions
diff --git a/sci-libs/Shapely/ChangeLog b/sci-libs/Shapely/ChangeLog
index 96135078f37f..ec065f7a331b 100644
--- a/sci-libs/Shapely/ChangeLog
+++ b/sci-libs/Shapely/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/Shapely
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.4 2014/11/28 14:55:57 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.5 2015/01/08 12:53:15 jlec Exp $
+
+ 08 Jan 2015; Justin Lecher <jlec@gentoo.org> Shapely-1.3.0.ebuild,
+ Shapely-1.3.2.ebuild, Shapely-9999.ebuild:
+ Drop obsolete python ABIs
28 Nov 2014; Pacho Ramos <pacho@gentoo.org> Shapely-1.3.2.ebuild,
Shapely-9999.ebuild:
diff --git a/sci-libs/Shapely/Shapely-1.3.0.ebuild b/sci-libs/Shapely/Shapely-1.3.0.ebuild
index 6f3eb5bd6350..ef950a23dead 100644
--- a/sci-libs/Shapely/Shapely-1.3.0.ebuild
+++ b/sci-libs/Shapely/Shapely-1.3.0.ebuild
@@ -1,26 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.2 2014/06/20 09:29:34 slis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.3 2015/01/08 12:53:15 jlec Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.python.org/pypi/Shapely"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND=">=sci-libs/geos-3.1"
@@ -29,7 +23,7 @@ DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
src_prepare() {
- epatch "${FILESDIR}/setup_unicode.patch"
+ epatch "${FILESDIR}"/setup_unicode.patch
}
python_test() {
diff --git a/sci-libs/Shapely/Shapely-1.3.2.ebuild b/sci-libs/Shapely/Shapely-1.3.2.ebuild
index daba7d0480de..bf9abdc46512 100644
--- a/sci-libs/Shapely/Shapely-1.3.2.ebuild
+++ b/sci-libs/Shapely/Shapely-1.3.2.ebuild
@@ -1,26 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.2.ebuild,v 1.2 2014/11/28 14:55:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.2.ebuild,v 1.3 2015/01/08 12:53:15 jlec Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.python.org/pypi/Shapely"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
-else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
LICENSE="BSD"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND=">=sci-libs/geos-3.1"
diff --git a/sci-libs/Shapely/Shapely-9999.ebuild b/sci-libs/Shapely/Shapely-9999.ebuild
index 77199b85b37d..b9cbee9a338d 100644
--- a/sci-libs/Shapely/Shapely-9999.ebuild
+++ b/sci-libs/Shapely/Shapely-9999.ebuild
@@ -1,26 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-9999.ebuild,v 1.2 2014/11/28 14:55:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-9999.ebuild,v 1.3 2015/01/08 12:53:15 jlec Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3,3_4} )
-inherit distutils-r1
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 git-r3
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.python.org/pypi/Shapely"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
LICENSE="BSD"
SLOT="0"
+KEYWORDS=""
IUSE="test"
RDEPEND=">=sci-libs/geos-3.1"
@@ -30,4 +25,4 @@ DEPEND="${RDEPEND}
python_test() {
esetup.py test
-} \ No newline at end of file
+}