summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-28 07:40:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-28 07:40:15 +0000
commitb40fc342e265ac4324cc2306eed7e500c0734a47 (patch)
treeeb2e83d9b84d5794566dceed374a977ceed553cf /sci-geosciences
parentautotools.eclass no longer supports re-inheriting so we need to override AUTO... (diff)
downloadgentoo-2-b40fc342e265ac4324cc2306eed7e500c0734a47.tar.gz
gentoo-2-b40fc342e265ac4324cc2306eed7e500c0734a47.tar.bz2
gentoo-2-b40fc342e265ac4324cc2306eed7e500c0734a47.zip
Fix wxwidgets handling, thanks to papillon81
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog5
-rw-r--r--sci-geosciences/grass/grass-6.4.2.ebuild38
2 files changed, 24 insertions, 19 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 91eb5e99f139..357d5beb8fd4 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.114 2012/05/24 19:33:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.115 2012/05/28 07:40:15 scarabeus Exp $
+
+ 28 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> grass-6.4.2.ebuild:
+ Fix wxwidgets handling, thanks to papillon81
24 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> grass-6.4.2.ebuild:
Whitespace to shutup repoman.
diff --git a/sci-geosciences/grass/grass-6.4.2.ebuild b/sci-geosciences/grass/grass-6.4.2.ebuild
index 1b7d6e285395..c88551b7902c 100644
--- a/sci-geosciences/grass/grass-6.4.2.ebuild
+++ b/sci-geosciences/grass/grass-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.2.ebuild,v 1.2 2012/05/24 19:33:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.2.ebuild,v 1.3 2012/05/28 07:40:15 scarabeus Exp $
EAPI=4
@@ -147,28 +147,30 @@ src_configure() {
use opengl && myconf+=" --with-tcltk"
use motif && use opengl && myconf+=" --with-glw"
use motif || myconf+=" --without-glw"
+
+ if use wxwidgets; then
+ WX_BUILD=yes
+ WX_GTK_VER=2.8
+ need-wxwidgets unicode
+ myconf+="
+ --without-tcltk
+ --with-wxwidgets=${WX_CONFIG}
+ "
+ else
+ WX_BUILD=no
+ # use tcl gui if wxwidgets are disabled
+ myconf+="
+ --with-tcltk
+ --without-wxwidgets
+ "
+ fi
else
myconf+="
- --without-opengl
--without-glw
- --without-x
- "
- fi
-
- if use wxwidgets; then
- WX_BUILD=yes
- WX_GTK_VER=2.8
- need-wxwidgets unicode
- myconf+="
+ --without-opengl
--without-tcltk
- --with-wxwidgets=${WX_CONFIG}
- "
- else
- WX_BUILD=no
- # use tcl gui if wxwidgets are disabled
- myconf+="
- --with-tcltk
--without-wxwidgets
+ --without-x
"
fi