summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-05-16 23:07:07 +0000
committerVlastimil Babka <caster@gentoo.org>2010-05-16 23:07:07 +0000
commit001cf3b0d4d4098093284a5ec5deb3cbf98a19e6 (patch)
tree341896c424ce94d18cc7b0ed47275b6c243c57a6 /sci-geosciences
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-001cf3b0d4d4098093284a5ec5deb3cbf98a19e6.tar.gz
gentoo-2-001cf3b0d4d4098093284a5ec5deb3cbf98a19e6.tar.bz2
gentoo-2-001cf3b0d4d4098093284a5ec5deb3cbf98a19e6.zip
Version bump, bug #320065. Progress on lib unbundling thanks to tommy, bug #212373.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/googleearth/ChangeLog9
-rw-r--r--sci-geosciences/googleearth/googleearth-5.1.3535.3218.ebuild141
2 files changed, 149 insertions, 1 deletions
diff --git a/sci-geosciences/googleearth/ChangeLog b/sci-geosciences/googleearth/ChangeLog
index 59d554550495..6b95e36c338c 100644
--- a/sci-geosciences/googleearth/ChangeLog
+++ b/sci-geosciences/googleearth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/googleearth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/ChangeLog,v 1.3 2010/04/26 19:06:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/ChangeLog,v 1.4 2010/05/16 23:07:07 caster Exp $
+
+*googleearth-5.1.3535.3218 (16 May 2010)
+
+ 16 May 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3535.3218.ebuild:
+ Version bump, bug #320065. Progress on lib unbundling thanks to tommy, bug
+ #212373.
26 Apr 2010; Markus Meier <maekke@gentoo.org>
googleearth-5.1.3533.1731-r1.ebuild:
diff --git a/sci-geosciences/googleearth/googleearth-5.1.3535.3218.ebuild b/sci-geosciences/googleearth/googleearth-5.1.3535.3218.ebuild
new file mode 100644
index 000000000000..59bc32aa44fe
--- /dev/null
+++ b/sci-geosciences/googleearth/googleearth-5.1.3535.3218.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.1.3535.3218.ebuild,v 1.1 2010/05/16 23:07:07 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
+ -> GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth MIT SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE="qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+S="${WORKDIR}"
+
+QA_TEXTRELS="opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/libevll.so
+opt/googleearth/librender.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libflightsim.so
+opt/googleearth/libcollada.so
+opt/googleearth/libminizip.so
+opt/googleearth/libauth.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libmeasure.so
+opt/googleearth/libgoogleearth_lib.so
+opt/googleearth/libmoduleframework.so
+"
+
+QA_DT_HASH="opt/${PN}/.*"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_prepare() {
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" postinstall.sh
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml || die
+ domenu Google-${PN}.desktop || die
+ doicon ${PN}-icon.png || die
+ dodoc README.linux || die
+
+ cd bin
+ tar xf "${WORKDIR}"/${PN}-linux-x86.tar || die
+ # bug #262780
+ epatch "${FILESDIR}/decimal-separator.patch"
+ exeinto /opt/${PN}
+ doexe * || die
+
+ cd "${D}"/opt/${PN}
+ tar xf "${WORKDIR}"/${PN}-data.tar || die
+
+ if ! use qt-bundled; then
+ rm -rvf libQt{Core,Gui,Network,WebKit}.so.4 plugins/imageformats qt.conf || die
+ fi
+ rm -rvf libGLU.so.1 libcurl.so.4
+ if use amd64; then
+ # provided by emul-baselibs for amd64
+ # on x86 need to sort out collision between mDNSresponder and nss-mdns first
+ rm -rvf libnss_mdns4_minimal.so.2 || die
+ fi
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -rvf libgdal.so.1 || die
+ fi
+
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}