summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-12-01 18:35:03 +0000
committerHanno Böck <hanno@gentoo.org>2008-12-01 18:35:03 +0000
commit8eea0838d1b42f20bbaa3e67e9b8ce409c31fbd1 (patch)
tree125fbf4a9d41ff78e9c6a6653fee62120e39c202 /sci-geosciences/gpscorrelate
parentUnmask rar-3.8.0 and above since it's a native 64bit binary. (diff)
downloadgentoo-2-8eea0838d1b42f20bbaa3e67e9b8ce409c31fbd1.tar.gz
gentoo-2-8eea0838d1b42f20bbaa3e67e9b8ce409c31fbd1.tar.bz2
gentoo-2-8eea0838d1b42f20bbaa3e67e9b8ce409c31fbd1.zip
gpscorrelate bump and makefile improvements
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'sci-geosciences/gpscorrelate')
-rw-r--r--sci-geosciences/gpscorrelate/ChangeLog9
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.5.8-makefile.diff35
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild42
3 files changed, 85 insertions, 1 deletions
diff --git a/sci-geosciences/gpscorrelate/ChangeLog b/sci-geosciences/gpscorrelate/ChangeLog
index 367c1cd202f5..353d172e443f 100644
--- a/sci-geosciences/gpscorrelate/ChangeLog
+++ b/sci-geosciences/gpscorrelate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/gpscorrelate
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/ChangeLog,v 1.3 2008/08/23 18:13:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/ChangeLog,v 1.4 2008/12/01 18:35:02 hanno Exp $
+
+*gpscorrelate-1.5.8 (01 Dec 2008)
+
+ 01 Dec 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/gpscorrelate-1.5.8-makefile.diff, +gpscorrelate-1.5.8.ebuild:
+ Version bump, much improved Makefile (respect LDFLAGS, build without gtk+,
+ fix --as-needed).
23 Aug 2008; Markus Meier <maekke@gentoo.org> gpscorrelate-1.5.6.ebuild:
add ~amd64, bug #224325
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.5.8-makefile.diff b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.5.8-makefile.diff
new file mode 100644
index 000000000000..a3952bd348d6
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.5.8-makefile.diff
@@ -0,0 +1,35 @@
+--- gpscorrelate-1.5.8/Makefile 2008-10-31 12:50:39.000000000 +0100
++++ gpscorrelate-1.5.8-1/Makefile 2008-12-01 19:19:12.000000000 +0100
+@@ -5,9 +5,10 @@
+ COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o
+ GOBJS = main-gui.o gui.o unixtime.o gpx-read.o correlate.o exif-gps.o
+ CFLAGS = -Wall
+-override CFLAGS += $(shell pkg-config --cflags libxml-2.0 gtk+-2.0) -I/usr/include/exiv2
++override CFLAGS += $(shell pkg-config --cflags libxml-2.0) $(shell pkg-config --cflags gtk+-2.0) -I/usr/include/exiv2
+ OFLAGS = -Wall
+ override OFLAGS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
++OFLAGS_GUI = $(shell pkg-config --libs gtk+-2.0)
+ prefix = /usr/local
+ bindir = $(prefix)/bin
+ mandir = $(prefix)/share/man
+@@ -17,16 +18,16 @@
+ all: gpscorrelate gpscorrelate-gui gpscorrelate.1
+
+ gpscorrelate: $(COBJS)
+- gcc $(OFLAGS) -o $@ $(COBJS)
++ $(CC) -o $@ $(COBJS) $(OFLAGS) $(LDFLAGS)
+
+ gpscorrelate-gui: $(GOBJS)
+- gcc $(OFLAGS) -o $@ $(GOBJS)
++ $(CC) -o $@ $(GOBJS) $(OFLAGS) $(OFLAGS_GUI) $(LDFLAGS)
+
+ .c.o:
+- gcc $(CFLAGS) -c -o $*.o $<
++ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ .cpp.o:
+- g++ $(CFLAGS) -c -o $*.o $<
++ $(CXX) $(CFLAGS) -c -o $*.o $<
+
+ clean:
+ rm -f *.o gpscorrelate{,.exe} gpscorrelate-gui{,.exe}
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild
new file mode 100644
index 000000000000..394312697cbd
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild,v 1.1 2008/12/01 18:35:02 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
+HOMEPAGE="http://freefoote.dview.net/linux_gpscorr.html"
+SRC_URI="http://freefoote.dview.net/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc gtk"
+DEPEND="dev-libs/libxml2
+ media-gfx/exiv2
+ gtk? ( >=x11-libs/gtk+-2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.diff"
+}
+
+src_compile() {
+ emake gpscorrelate gpscorrelate.1 || die
+ if use gtk; then
+ emake gpscorrelate-gui || die
+ fi
+}
+
+src_install() {
+ dobin gpscorrelate
+ if use gtk; then
+ dobin gpscorrelate-gui
+ make_desktop_entry gpscorrelate-gui GPSCorrelate "" "Photography;Graphics;Geography;"
+ fi
+ if use doc; then
+ dohtml doc/* || die
+ fi
+ doman gpscorrelate.1 || die
+}