summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-22 11:28:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-22 11:28:39 +0000
commitdb273fb17fc8f9ca3c8b0792a57de11fab94ce2d (patch)
treedca804203018dfda2461e06e6e7f8d97c00aae45 /sci-geosciences/gdal-grass
parentppc64 stable wrt #369897 (diff)
downloadgentoo-2-db273fb17fc8f9ca3c8b0792a57de11fab94ce2d.tar.gz
gentoo-2-db273fb17fc8f9ca3c8b0792a57de11fab94ce2d.tar.bz2
gentoo-2-db273fb17fc8f9ca3c8b0792a57de11fab94ce2d.zip
Stabilise revison-bumped gdal-grass that works with grass-6.4. Punt older. This actualy makes stable compile again.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gdal-grass')
-rw-r--r--sci-geosciences/gdal-grass/ChangeLog9
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild21
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild42
3 files changed, 20 insertions, 52 deletions
diff --git a/sci-geosciences/gdal-grass/ChangeLog b/sci-geosciences/gdal-grass/ChangeLog
index e1c93f3e6044..d0c5da98b4b0 100644
--- a/sci-geosciences/gdal-grass/ChangeLog
+++ b/sci-geosciences/gdal-grass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gdal-grass
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/ChangeLog,v 1.5 2010/06/13 09:20:01 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/ChangeLog,v 1.6 2011/07/22 11:28:38 scarabeus Exp $
+
+ 22 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -gdal-grass-1.4.3.ebuild, gdal-grass-1.4.3-r1.ebuild:
+ Stabilise revison-bumped gdal-grass that works with grass-6.4. Punt older.
+ This actualy makes stable compile again.
*gdal-grass-1.4.3-r1 (13 Jun 2010)
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
index 78c8150e3f12..01980fb9d6af 100644
--- a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
+++ b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild,v 1.1 2010/06/13 09:20:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild,v 1.2 2011/07/22 11:28:38 scarabeus Exp $
+
+EAPI=4
-EAPI=2
inherit eutils
DESCRIPTION="GDAL plugin to access GRASS data"
@@ -11,12 +12,14 @@ SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="sci-libs/gdal
- >=sci-geosciences/grass-6.4.0_rc6"
+RDEPEND="
+ sci-libs/gdal
+ >=sci-geosciences/grass-6.4.0_rc6
+"
DEPEND="${RDEPEND}"
src_prepare() {
@@ -24,7 +27,9 @@ src_prepare() {
}
src_configure() {
- econf --with-grass=$(pkg-config grass --variable grassdir) --with-gdal
+ econf \
+ --with-grass=$(pkg-config grass --variable grassdir) \
+ --with-gdal
}
src_install() {
@@ -32,5 +37,5 @@ src_install() {
emake DESTDIR="${D}" \
GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
- install || die "emake install failure"
+ install
}
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild
deleted file mode 100644
index 40b52bc015dc..000000000000
--- a/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild,v 1.5 2010/06/13 09:20:01 scarabeus Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="GDAL plugin to access GRASS data"
-HOMEPAGE="http://www.gdal.org/"
-SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-
-IUSE=""
-
-RDEPEND="sci-libs/gdal
- <sci-geosciences/grass-6.4.0_rc6"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-makefile.patch"
-}
-
-src_configure() {
- GRASS_ENVD="/etc/env.d/99grass /etc/env.d/99grass-6 /etc/env.d/99grass-cvs";
- for file in ${GRASS_ENVD}; do
- if test -r ${file}; then
- GRASSPATH=$(sed -n 's/LDPATH="\(.*\)\/lib"$/\1/p' ${file});
- fi
- done
- econf --with-grass=${GRASSPATH} --with-gdal
-}
-
-src_install() {
- #pass the right variables to 'make install' to prevent a sandbox access violation
- emake DESTDIR="${D}" \
- GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
- AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
- install || die "emake install failure"
-}