summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-06-14 07:02:49 +0000
committerMike Frysinger <vapier@gentoo.org>2014-06-14 07:02:49 +0000
commitf8f6265d60c3447d53f7aeaf1129757889c8a8f1 (patch)
tree265e6712c22f9a17bd00141b63ec00f4c9eb21cb /sci-electronics
parentAdjust python-dateutil deps to require Python 2.7 support for bug #399511. (diff)
downloadgentoo-2-f8f6265d60c3447d53f7aeaf1129757889c8a8f1.tar.gz
gentoo-2-f8f6265d60c3447d53f7aeaf1129757889c8a8f1.tar.bz2
gentoo-2-f8f6265d60c3447d53f7aeaf1129757889c8a8f1.zip
Initial ebuild based on work by Christopher Friedt & Cody Schafer #426586.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/pulseview/ChangeLog10
-rw-r--r--sci-electronics/pulseview/metadata.xml8
-rw-r--r--sci-electronics/pulseview/pulseview-0.2.0.ebuild46
-rw-r--r--sci-electronics/pulseview/pulseview-9999.ebuild46
4 files changed, 110 insertions, 0 deletions
diff --git a/sci-electronics/pulseview/ChangeLog b/sci-electronics/pulseview/ChangeLog
new file mode 100644
index 000000000000..5ec5eb849477
--- /dev/null
+++ b/sci-electronics/pulseview/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-electronics/pulseview
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pulseview/ChangeLog,v 1.1 2014/06/14 07:02:49 vapier Exp $
+
+*pulseview-9999 (14 Jun 2014)
+*pulseview-0.2.0 (14 Jun 2014)
+
+ 14 Jun 2014; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +pulseview-0.2.0.ebuild, +pulseview-9999.ebuild:
+ Initial ebuild based on work by Christopher Friedt & Cody Schafer #426586.
diff --git a/sci-electronics/pulseview/metadata.xml b/sci-electronics/pulseview/metadata.xml
new file mode 100644
index 000000000000..9ec6e5e675dc
--- /dev/null
+++ b/sci-electronics/pulseview/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<use>
+ <flag name='decode'>Enable decoding of protocols while capturing</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-electronics/pulseview/pulseview-0.2.0.ebuild b/sci-electronics/pulseview/pulseview-0.2.0.ebuild
new file mode 100644
index 000000000000..92ca679898b3
--- /dev/null
+++ b/sci-electronics/pulseview/pulseview-0.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pulseview/pulseview-0.2.0.ebuild,v 1.1 2014/06/14 07:02:49 vapier Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{2,3,4} )
+inherit eutils cmake-utils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Qt based logic analyzer GUI for sigrok"
+HOMEPAGE="http://sigrok.org/wiki/PulseView"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+decode static"
+REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.28.0
+ >=sci-libs/libsigrok-0.3.0
+ dev-qt/qtgui:4
+ >=dev-libs/boost-1.42
+ decode? (
+ >=sci-libs/libsigrokdecode-0.3.0
+ ${PYTHON_DEPS}
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( HACKING NEWS README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_WERROR=TRUE
+ $(cmake-utils_use_enable decode DECODE)
+ $(cmake-utils_use_enable static STATIC_PKGDEPS_LIBS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-electronics/pulseview/pulseview-9999.ebuild b/sci-electronics/pulseview/pulseview-9999.ebuild
new file mode 100644
index 000000000000..8c87c3bb3925
--- /dev/null
+++ b/sci-electronics/pulseview/pulseview-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pulseview/pulseview-9999.ebuild,v 1.1 2014/06/14 07:02:49 vapier Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{2,3,4} )
+inherit eutils cmake-utils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Qt based logic analyzer GUI for sigrok"
+HOMEPAGE="http://sigrok.org/wiki/PulseView"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+decode static"
+REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.28.0
+ >=sci-libs/libsigrok-0.3.0
+ dev-qt/qtgui:4
+ >=dev-libs/boost-1.42
+ decode? (
+ >=sci-libs/libsigrokdecode-0.3.0
+ ${PYTHON_DEPS}
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( HACKING NEWS README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_WERROR=TRUE
+ $(cmake-utils_use_enable decode DECODE)
+ $(cmake-utils_use_enable static STATIC_PKGDEPS_LIBS)
+ )
+ cmake-utils_src_configure
+}