summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2006-09-12 05:41:00 +0000
committerDenis Dupeyron <calchan@gentoo.org>2006-09-12 05:41:00 +0000
commite4ef0964326e030c86dbf2daf20f63613800f576 (patch)
treea6555dcd8bb7a6a78da8ab5df2dc7298e9153433 /sci-electronics
parentSome tweaks for compiling (diff)
downloadgentoo-2-e4ef0964326e030c86dbf2daf20f63613800f576.tar.gz
gentoo-2-e4ef0964326e030c86dbf2daf20f63613800f576.tar.bz2
gentoo-2-e4ef0964326e030c86dbf2daf20f63613800f576.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog7
-rw-r--r--sci-electronics/kicad/files/digest-kicad-200608286
-rw-r--r--sci-electronics/kicad/kicad-20060828.ebuild101
3 files changed, 113 insertions, 1 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 598910592dce..0898e975751a 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.10 2006/07/07 17:24:52 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.11 2006/09/12 05:41:00 calchan Exp $
+
+*kicad-20060828 (12 Sep 2006)
+
+ 12 Sep 2006; Denis Dupeyron <calchan@gentoo.org> +kicad-20060828.ebuild:
+ Version bump.
07 Jul 2006; Denis Dupeyron <calchan@gentoo.org> kicad-20060328.ebuild,
kicad-20060424.ebuild, kicad-20060626.ebuild:
diff --git a/sci-electronics/kicad/files/digest-kicad-20060828 b/sci-electronics/kicad/files/digest-kicad-20060828
new file mode 100644
index 000000000000..e886477acf3d
--- /dev/null
+++ b/sci-electronics/kicad/files/digest-kicad-20060828
@@ -0,0 +1,6 @@
+MD5 6d27571755e6321d6a117f7e040999ff kicad-2006-08-28.tgz 58438630
+RMD160 7e14ca52b0fd71385b24bb98f02c30cb488b8c85 kicad-2006-08-28.tgz 58438630
+SHA256 a7a7197bae9a78bf4af1e5ef40152057b27a605403791c101a8684ea766fd637 kicad-2006-08-28.tgz 58438630
+MD5 194f6f214ede60d44eeb83881700bae8 kicad-20060828.tar.bz2 11314983
+RMD160 183eefd26e6ceb0623a314a2348e08e7c1470bd6 kicad-20060828.tar.bz2 11314983
+SHA256 d2d203c77f18c60d98f3d19150bce9ceba41810c147c3d59d820d4d683ca5ef1 kicad-20060828.tar.bz2 11314983
diff --git a/sci-electronics/kicad/kicad-20060828.ebuild b/sci-electronics/kicad/kicad-20060828.ebuild
new file mode 100644
index 000000000000..b0f69dcb6af6
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20060828.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060828.ebuild,v 1.1 2006/09/12 05:41:00 calchan Exp $
+
+inherit wxwidgets
+
+UPSTREAM_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+DESCRIPTION="Electronic schematic and PCB design tools."
+HOMEPAGE="http://www.lis.inpg.fr/realise_au_lis/kicad/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ !minimal? ( ftp://iut-tice.ujf-grenoble.fr/cao/${PN}-${UPSTREAM_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="unicode doc examples minimal"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ media-gfx/wings"
+
+pkg_setup() {
+ # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
+ WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+
+ # Check for proper wxGTK USE flags.
+ if use unicode; then
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
+ else
+ need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
+ fi
+ built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+
+ # Use the chosen wx-config executable
+ sed -i -e "s:wx-config:${WX_CONFIG}:" libs.* || die "sed failed"
+ sed -i -e "s:wx-config:${WX_CONFIG}:" */makefile.* || die "sed failed"
+}
+
+src_compile() {
+ # Build the main executables
+ emake -f makefile.gtk || die "make failed (main)"
+
+ # Minizip needs to be built independently
+ cd kicad/minizip
+ emake -f makefile.unx || die "make failed (minizip)"
+}
+
+src_install() {
+ # kicad doesn't use the autotools yet
+ exeinto /usr/lib/${PN}/linux
+ doexe eeschema/eeschema
+ doexe pcbnew/pcbnew
+ doexe cvpcb/cvpcb
+ doexe kicad/kicad
+ doexe kicad/minizip/minizip
+ doexe gerbview/gerbview
+ exeinto /usr/lib/${PN}/linux/plugins
+ doexe eeschema/plugins/netlist_form_pads-pcb
+ newicon kicad_icon.png kicad.png
+ make_wrapper kicad "/usr/lib/${PN}/linux/kicad"
+ make_desktop_entry kicad Kicad kicad.png Electronics
+
+ # kicad requires everything to be in the same place
+ cp -pPR library ${D}/usr/lib/${PN}
+ cp -pPR internat ${D}/usr/lib/${PN}
+ cp -pPR template ${D}/usr/lib/${PN}
+ cp -pPR help ${D}/usr/lib/${PN}
+ if ! use minimal ; then
+ cp -pPR ${WORKDIR}/kicad/library ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/modules ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/template ${D}/usr/lib/${PN}
+ if use doc ; then
+ cp -pPR ${WORKDIR}/kicad/help ${D}/usr/lib/${PN}
+ fi
+ if use examples ; then
+ cp -pPR ${WORKDIR}/kicad/demos ${D}/usr/lib/${PN}
+ fi
+ fi
+ dodoc author.txt copyright.txt news.txt contrib.txt version.txt
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you open old projects,"
+ ewarn "you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ else
+ elog "Please note that the PDF datasheets that can be linked to components from the default libraries"
+ elog "cannot be mirrored by Gentoo for legal reasons."
+ elog "If you want them, you need to download them yourself from :"
+ elog "${HOMEPAGE}"
+ elog "and install them manually."
+ fi
+}