summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-23 20:53:13 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-23 20:53:13 +0000
commit29cc0d75712cbd766fe09768e180b45c99b5ad55 (patch)
treeb91007203e9c23c4abeb5f5658b64c6edd3e4f32 /sci-electronics
parentadd ~arm, bug #324129 (diff)
downloadgentoo-2-29cc0d75712cbd766fe09768e180b45c99b5ad55.tar.gz
gentoo-2-29cc0d75712cbd766fe09768e180b45c99b5ad55.tar.bz2
gentoo-2-29cc0d75712cbd766fe09768e180b45c99b5ad55.zip
Import from sci overlay. Fixes bug 74201.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gspiceui/ChangeLog11
-rw-r--r--sci-electronics/gspiceui/gspiceui-0.9.99.ebuild70
-rw-r--r--sci-electronics/gspiceui/metadata.xml10
3 files changed, 91 insertions, 0 deletions
diff --git a/sci-electronics/gspiceui/ChangeLog b/sci-electronics/gspiceui/ChangeLog
new file mode 100644
index 000000000000..a41b4d400aa0
--- /dev/null
+++ b/sci-electronics/gspiceui/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-electronics/gspiceui
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/ChangeLog,v 1.1 2010/09/23 20:53:13 dilfridge Exp $
+
+*gspiceui-0.9.99 (23 Sep 2010)
+
+ 23 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +gspiceui-0.9.99.ebuild, +metadata.xml:
+ New application, fixes bug 74201 (!). Thanks to jokey, jakub, tomjbe, and
+ Rafael G. Martins.
+
diff --git a/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild b/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild
new file mode 100644
index 000000000000..c52acf1663ba
--- /dev/null
+++ b/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild,v 1.1 2010/09/23 20:53:13 dilfridge Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+inherit wxwidgets
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="GUI frontend for Ngspice and Gnucap"
+HOMEPAGE="http://www.geda.seul.org/tools/gspiceui/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples schematics waveform"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ sci-electronics/electronics-menu"
+RDEPEND="${DEPEND}
+ || ( sci-electronics/ng-spice-rework sci-electronics/gnucap )
+ waveform? ( sci-electronics/gwave )
+ schematics? ( sci-electronics/geda )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Removing pre-configured CXXFLAGS from Makefile. The Makefile then only appends
+ # the flags required for wxwidgets to the Gentoo preset.
+ sed -i \
+ -e "s:CXXFLAGS = -O -pipe:CXXFLAGS += :" \
+ src/Makefile || die "Patching src/Makefile failed"
+
+ # Adjusting the doc path at src/main/HelpTasks.cpp
+ sed -i \
+ -e "s:/share/gspiceui/html/gSpiceUI.html:/share/doc/${PF}/html/gSpiceUI.html:" \
+ src/main/HelpTasks.cpp \
+ || die "Patching src/main/HelpTasks.cpp failed"
+}
+
+src_install() {
+ dobin bin/gspiceui || die
+ dodoc ChangeLog ToDo || die
+ doman gspiceui.1 || die
+ newicon src/icons/gspiceui-48x48.xpm gspiceui.xpm || die
+
+ dohtml html/*.html html/*.jpeg || die
+
+ # installing examples and according model and symbol files
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/sch
+ doins -r sch/* || die
+ insinto /usr/share/doc/${PF}/lib
+ doins -r lib/* || die
+ fi
+
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui.xpm "Electronics"
+}
+
+pkg_postinst() {
+ if use examples ; then
+ elog "If you want to use the examples, copy from"
+ elog "/usr/share/doc/${PF} the sch and lib directory"
+ elog "side by side to your home directory to be able"
+ elog "to generate the netlists as normal user."
+ fi
+}
diff --git a/sci-electronics/gspiceui/metadata.xml b/sci-electronics/gspiceui/metadata.xml
new file mode 100644
index 000000000000..4237c33b3037
--- /dev/null
+++ b/sci-electronics/gspiceui/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer><email>dilfridge@gentoo.org</email></maintainer>
+ <use>
+ <flag name='schematics'>Use sci-electronics/geda for schematics editing</flag>
+ <flag name='waveform'>Use sci-electronics/gwave for waveform display</flag>
+ </use>
+</pkgmetadata>