summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2006-01-01 22:07:23 +0000
committerTim Yamin <plasmaroo@gentoo.org>2006-01-01 22:07:23 +0000
commit140256afe5ceb8dd86f366f04c3d6f8c9a1ff495 (patch)
tree12134d71f57a432b7bec8b01e764deb1faa97f50 /sci-electronics
parentPath fix; bug #100879. (diff)
downloadgentoo-2-140256afe5ceb8dd86f366f04c3d6f8c9a1ff495.tar.gz
gentoo-2-140256afe5ceb8dd86f366f04c3d6f8c9a1ff495.tar.bz2
gentoo-2-140256afe5ceb8dd86f366f04c3d6f8c9a1ff495.zip
Add debug and readline USE flags; bug #106496.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ng-spice-rework/ChangeLog7
-rw-r--r--sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/sci-electronics/ng-spice-rework/ChangeLog b/sci-electronics/ng-spice-rework/ChangeLog
index 29c4d33cd104..db26ef49daf7 100644
--- a/sci-electronics/ng-spice-rework/ChangeLog
+++ b/sci-electronics/ng-spice-rework/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-electronics/ng-spice-rework
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ChangeLog,v 1.9 2005/12/28 12:34:54 plasmaroo Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ChangeLog,v 1.10 2006/01/01 22:07:23 plasmaroo Exp $
+
+ 01 Jan 2006; <plasmaroo@gentoo.org> ng-spice-rework-17.ebuild:
+ Add debug and readline USE flags; bug #106496.
28 Dec 2005; <plasmaroo@gentoo.org> ng-spice-rework-17.ebuild:
Fix #116936.
diff --git a/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild b/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild
index cc62629976ec..b0abac3b6659 100644
--- a/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild
+++ b/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild,v 1.3 2005/12/28 12:34:54 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-17.ebuild,v 1.4 2006/01/01 22:07:23 plasmaroo Exp $
inherit eutils
@@ -10,17 +10,20 @@ HOMEPAGE="http://ngspice.sourceforge.net"
LICENSE="BSD GPL-2"
SLOT="0"
-IUSE=""
+IUSE="readline debug"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="virtual/libc"
+DEPEND="readline? ( >=sys-libs/readline-5.0 )"
src_compile() {
- econf || die "econf failed"
+ econf \
+ $(use_with debug) \
+ $(use_with readline) || die "econf failed"
emake || die "emake failed"
}
src_install () {
+ local infoFile
for infoFile in doc/ngspice.info*; do
echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
echo 'START-INFO-DIR-ENTRY' >> ${infoFile}