summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-06-07 05:43:47 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-06-07 05:43:47 +0000
commitf6a752270d570f31c5f58f58feff536aa820dd05 (patch)
treeba426e293fec8de0baece98313abafdec12151f7 /sci-electronics/spice
parentCopied ebuild from overlay - thanks to ABCD and reavertm for the fixes. (diff)
downloadgentoo-2-f6a752270d570f31c5f58f58feff536aa820dd05.tar.gz
gentoo-2-f6a752270d570f31c5f58f58feff536aa820dd05.tar.bz2
gentoo-2-f6a752270d570f31c5f58f58feff536aa820dd05.zip
Fixed pre-stripped files and LDFLAGS, bug #252038. Straight to stable for those arches where it is stable because it is such a minor change.
(Portage version: 2.1.6.13/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'sci-electronics/spice')
-rw-r--r--sci-electronics/spice/ChangeLog10
-rw-r--r--sci-electronics/spice/spice-3.5.5-r1.ebuild65
2 files changed, 73 insertions, 2 deletions
diff --git a/sci-electronics/spice/ChangeLog b/sci-electronics/spice/ChangeLog
index 09e210d1334c..df4f6895c86d 100644
--- a/sci-electronics/spice/ChangeLog
+++ b/sci-electronics/spice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/spice
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/ChangeLog,v 1.10 2007/04/18 07:36:35 opfer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/ChangeLog,v 1.11 2009/06/07 05:43:47 calchan Exp $
+
+*spice-3.5.5-r1 (07 Jun 2009)
+
+ 07 Jun 2009; Denis Dupeyron <calchan@gentoo.org> +spice-3.5.5-r1.ebuild:
+ Fixed pre-stripped files and LDFLAGS, bug #252038. Straight to stable for
+ those arches where it is stable because it is such a minor change.
18 Apr 2007; Christian Faulhammer <opfer@gentoo.org> spice-3.5.5.ebuild:
stable amd64, bug 174791
diff --git a/sci-electronics/spice/spice-3.5.5-r1.ebuild b/sci-electronics/spice/spice-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..6b86bdc3084f
--- /dev/null
+++ b/sci-electronics/spice/spice-3.5.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/spice-3.5.5-r1.ebuild,v 1.1 2009/06/07 05:43:47 calchan Exp $
+
+inherit eutils flag-o-matic multilib
+
+IUSE=""
+
+MY_P="spice3f5sfix"
+DESCRIPTION="general-purpose circuit simulation program"
+HOMEPAGE="http://bwrc.eecs.berkeley.edu/Classes/IcBook/SPICE/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/circuits/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="sys-libs/ncurses
+ x11-libs/libXaw"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ # spice accepts -O1 at most
+ replace-flags -O* -O1
+
+ unpack ${A}
+ cd "${S}"
+ # Avoid re-creating WORKDIR due to stupid mtime
+ touch ..
+
+ [ -z $EDITOR ] || EDITOR="vim"
+ sed -i -e "s:termcap:ncurses:g" \
+ -e "s:joe:${EDITOR}:g" \
+ -e "s:-O2 -s:${CFLAGS}:g" \
+ -e "s:-lncurses -lm -s:-lncurses -lm ${LDFLAGS}:" \
+ -e "s:SPICE_DIR)/lib:SPICE_DIR)/$(get_libdir)/spice:g" \
+ -e "s:/usr/local/spice:/usr:g" \
+ -e "s:/X11R6::" \
+ conf/linux
+ sed -i -e "s:head -1:head -n 1:" util/build
+ epatch "${FILESDIR}"/${P}-gcc-4.1.patch
+}
+
+src_compile() {
+ ./util/build linux || die "build failed"
+ obj/bin/makeidx lib/helpdir/spice.txt || die "makeidx failed"
+}
+
+src_install() {
+ # install binaries
+ dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod} || die "failed to copy binaries"
+ newbin obj/bin/help spice.help
+ dosym /usr/bin/spice3 /usr/bin/spice
+ # install runtime stuff
+ rm -f lib/make*
+ dodir /usr/$(get_libdir)/spice
+ cp -R lib/* "${D}"/usr/$(get_libdir)/spice/
+ # install docs
+ doman man/man1/*.1
+ dodoc readme readme.Linux notes/spice2
+}