summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-25 22:05:21 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-25 22:05:21 +0000
commit0e0693d8f67efb2252e186092de4f5c29673b814 (patch)
tree7d069b7492116a592f9aa83ab7eb7e94c123fddc /sci-electronics/klayout
parentAdd sys-devel/libtool to RDEPEND, bug 376085 (diff)
downloadgentoo-2-0e0693d8f67efb2252e186092de4f5c29673b814.tar.gz
gentoo-2-0e0693d8f67efb2252e186092de4f5c29673b814.tar.bz2
gentoo-2-0e0693d8f67efb2252e186092de4f5c29673b814.zip
Version bump, add missing ruby dependency (bug 369055)
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog8
-rw-r--r--sci-electronics/klayout/klayout-0.21.11.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
index 716a36699a84..6aba8ffeee19 100644
--- a/sci-electronics/klayout/ChangeLog
+++ b/sci-electronics/klayout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/klayout
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.7 2011/05/29 08:46:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.8 2011/07/25 22:05:21 dilfridge Exp $
+
+*klayout-0.21.11 (25 Jul 2011)
+
+ 25 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +klayout-0.21.11.ebuild:
+ Version bump, add missing ruby dependency (bug 369055)
29 May 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-klayout-0.21.7.ebuild:
diff --git a/sci-electronics/klayout/klayout-0.21.11.ebuild b/sci-electronics/klayout/klayout-0.21.11.ebuild
new file mode 100644
index 000000000000..65d03c0d3d8c
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.21.11.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.21.11.ebuild,v 1.1 2011/07/25 22:05:21 dilfridge Exp $
+
+EAPI=3
+
+USE_RUBY="ruby18"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=yes
+
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://www.klayout.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ruby"
+
+RDEPEND="
+ x11-libs/qt-gui:4[qt3support]
+ ruby? ( $(ruby_implementations_depend) )
+"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.21.7-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ local rbflags
+
+ if use ruby ; then
+ rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
+ fi
+
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -qtbin /usr/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 \
+ ${rbflags} || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all || die "Build failed"
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install || die "make install failed"
+
+ cd ..
+ dobin bin/klayout || die
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds || die "Installation of gds testdata failed"
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot || die "Installation of oasis testdata failed"
+
+ if use ruby; then
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby || die "Installation of ruby testdata failed"
+ fi
+}