summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 12:49:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 12:49:23 +0000
commitf1f9daec51efb94322684984ae930101091cd2fb (patch)
tree121d218829fb67a8c0a2a9844d5ce3476188a1a0 /sci-chemistry
parentDelete older ebuilds. (diff)
downloadgentoo-2-f1f9daec51efb94322684984ae930101091cd2fb.tar.gz
gentoo-2-f1f9daec51efb94322684984ae930101091cd2fb.tar.bz2
gentoo-2-f1f9daec51efb94322684984ae930101091cd2fb.zip
Prefix cleaning, keyworded for *-linux, tested by me
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/sparky/ChangeLog6
-rw-r--r--sci-chemistry/sparky/files/fix-install.patch2
-rw-r--r--sci-chemistry/sparky/sparky-3.115.ebuild7
3 files changed, 11 insertions, 4 deletions
diff --git a/sci-chemistry/sparky/ChangeLog b/sci-chemistry/sparky/ChangeLog
index 9d81c4d773b9..b9e7fc3e5864 100644
--- a/sci-chemistry/sparky/ChangeLog
+++ b/sci-chemistry/sparky/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/sparky
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.15 2010/02/26 23:10:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.16 2010/03/07 12:49:22 jlec Exp $
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> sparky-3.115.ebuild,
+ files/fix-install.patch:
+ Prefix cleaning, keyworded for *-linux, tested by me
26 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> sparky-3.115.ebuild:
python_mod_compile arguments fixed
diff --git a/sci-chemistry/sparky/files/fix-install.patch b/sci-chemistry/sparky/files/fix-install.patch
index a9d10a3f5aeb..869064a33a0b 100644
--- a/sci-chemistry/sparky/files/fix-install.patch
+++ b/sci-chemistry/sparky/files/fix-install.patch
@@ -21,7 +21,7 @@ diff -ur -x make-sparky sparky.orig/bin/sparky sparky/bin/sparky
# application resource file and print prolog file.
#
-setenv SPARKY_INSTALL $sparky_inst
-+setenv SPARKY_INSTALL /usr/lib/sparky
++setenv SPARKY_INSTALL @GENTOO_PORTAGE_EPREFIX@/usr/lib/sparky
# -----------------------------------------------------------------------------
# If Python is available start Sparky as a Python extension.
diff --git a/sci-chemistry/sparky/sparky-3.115.ebuild b/sci-chemistry/sparky/sparky-3.115.ebuild
index 81f0445d433b..17320dc90e76 100644
--- a/sci-chemistry/sparky/sparky-3.115.ebuild
+++ b/sci-chemistry/sparky/sparky-3.115.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115.ebuild,v 1.2 2010/02/26 23:10:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115.ebuild,v 1.3 2010/03/07 12:49:22 jlec Exp $
EAPI="3"
PYTHON_USE_WITH="tk"
+PYTHON_DEPEND="2"
inherit eutils flag-o-matic multilib prefix python toolchain-funcs
@@ -14,7 +15,7 @@ SRC_URI="http://www.cgl.ucsf.edu/home/sparky/distrib-${PV}/${PN}-source-${PV}.ta
LICENSE="sparky"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
RDEPEND="app-shells/tcsh"
@@ -25,6 +26,8 @@ RESTRICT="mirror"
S="${WORKDIR}/${PN}"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
TKVER=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
PYVER=$(python_get_version)
}