summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-20 14:22:03 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-20 14:22:03 +0000
commiteaef133d9d3d00a477b443ae916eb76d50fb896f (patch)
treec6ea3381e8ef62dfc7cc18691c7e719f1c978853 /sci-chemistry
parentVersion bump, closes bug #232325 by Daniel Pielmeier <daniel.pielmeier@google... (diff)
downloadgentoo-2-eaef133d9d3d00a477b443ae916eb76d50fb896f.tar.gz
gentoo-2-eaef133d9d3d00a477b443ae916eb76d50fb896f.tar.bz2
gentoo-2-eaef133d9d3d00a477b443ae916eb76d50fb896f.zip
Keyword ~x86, fix to build with gcc-4.3 and fixup build-deps.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/massxpert/ChangeLog5
-rw-r--r--sci-chemistry/massxpert/massxpert-1.7.6.ebuild78
2 files changed, 53 insertions, 30 deletions
diff --git a/sci-chemistry/massxpert/ChangeLog b/sci-chemistry/massxpert/ChangeLog
index 5c03a358da9a..39471d4772dc 100644
--- a/sci-chemistry/massxpert/ChangeLog
+++ b/sci-chemistry/massxpert/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/massxpert
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.4 2008/06/08 09:24:02 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.5 2008/07/20 14:22:03 loki_val Exp $
+
+ 20 Jul 2008; Peter Alfredsen <loki_val@gentoo.org> massxpert-1.7.6.ebuild:
+ Keyword x86, fix to build with gcc-4.3 and fixup build-deps.
08 Jun 2008; Jeff Gardner <je_fro@gentoo.org> massxpert-1.7.6.ebuild:
Change LICENSE to GPL-3
diff --git a/sci-chemistry/massxpert/massxpert-1.7.6.ebuild b/sci-chemistry/massxpert/massxpert-1.7.6.ebuild
index a0f02583c290..e5efaa448f73 100644
--- a/sci-chemistry/massxpert/massxpert-1.7.6.ebuild
+++ b/sci-chemistry/massxpert/massxpert-1.7.6.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-1.7.6.ebuild,v 1.2 2008/06/08 09:24:02 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-1.7.6.ebuild,v 1.3 2008/07/20 14:22:03 loki_val Exp $
-inherit eutils flag-o-matic cmake-utils
+EAPI=1
+
+inherit base eutils flag-o-matic cmake-utils
DESCRIPTION="A software suite to predict/analyze mass spectrometric data on (bio)polymers."
HOMEPAGE="http://massxpert.org/wiki/"
@@ -10,44 +12,62 @@ SRC_URI="http://download.tuxfamily.org/massxpert/source/${PF}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND=">=dev-util/cmake-2.4.7"
-RDEPEND=">=x11-libs/qt-4.3.3
- x11-libs/libSM
- x11-libs/libICE
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libXfixes
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libX11
- sys-libs/zlib
- media-libs/freetype
- media-libs/fontconfig
- media-libs/nas
- media-libs/libpng
- dev-libs/libxml2"
+RDEPEND="|| (
+ ( x11-libs/qt-gui:4 x11-libs/qt-svg:4 x11-libs/qt-xmlpatterns:4 x11-libs/qt-core:4 )
+ =x11-libs/qt-4.3*:4
+ )
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXfixes
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libX11
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/fontconfig
+ media-libs/nas
+ media-libs/libpng
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7"
S="${WORKDIR}/${P}"
CMAKE_IN_SOURCE_BUILD="true"
-pkg_setup() {
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
- if ! built_with_use '>=x11-libs/qt-4.3.3' accessibility ; then
- eerror "qt4 must be built with the accessibility USE flag."
- die "qt4 must be built with the accessibility USE flag.."
+pkg_setup() {
+ if has_version '=x11-libs/qt-4.3*'
+ then
+ if ! built_with_use '>x11-libs/qt-4.3' accessibility
+ then
+ eerror "qt-4 must be built with the accessibility USE flag."
+ die "qt-4 must be built with the accessibility USE flag.."
+ fi
+ else
+ if ! built_with_use '>x11-libs/qt-gui-4.4' accessibility
+ then
+ eerror "qt-gui must be built with the accessibility USE flag."
+ die "qt-gui must be built with the accessibility USE flag.."
+ fi
fi
}
src_compile() {
- sed -e "s:/lib/:/$(get_libdir)/:g" -i CMakeLists.txt || \
- die "sed failed"
+ sed -i \
+ -e "s:/lib/:/$(get_libdir)/:g" \
+ -e "s:ADD_DEFINITIONS (-Wall -Werror):ADD_DEFINITIONS (-Wall):" \
+ CMakeLists.txt || \
+ die "404. File not found while sedding."
tc-export CC CXX LD
mycmakeargs="-D__LIB=$(get_libdir)"