summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-18 18:09:45 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-18 18:09:45 +0000
commitde64c844796aeebba871a0e82849d9ed51a5b4c8 (patch)
tree6b1a94aefbd5a58add32bb6c69cc96a4e6119ea3 /sci-chemistry
parentUnmask dev-util/pkgconfig-0.25-r1. works fine here. (diff)
downloadgentoo-2-de64c844796aeebba871a0e82849d9ed51a5b4c8.tar.gz
gentoo-2-de64c844796aeebba871a0e82849d9ed51a5b4c8.tar.bz2
gentoo-2-de64c844796aeebba871a0e82849d9ed51a5b4c8.zip
Fix Assertions, thanks rei4dan for providing the patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/bkchem/ChangeLog9
-rw-r--r--sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild (renamed from sci-chemistry/bkchem/bkchem-0.14.0_pre1-r1.ebuild)13
-rw-r--r--sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch48
3 files changed, 65 insertions, 5 deletions
diff --git a/sci-chemistry/bkchem/ChangeLog b/sci-chemistry/bkchem/ChangeLog
index 5f93aeed8d31..cccfa86ecd7a 100644
--- a/sci-chemistry/bkchem/ChangeLog
+++ b/sci-chemistry/bkchem/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/bkchem
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bkchem/ChangeLog,v 1.2 2010/06/18 06:28:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bkchem/ChangeLog,v 1.3 2010/06/18 18:09:45 jlec Exp $
+
+*bkchem-0.14.0_pre1-r2 (18 Jun 2010)
+
+ 18 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.14.0_pre1-piddle-Fix-assertions.patch,
+ -bkchem-0.14.0_pre1-r1.ebuild, +bkchem-0.14.0_pre1-r2.ebuild:
+ Fix Assertions, thanks rei4dan for providing the patch
*bkchem-0.14.0_pre1-r1 (18 Jun 2010)
diff --git a/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r1.ebuild b/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild
index 17f0dd9eee70..11006df5ef71 100644
--- a/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r1.ebuild
+++ b/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r1.ebuild,v 1.1 2010/06/18 06:28:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild,v 1.1 2010/06/18 18:09:45 jlec Exp $
EAPI="3"
-PYTHON_DEPEND="2:2.5:2.5"
+PYTHON_DEPEND="2"
PYTHON_USE_WITH="tk"
-inherit distutils versionator
+inherit distutils eutils versionator
MY_P="${PN}-$(replace_version_separator 3 -)"
@@ -26,7 +26,12 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MY_P}
pkg_setup() {
- python_set_active_version 2.5
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-piddle-Fix-assertions.patch
+ distutils_src_prepare
}
src_install() {
diff --git a/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch b/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch
new file mode 100644
index 000000000000..6270e59d5320
--- /dev/null
+++ b/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch
@@ -0,0 +1,48 @@
+diff --git a/bkchem/plugins/piddle/pdfgen.py b/bkchem/plugins/piddle/pdfgen.py
+index 5213672..4c056c7 100644
+--- a/bkchem/plugins/piddle/pdfgen.py
++++ b/bkchem/plugins/piddle/pdfgen.py
+@@ -639,7 +639,7 @@ class Canvas:
+
+ #use a flate filter and Ascii Base 85 to compress
+ raw = myimage.tostring()
+- assert(len(raw) == imgwidth * imgheight, "Wrong amount of data for image")
++ assert len(raw) == imgwidth * imgheight, "Wrong amount of data for image"
+ compressed = zlib.compress(raw) #this bit is very fast...
+ encoded = pdfutils._AsciiBase85Encode(compressed) #...sadly this isn't
+
+diff --git a/bkchem/plugins/piddle/pdfutils.py b/bkchem/plugins/piddle/pdfutils.py
+index ebde677..4a7675d 100644
+--- a/bkchem/plugins/piddle/pdfutils.py
++++ b/bkchem/plugins/piddle/pdfutils.py
+@@ -27,7 +27,7 @@ def cacheImageFile(filename):
+ code.append('ID')
+ #use a flate filter and Ascii Base 85
+ raw = img.tostring()
+- assert(len(raw) == imgwidth * imgheight, "Wrong amount of data for image")
++ assert len(raw) == imgwidth * imgheight, "Wrong amount of data for image"
+ compressed = zlib.compress(raw) #this bit is very fast...
+ encoded = _AsciiBase85Encode(compressed) #...sadly this isn't
+
+diff --git a/bkchem/plugins/piddle/piddlePS.py b/bkchem/plugins/piddle/piddlePS.py
+index 4d3c327..3afa361 100644
+--- a/bkchem/plugins/piddle/piddlePS.py
++++ b/bkchem/plugins/piddle/piddlePS.py
+@@ -866,7 +866,7 @@ translate
+ # piddlePDF again
+
+ rawimage = myimage.tostring()
+- assert(len(rawimage) == imgwidth*imgheight, 'Wrong amount of data for image')
++ assert len(rawimage) == imgwidth*imgheight, 'Wrong amount of data for image'
+ #compressed = zlib.compress(rawimage) # no zlib at moment
+ hex_encoded = self._AsciiHexEncode(rawimage)
+
+@@ -957,7 +957,7 @@ translate
+ 'image'])
+ # after image operator just need to dump image dat to file as hexstring
+ rawimage = myimage.tostring()
+- assert(len(rawimage) == imwidth*imheight, 'Wrong amount of data for image')
++ assert len(rawimage) == imwidth*imheight, 'Wrong amount of data for image'
+ #compressed = zlib.compress(rawimage) # no zlib at moment
+ hex_encoded = self._AsciiHexEncode(rawimage)
+