summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-06-22 22:33:19 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-06-22 22:33:19 +0000
commitb773e4b0c91743cfcaaf8b2515f68793fb2b64ba (patch)
treedf5a4c96812a3f3317f7820a3a67006124a931d2 /sci-chemistry
parentKeyword ~ppc. (diff)
downloadgentoo-2-b773e4b0c91743cfcaaf8b2515f68793fb2b64ba.tar.gz
gentoo-2-b773e4b0c91743cfcaaf8b2515f68793fb2b64ba.tar.bz2
gentoo-2-b773e4b0c91743cfcaaf8b2515f68793fb2b64ba.zip
Add USE=new-interface to prefer gtk2, which is still experimental. Add patches to make it work with guile 1.8 and link against guile-gtk properly. Change src_install() make to emake -j1 so other MAKEOPTS get through.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/coot/ChangeLog9
-rw-r--r--sci-chemistry/coot/coot-0.3.1.ebuild24
-rw-r--r--sci-chemistry/coot/files/0.3.1-fix-compilation-with-guile-1.8.patch32
-rw-r--r--sci-chemistry/coot/files/0.3.1-link-against-guile-gtk-properly.patch15
4 files changed, 73 insertions, 7 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 283f5d0093c5..280aac46b74d 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.12 2007/05/30 22:03:44 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.13 2007/06/22 22:33:19 dberkholz Exp $
+
+ 22 Jun 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/0.3.1-link-against-guile-gtk-properly.patch,
+ +files/0.3.1-fix-compilation-with-guile-1.8.patch, coot-0.3.1.ebuild:
+ Add USE=new-interface to prefer gtk2, which is still experimental. Add
+ patches to make it work with guile 1.8 and link against guile-gtk properly.
+ Change src_install() make to emake -j1 so other MAKEOPTS get through.
30 May 2007; Donnie Berkholz <dberkholz@gentoo.org>; coot-0.3.1.ebuild:
Keyword ~ppc.
diff --git a/sci-chemistry/coot/coot-0.3.1.ebuild b/sci-chemistry/coot/coot-0.3.1.ebuild
index 4db664caf991..1611dd285c04 100644
--- a/sci-chemistry/coot/coot-0.3.1.ebuild
+++ b/sci-chemistry/coot/coot-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.3.1.ebuild,v 1.3 2007/05/30 22:03:44 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.3.1.ebuild,v 1.4 2007/06/22 22:33:19 dberkholz Exp $
inherit autotools eutils
@@ -17,10 +17,18 @@ fi
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE=""
+IUSE="new-interface"
RDEPEND=">=sci-libs/gsl-1.3
- =dev-libs/glib-1.2*
- =x11-libs/gtkglarea-1.2*
+ new-interface? (
+ >=x11-libs/gtk+-2.2
+ gnome-base/libgnomecanvas
+ =x11-libs/guile-gtk-2*
+ )
+ !new-interface? (
+ =dev-libs/glib-1.2*
+ =x11-libs/gtkglarea-1.2*
+ =x11-libs/guile-gtk-1*
+ )
x11-libs/gtkglext
virtual/glut
virtual/opengl
@@ -28,7 +36,6 @@ RDEPEND=">=sci-libs/gsl-1.3
dev-lang/python
>=x11-libs/gtk-canvas-0.1.1-r2
dev-lang/python
- x11-libs/guile-gtk
dev-scheme/guile-gui
dev-scheme/net-http
dev-scheme/goosh
@@ -42,8 +49,11 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}"/${PV}-as-needed.patch
+ epatch "${FILESDIR}"/${PV}-fix-compilation-with-guile-1.8.patch
+ epatch "${FILESDIR}"/${PV}-link-against-guile-gtk-properly.patch
# Link against single-precision fftw
sed -i \
@@ -82,6 +92,8 @@ src_compile() {
--with-ssmlib-prefix=/usr \
--with-guile=/usr \
--with-python=/usr \
+ --with-guile-gtk \
+ $(use_with new-interface gtk2) \
|| die "econf failed"
# Parallel build's broken
@@ -89,7 +101,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ emake -j1 DESTDIR="${D}" install || die "install failed"
# Install misses this
insinto /usr/share/coot/python
diff --git a/sci-chemistry/coot/files/0.3.1-fix-compilation-with-guile-1.8.patch b/sci-chemistry/coot/files/0.3.1-fix-compilation-with-guile-1.8.patch
new file mode 100644
index 000000000000..211376121c5b
--- /dev/null
+++ b/sci-chemistry/coot/files/0.3.1-fix-compilation-with-guile-1.8.patch
@@ -0,0 +1,32 @@
+Index: src/c-interface.h
+===================================================================
+--- src/c-interface.h (revision 219)
++++ src/c-interface.h (revision 220)
+@@ -57,6 +57,14 @@
+
+ */
+
++/* Francois says move this up here so that things don't get wrapped
++ twice in C-declarations inside gmp library. Hmm! */
++#ifdef __cplusplus
++#ifdef USE_GUILE
++#include <libguile.h> /* for SCM type (returned by safe_scheme_command) */
++#endif // USE_GUILE
++#endif
++
+ #ifndef BEGIN_C_DECLS
+
+ #ifdef __cplusplus
+@@ -83,12 +91,6 @@
+
+ #define COOT_SCHEME_DIR "COOT_SCHEME_DIR"
+
+-#ifdef __cplusplus
+-#ifdef USE_GUILE
+-#include <libguile.h> /* for SCM type (returned by safe_scheme_command) */
+-#endif // USE_GUILE
+-#endif
+-
+ /* ------------------------------------------------------------------------ */
+ /* File system Functions: */
+ /* ------------------------------------------------------------------------ */
diff --git a/sci-chemistry/coot/files/0.3.1-link-against-guile-gtk-properly.patch b/sci-chemistry/coot/files/0.3.1-link-against-guile-gtk-properly.patch
new file mode 100644
index 000000000000..18af14a2966e
--- /dev/null
+++ b/sci-chemistry/coot/files/0.3.1-link-against-guile-gtk-properly.patch
@@ -0,0 +1,15 @@
+diff -urN coot-0.3.1.orig/macros/guile-gtk.m4 coot-0.3.1/macros/guile-gtk.m4
+--- coot-0.3.1.orig/macros/guile-gtk.m4 2007-06-21 22:48:39.000000000 -0700
++++ coot-0.3.1/macros/guile-gtk.m4 2007-06-21 22:55:17.000000000 -0700
+@@ -47,9 +47,9 @@
+ # we have the variable coot_gtk2 in configure.in, which is either TRUE or FALSE
+ # Let's use that here. Perhaps there is a better (set by gtk macro?) variable?
+ if test $coot_gtk2 = TRUE ; then
+- GUILE_GTK_LIBS=$guile_gtk_prefix/lib/libguilegtk-2.0.la
++ GUILE_GTK_LIBS="-L$guile_gtk_prefix/lib -lguilegtk-2.0"
+ else
+- GUILE_GTK_LIBS=$guile_gtk_prefix/lib/libguilegtk-1.2.la
++ GUILE_GTK_LIBS="-L$guile_gtk_prefix/lib -lguilegtk-1.2"
+ fi
+ # do we need to set this in fact?
+ GUILE_GTK_CFLAGS="-I$guile_gtk_prefix/include"