summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 22:12:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 22:12:27 +0000
commit18f0ff1bd1f02f52321614ec9ecd265b19a534f3 (patch)
treea8a665ae41532bee8d28d4b62ad91bcd72b5356b /sci-chemistry
parentVersion bump, drop python3_2 support. (diff)
downloadgentoo-2-18f0ff1bd1f02f52321614ec9ecd265b19a534f3.tar.gz
gentoo-2-18f0ff1bd1f02f52321614ec9ecd265b19a534f3.tar.bz2
gentoo-2-18f0ff1bd1f02f52321614ec9ecd265b19a534f3.zip
Cleanup due to old EAPI; add slot operator on Perl dependency
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-perl/ChangeLog6
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.3.1.ebuild68
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild6
3 files changed, 8 insertions, 72 deletions
diff --git a/sci-chemistry/openbabel-perl/ChangeLog b/sci-chemistry/openbabel-perl/ChangeLog
index 9c01a5edcc84..9719efbf167c 100644
--- a/sci-chemistry/openbabel-perl/ChangeLog
+++ b/sci-chemistry/openbabel-perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/openbabel-perl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.11 2014/07/15 11:51:35 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.12 2014/10/25 22:12:27 dilfridge Exp $
+
+ 25 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ -openbabel-perl-2.3.1.ebuild, openbabel-perl-2.3.2.ebuild:
+ Cleanup due to old EAPI; add slot operator on Perl dependency
15 Jul 2014; Mikle Kolyada <zlogene@gentoo.org> -openbabel-perl-2.3.0.ebuild:
Cleanup due to old EAPI
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.1.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.1.ebuild
deleted file mode 100644
index b8ae965bc95d..000000000000
--- a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.1.ebuild,v 1.1 2012/03/04 10:30:40 jlec Exp $
-
-EAPI=4
-
-inherit cmake-utils eutils perl-module
-
-DESCRIPTION="Perl bindings for OpenBabel"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openbabel/openbabel-${PV}.tar.gz"
-
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="
- dev-lang/perl
- ~sci-chemistry/openbabel-${PV}"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2
- dev-util/cmake"
-
-S="${WORKDIR}/openbabel-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-makefile.patch"
-}
-
-src_configure() {
- local mycmakeargs="-DPERL_BINDINGS=ON"
- mycmakeargs="${mycmakeargs}
- -DRUN_SWIG=ON"
- cmake-utils_src_configure
-}
-
-src_compile() {
- cd "${WORKDIR}/${P}_build/scripts"
- perl-module_src_prep
- perl-module_src_compile
-}
-
-src_test() {
- cd "${WORKDIR}/${P}_build/scripts"
- emake test
-}
-
-src_install() {
- cd "${WORKDIR}/${P}_build/scripts/perl"
- perl-module_src_install
-}
-
-pkg_preinst() {
- perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
-}
-
-pkg_prerm() {
- perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- perl-module_pkg_postrm
-}
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild
index 2bd8f6ae2aea..dcf4028a9456 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild,v 1.4 2013/02/20 19:42:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.2.ebuild,v 1.5 2014/10/25 22:12:27 dilfridge Exp $
EAPI=5
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
IUSE=""
RDEPEND="
- dev-lang/perl
+ dev-lang/perl:=
~sci-chemistry/openbabel-${PV}"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.4.8