summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-29 11:51:15 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-29 11:51:15 +0000
commit0e84e9eb83326db4bb12ab2f5181f13be06e043f (patch)
tree4024ade5311d95ff5f210bc210e4faacfa7229da /sci-chemistry
parentmico-2.3.13-r5: try to find bug#343827 via extra patch upon USE=findbug (diff)
downloadgentoo-2-0e84e9eb83326db4bb12ab2f5181f13be06e043f.tar.gz
gentoo-2-0e84e9eb83326db4bb12ab2f5181f13be06e043f.tar.bz2
gentoo-2-0e84e9eb83326db4bb12ab2f5181f13be06e043f.zip
Fix blocking of refmac-5.6, EAPI bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/makecif/ChangeLog8
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6-r1.ebuild41
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6.ebuild13
-rw-r--r--sci-chemistry/makecif/metadata.xml12
4 files changed, 60 insertions, 14 deletions
diff --git a/sci-chemistry/makecif/ChangeLog b/sci-chemistry/makecif/ChangeLog
index 56774bc8f979..9367a3663243 100644
--- a/sci-chemistry/makecif/ChangeLog
+++ b/sci-chemistry/makecif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/makecif
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/ChangeLog,v 1.9 2011/06/21 16:03:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/ChangeLog,v 1.10 2011/06/29 11:51:15 jlec Exp $
+
+*makecif-5.6.6-r1 (29 Jun 2011)
+
+ 29 Jun 2011; Justin Lecher <jlec@gentoo.org> makecif-5.6.6.ebuild,
+ +makecif-5.6.6-r1.ebuild, metadata.xml:
+ Fix blocking of refmac-5.6, EAPI bump
21 Jun 2011; Justin Lecher <jlec@gentoo.org> makecif-5.6.6.ebuild:
Add dependency on virtual/fortran
diff --git a/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild b/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild
new file mode 100644
index 000000000000..1484ea658bf3
--- /dev/null
+++ b/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild,v 1.1 2011/06/29 11:51:15 jlec Exp $
+
+EAPI=4
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="PDB --> CIF convertor"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/makecif.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="ccp4"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+DEPEND="
+ !>=sci-chemistry/refmac-5.6
+ virtual/fortran"
+RDEPEND="${DEPEND}
+ sci-libs/monomer-db"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-makefile.patch
+}
+
+src_compile() {
+ emake -C src clean
+ emake \
+ -C src \
+ BLANC_FORT="$(tc-getFC) ${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc readme
+}
diff --git a/sci-chemistry/makecif/makecif-5.6.6.ebuild b/sci-chemistry/makecif/makecif-5.6.6.ebuild
index 9844ea22b7d0..2ac244edf3be 100644
--- a/sci-chemistry/makecif/makecif-5.6.6.ebuild
+++ b/sci-chemistry/makecif/makecif-5.6.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.9 2011/06/21 16:03:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.10 2011/06/29 11:51:15 jlec Exp $
-EAPI="3"
+EAPI=3
inherit eutils fortran-2 toolchain-funcs
@@ -18,11 +18,10 @@ IUSE=""
S="${WORKDIR}"/${PN}
DEPEND="
- virtual/fortran
- "
-RDEPEND="
- sci-libs/monomer-db
- !<sci-chemistry/refmac-5.5.0110-r1"
+ !>=sci-chemistry/refmac-5.6
+ virtual/fortran"
+RDEPEND="${DEPEND}
+ sci-libs/monomer-db"
src_prepare() {
epatch "${FILESDIR}"/${PV}-makefile.patch
diff --git a/sci-chemistry/makecif/metadata.xml b/sci-chemistry/makecif/metadata.xml
index fc1a45358926..993c1d1ffcda 100644
--- a/sci-chemistry/makecif/metadata.xml
+++ b/sci-chemistry/makecif/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
-PDB --> CIF convertor
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+PDB - CIF convertor
check and create correct structure description
create the list of restraints
create dictionary description of new ligands