summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-04 21:03:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-04 21:03:27 +0000
commitbfd042c116e114b374cb7cc57d177ee632c323f9 (patch)
treea8a4be295fc665ec222386124cfd4ff0d6a40b8c /sci-chemistry/scala
parentFix LICENSE (#301969). Maintenance (diff)
downloadgentoo-2-bfd042c116e114b374cb7cc57d177ee632c323f9.tar.gz
gentoo-2-bfd042c116e114b374cb7cc57d177ee632c323f9.tar.bz2
gentoo-2-bfd042c116e114b374cb7cc57d177ee632c323f9.zip
Splitted of scala programm from ccp4 package
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/scala')
-rw-r--r--sci-chemistry/scala/ChangeLog10
-rw-r--r--sci-chemistry/scala/files/Makefile.am7
-rw-r--r--sci-chemistry/scala/files/configure.ac12
-rw-r--r--sci-chemistry/scala/metadata.xml13
-rw-r--r--sci-chemistry/scala/scala-3.3.18.ebuild35
5 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/scala/ChangeLog b/sci-chemistry/scala/ChangeLog
new file mode 100644
index 000000000000..2fcb07ef714a
--- /dev/null
+++ b/sci-chemistry/scala/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/scala
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/ChangeLog,v 1.1 2010/02/04 21:03:27 jlec Exp $
+
+*scala-3.3.18 (04 Feb 2010)
+
+ 04 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +scala-3.3.18.ebuild,
+ +files/Makefile.am, +files/configure.ac, +metadata.xml:
+ scala splitted of from ccp4
+
diff --git a/sci-chemistry/scala/files/Makefile.am b/sci-chemistry/scala/files/Makefile.am
new file mode 100644
index 000000000000..b16394b8817c
--- /dev/null
+++ b/sci-chemistry/scala/files/Makefile.am
@@ -0,0 +1,7 @@
+
+LIBS = -lccp4f -llapack
+
+bin_PROGRAMS = scala
+
+scala_SOURCES = scala.f
+
diff --git a/sci-chemistry/scala/files/configure.ac b/sci-chemistry/scala/files/configure.ac
new file mode 100644
index 000000000000..bcbd7dededa2
--- /dev/null
+++ b/sci-chemistry/scala/files/configure.ac
@@ -0,0 +1,12 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(scala, https://bugs.gentoo.org/)
+AC_CONFIG_SRCDIR([scala.f])
+AM_INIT_AUTOMAKE([foreign])
+
+# Checks for programs.
+AC_PROG_FC
+AC_PROG_F77
+AC_OUTPUT([Makefile])
diff --git a/sci-chemistry/scala/metadata.xml b/sci-chemistry/scala/metadata.xml
new file mode 100644
index 000000000000..2e43eee76f25
--- /dev/null
+++ b/sci-chemistry/scala/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+This program scales together multiple observations of reflections from
+Xray difraction experiments, and merges multiple observations into an
+average intensity.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/scala/scala-3.3.18.ebuild b/sci-chemistry/scala/scala-3.3.18.ebuild
new file mode 100644
index 000000000000..909bd16663e2
--- /dev/null
+++ b/sci-chemistry/scala/scala-3.3.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/scala-3.3.18.ebuild,v 1.1 2010/02/04 21:03:27 jlec Exp $
+
+EAPI="2"
+
+inherit autotools fortran
+
+FORTRAN="gfortran ifc"
+
+DESCRIPTION="scale together multiple observations of reflections"
+HOMEPAGE="http://www.ccp4.ac.uk/dist/html/scala.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ virtual/lapack
+ !<sci-chemistry/ccp4-6.1.2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cp "${FILESDIR}"/{configure.ac,Makefile.am} "${S}"
+ eautoreconf
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc ${PN}.doc || die
+ dohtml ${PN}.html || die
+}