summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-05-02 16:52:04 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-05-02 16:52:04 +0000
commitb9c15a01e1f7b831d452f828d7d713299249a5b6 (patch)
tree1fdf87cbf0b47c02f48f968a3a1bad83615969c9 /sci-chemistry/pymol
parentx86 stable wrt #176576 (diff)
downloadgentoo-2-b9c15a01e1f7b831d452f828d7d713299249a5b6.tar.gz
gentoo-2-b9c15a01e1f7b831d452f828d7d713299249a5b6.tar.bz2
gentoo-2-b9c15a01e1f7b831d452f828d7d713299249a5b6.zip
Version bump to pymol-0.99_rc8, big thanks to hodak at ncsu.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog7
-rw-r--r--sci-chemistry/pymol/files/digest-pymol-0.99_rc80
-rw-r--r--sci-chemistry/pymol/pymol-0.99_rc8.ebuild77
3 files changed, 83 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index edf869348fe5..4c354a6d8c07 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.20 2007/02/10 03:29:43 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.21 2007/05/02 16:52:04 je_fro Exp $
+
+*pymol-0.99_rc8 (02 May 2007)
+
+ 02 May 2007; Jeff Gardner <je_fro@gentoo.org> +pymol-0.99_rc8.ebuild:
+ Version bump to pymol-0.99_rc8, big thanks to hodak at ncsu.
10 Feb 2007; Steve Dibb <beandog@gentoo.org> pymol-0.98.ebuild:
amd64 stable, bug 165712
diff --git a/sci-chemistry/pymol/files/digest-pymol-0.99_rc8 b/sci-chemistry/pymol/files/digest-pymol-0.99_rc8
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sci-chemistry/pymol/files/digest-pymol-0.99_rc8
diff --git a/sci-chemistry/pymol/pymol-0.99_rc8.ebuild b/sci-chemistry/pymol/pymol-0.99_rc8.ebuild
new file mode 100644
index 000000000000..cc6a7fcf6b10
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.99_rc8.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.99_rc8.ebuild,v 1.1 2007/05/02 16:52:04 je_fro Exp $
+
+inherit distutils eutils multilib subversion
+
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/pymol/branches/b099/pymol"
+ESVN_UPDATE_CMD="svn -r 2805 update"
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+
+LICENSE="PSF-2.2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/python
+dev-python/pmw
+dev-python/numeric
+dev-lang/tk
+media-libs/libpng
+sys-libs/zlib
+media-libs/glut"
+
+src_unpack() {
+ subversion_src_unpack
+
+ epatch "${FILESDIR}"/${P}-data-path.patch
+
+# Turn off splash screen. Please do make a project contribution
+# if you are able.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch "${FILESDIR}"/nosplash-gentoo.patch
+
+# Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py
+}
+
+src_install() {
+ python_version
+
+ distutils_src_install
+ cd "${S}"
+
+#The following three lines probably do not do their jobs and should be
+#changed
+ PYTHONPATH="${D}/usr/$(get_libdir)/site-packages" ${python} setup2.py
+
+# These environment variables should not go in the wrapper script, or else
+# it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol << EOF
+ PYMOL_PATH=/usr/$(get_libdir)/python${PYVER}/site-packages/pymol
+ PYMOL_DATA="/usr/share/pymol/data"
+ PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+# Make our own wrapper
+ cat >> "${T}"/pymol << EOF
+#!/bin/sh
+ ${python} \${PYMOL_PATH}/__init__.py \$*
+EOF
+
+ exeinto /usr/bin
+ doexe "${T}"/pymol || die "Failed to install wrapper."
+ dodoc DEVELOPERS CHANGES || die "Failed to install docs."
+
+ mv examples "${D}"/usr/share/doc/${PF}/ || die "Failed moving docs."
+
+ dodir /usr/share/pymol
+ mv test "${D}"/usr/share/pymol/ || die "Failed moving test files."
+ mv data "${D}"/usr/share/pymol/ || die "Failed moving data files."
+ mv scripts "${D}"/usr/share/pymol/ || die "Failed moving scripts."
+}