summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-07-03 00:12:04 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-07-03 00:12:04 +0000
commit24c6041272881d09be21f007455ea375e4ef05d0 (patch)
tree26b4e98c33273e2d3b249d0aa0f17f414f74bc69 /sci-chemistry/pymol/pymol-1.0-r1.ebuild
parentRemove old broken version, bug 183919 (diff)
downloadgentoo-2-24c6041272881d09be21f007455ea375e4ef05d0.tar.gz
gentoo-2-24c6041272881d09be21f007455ea375e4ef05d0.tar.bz2
gentoo-2-24c6041272881d09be21f007455ea375e4ef05d0.zip
Adding 1.0 release, changed LICENCE to pymol for the last 2 releases, and cleaned up old files and patches.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sci-chemistry/pymol/pymol-1.0-r1.ebuild')
-rw-r--r--sci-chemistry/pymol/pymol-1.0-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/pymol-1.0-r1.ebuild b/sci-chemistry/pymol/pymol-1.0-r1.ebuild
new file mode 100644
index 000000000000..97ea99a2ac28
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.0-r1.ebuild,v 1.1 2007/07/03 00:12:04 je_fro Exp $
+
+inherit distutils eutils multilib subversion
+
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/pymol/trunk/pymol"
+ESVN_UPDATE_CMD="svn -r 3010 update"
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+
+LICENSE="pymol"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/python
+dev-python/pmw
+dev-lang/tk
+media-libs/libpng
+sys-libs/zlib
+virtual/glut"
+
+src_unpack() {
+ subversion_src_unpack
+
+ epatch "${FILESDIR}"/${PF}-data-path.patch
+
+# Turn off splash screen. Please do make a project contribution
+# if you are able.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch "${FILESDIR}"/nosplash-gentoo.patch
+
+# Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py
+}
+
+src_install() {
+ python_version
+
+ distutils_src_install
+ cd "${S}"
+
+#The following three lines probably do not do their jobs and should be
+#changed
+ PYTHONPATH="${D}/usr/$(get_libdir)/site-packages" ${python} setup2.py
+
+# These environment variables should not go in the wrapper script, or else
+# it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol << EOF
+ PYMOL_PATH=/usr/$(get_libdir)/python${PYVER}/site-packages/pymol
+ PYMOL_DATA="/usr/share/pymol/data"
+ PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+# Make our own wrapper
+ cat >> "${T}"/pymol << EOF
+#!/bin/sh
+ ${python} \${PYMOL_PATH}/__init__.py \$*
+EOF
+
+ exeinto /usr/bin
+ doexe "${T}"/pymol || die "Failed to install wrapper."
+ dodoc DEVELOPERS || die "Failed to install docs."
+
+ mv examples "${D}"/usr/share/doc/${PF}/ || die "Failed moving docs."
+
+ dodir /usr/share/pymol
+ mv test "${D}"/usr/share/pymol/ || die "Failed moving test files."
+ mv data "${D}"/usr/share/pymol/ || die "Failed moving data files."
+ mv scripts "${D}"/usr/share/pymol/ || die "Failed moving scripts."
+}