summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-04-26 01:44:07 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-04-26 01:44:07 +0000
commitfc25db6421ca7f2ce883feb1d37325cd1c55279e (patch)
tree71b9e3bcc19b4be5dbd686b78cafc78b24a16b40 /sci-chemistry/platon
parentrevbump to re-add subversion support to echangelog (Bug #136048) (diff)
downloadgentoo-2-fc25db6421ca7f2ce883feb1d37325cd1c55279e.tar.gz
gentoo-2-fc25db6421ca7f2ce883feb1d37325cd1c55279e.tar.bz2
gentoo-2-fc25db6421ca7f2ce883feb1d37325cd1c55279e.zip
Version bump wrt bug #155351.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-chemistry/platon')
-rw-r--r--sci-chemistry/platon/ChangeLog7
-rw-r--r--sci-chemistry/platon/files/digest-platon-200704253
-rw-r--r--sci-chemistry/platon/platon-20060717.ebuild4
-rw-r--r--sci-chemistry/platon/platon-20070425.ebuild73
4 files changed, 84 insertions, 3 deletions
diff --git a/sci-chemistry/platon/ChangeLog b/sci-chemistry/platon/ChangeLog
index 3bcf81b7c555..0b461140c4a6 100644
--- a/sci-chemistry/platon/ChangeLog
+++ b/sci-chemistry/platon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/platon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.9 2007/04/24 08:30:13 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.10 2007/04/26 01:44:07 je_fro Exp $
+
+*platon-20070425 (26 Apr 2007)
+
+ 26 Apr 2007; Jeff Gardner <je_fro@gentoo.org> +platon-20070425.ebuild:
+ Version bump wrt bug #155351.
24 Apr 2007; Jeff Gardner <je_fro@gentoo.org>
files/digest-platon-20060717, Manifest:
diff --git a/sci-chemistry/platon/files/digest-platon-20070425 b/sci-chemistry/platon/files/digest-platon-20070425
new file mode 100644
index 000000000000..78260fe1b451
--- /dev/null
+++ b/sci-chemistry/platon/files/digest-platon-20070425
@@ -0,0 +1,3 @@
+MD5 599c1fa6493f8a073e3d84fe3e2292a5 platon-20070425.tar.gz 6818796
+RMD160 b147e41437edabe741fa0b13c4a7acc0a8ef5fc2 platon-20070425.tar.gz 6818796
+SHA256 364eece14916449a974e1c953543c4171c8b2d06b333c6b904ca76fbbb33850f platon-20070425.tar.gz 6818796
diff --git a/sci-chemistry/platon/platon-20060717.ebuild b/sci-chemistry/platon/platon-20060717.ebuild
index bb42b298befc..b737df3032ae 100644
--- a/sci-chemistry/platon/platon-20060717.ebuild
+++ b/sci-chemistry/platon/platon-20060717.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20060717.ebuild,v 1.1 2006/08/07 04:02:40 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20060717.ebuild,v 1.2 2007/04/26 01:44:07 je_fro Exp $
inherit fortran toolchain-funcs
diff --git a/sci-chemistry/platon/platon-20070425.ebuild b/sci-chemistry/platon/platon-20070425.ebuild
new file mode 100644
index 000000000000..4a600d2171eb
--- /dev/null
+++ b/sci-chemistry/platon/platon-20070425.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20070425.ebuild,v 1.1 2007/04/26 01:44:07 je_fro Exp $
+
+inherit fortran toolchain-funcs
+
+FORTRAN="g77 gfortran"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# Can't do libf2c dependent on whether <gcc-4 is selected for the build,
+# so we must always require it
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ${HOMEPAGE},"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+ einfo "If there is a digest mismatch, please file a bug"
+ einfo "at https://bugs.gentoo.org/ -- a version bump"
+ einfo "is probably required."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ local F2C
+ # Needs signal_ and system_, which g77 and libf2c provide,
+ # but gfortran does not
+ if [[ ${FORTRANC} != g77 ]]; then
+ F2C="-lf2c"
+ fi
+
+ COMMAND="$(tc-getCC) -c ${CFLAGS} xdrvr.c"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of xdrvr.c failed"
+ COMMAND="${FORTRANC} -c ${FFLAGS:- -O2} -fno-second-underscore platon.f"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of platon.f failed"
+ COMMAND="${FORTRANC} -o platon ${LDFLAGS} platon.o xdrvr.o -lX11 ${F2C}"
+ echo ${COMMAND}
+ ${COMMAND} || die "Linking failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}