summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-07 04:02:40 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-07 04:02:40 +0000
commit533728694ee513aa1ef680a62fca4bb2e9dba90a (patch)
treeceac972b089727ee108c736d1346b23a0278a8c9 /sci-chemistry/platon
parentversion bump (diff)
downloadgentoo-2-533728694ee513aa1ef680a62fca4bb2e9dba90a.tar.gz
gentoo-2-533728694ee513aa1ef680a62fca4bb2e9dba90a.tar.bz2
gentoo-2-533728694ee513aa1ef680a62fca4bb2e9dba90a.zip
(#137734) Bump.
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'sci-chemistry/platon')
-rw-r--r--sci-chemistry/platon/ChangeLog8
-rw-r--r--sci-chemistry/platon/files/digest-platon-200607173
-rw-r--r--sci-chemistry/platon/platon-20060717.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/sci-chemistry/platon/ChangeLog b/sci-chemistry/platon/ChangeLog
index f8172ff60afe..1fac06b011a2 100644
--- a/sci-chemistry/platon/ChangeLog
+++ b/sci-chemistry/platon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/platon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.5 2006/08/05 05:14:56 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.6 2006/08/07 04:02:40 dberkholz Exp $
+
+*platon-20060717 (07 Aug 2006)
+
+ 07 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +platon-20060717.ebuild:
+ (#137734) Bump.
05 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Remove myself as maintainer, anyone feel free to work on this, although I'll
diff --git a/sci-chemistry/platon/files/digest-platon-20060717 b/sci-chemistry/platon/files/digest-platon-20060717
new file mode 100644
index 000000000000..9fc9f44b0b1c
--- /dev/null
+++ b/sci-chemistry/platon/files/digest-platon-20060717
@@ -0,0 +1,3 @@
+MD5 bbf3ed9ddffbfac8901a160fd47a886c platon-20060717.tar.gz 6693503
+RMD160 22618cd9fd80f3b2b74efe40f6df19ed6e9ed71a platon-20060717.tar.gz 6693503
+SHA256 4c2ca3966f5cb66e951844682f4dc15e498f1d36923a894140f0b5f4a5d32516 platon-20060717.tar.gz 6693503
diff --git a/sci-chemistry/platon/platon-20060717.ebuild b/sci-chemistry/platon/platon-20060717.ebuild
new file mode 100644
index 000000000000..bb42b298befc
--- /dev/null
+++ b/sci-chemistry/platon/platon-20060717.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20060717.ebuild,v 1.1 2006/08/07 04:02:40 dberkholz Exp $
+
+inherit fortran toolchain-funcs
+
+FORTRAN="g77 gfortran"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# Can't do libf2c dependent on whether <gcc-4 is selected for the build,
+# so we must always require it
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ${HOMEPAGE},"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+ einfo "If there is a digest mismatch, please file a bug"
+ einfo "at https://bugs.gentoo.org/ -- a version bump"
+ einfo "is probably required."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ local F2C
+ # Needs signal_ and system_, which g77 and libf2c provide,
+ # but gfortran does not
+ if [[ ${FORTRANC} != g77 ]]; then
+ F2C="-lf2c"
+ fi
+
+ COMMAND="$(tc-getCC) -c ${CFLAGS} xdrvr.c"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of xdrvr.c failed"
+ COMMAND="${FORTRANC} -c ${FFLAGS:- -O2} -fno-second-underscore platon.f"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of platon.f failed"
+ COMMAND="${FORTRANC} -o platon ${LDFLAGS} platon.o xdrvr.o -lX11 ${F2C}"
+ echo ${COMMAND}
+ ${COMMAND} || die "Linking failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}