summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 13:45:43 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 13:45:43 +0000
commit92fbd6bce11f67c0956783c84be7b186e84cf5e4 (patch)
tree22d90213bea5b5ae0b5c97acfa846aa8e9e5c21b /sci-chemistry/pdb2pqr
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-92fbd6bce11f67c0956783c84be7b186e84cf5e4.tar.gz
gentoo-2-92fbd6bce11f67c0956783c84be7b186e84cf5e4.tar.bz2
gentoo-2-92fbd6bce11f67c0956783c84be7b186e84cf5e4.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pdb2pqr')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog6
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild10
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild8
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild9
4 files changed, 16 insertions, 17 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 41728a45d3ae..6b449d12cceb 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.29 2010/11/04 09:35:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.30 2010/12/16 13:45:43 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> pdb2pqr-1.5.0-r2.ebuild,
+ pdb2pqr-1.7.0.ebuild, pdb2pqr-1.7.0-r1.ebuild:
+ Removal of fortran.eclass, #348851
*pdb2pqr-1.7.0-r1 (04 Nov 2010)
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
index 7c0ac202a463..8bd20911af13 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.4 2010/10/15 18:56:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.5.0-r2.ebuild,v 1.5 2010/12/16 13:45:43 jlec Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit eutils fortran multilib flag-o-matic distutils python versionator
+inherit distutils eutils flag-o-matic multilib toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-2)
MY_P="${PN}-${MY_PV}"
@@ -26,9 +27,6 @@ DEPEND="
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-FORTRAN="g77 gfortran"
S="${WORKDIR}/${MY_P}"
@@ -53,7 +51,7 @@ src_configure() {
configuration() {
# Avoid automagic to numeric
NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="${FORTRANC}" \
+ F77="$(tc-getFC)" \
econf \
$(use_with opal) || \
die "econf failed"
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
index 26010325ccd9..259f9929e8bc 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild,v 1.1 2010/11/04 09:35:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild,v 1.2 2010/12/16 13:45:43 jlec Exp $
EAPI="3"
@@ -8,9 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit eutils fortran multilib flag-o-matic distutils python versionator toolchain-funcs
-
-FORTRAN="g77 gfortran"
+inherit distutils eutils flag-o-matic multilib toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-2)
MY_P="${PN}-${MY_PV}"
@@ -65,7 +63,7 @@ src_configure() {
configuration() {
# Avoid automagic to numeric
NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="${FORTRANC}" \
+ F77="$(tc-getFC)" \
econf \
--enable-propka \
--with-max-atoms=${MAXATOMS:-10000} \
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
index ec9873a2834e..f5b810fc7e1e 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.1 2010/10/14 17:53:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.2 2010/12/16 13:45:43 jlec Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit eutils fortran multilib flag-o-matic distutils python versionator
+inherit distutils eutils flag-o-matic multilib toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-2)
MY_P="${PN}-${MY_PV}"
@@ -26,9 +27,7 @@ DEPEND="
sci-chemistry/openbabel
opal? ( dev-python/zsi )"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-FORTRAN="g77 gfortran"
S="${WORKDIR}/${MY_P}"
@@ -53,7 +52,7 @@ src_configure() {
configuration() {
# Avoid automagic to numeric
NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="${FORTRANC}" \
+ F77="$(tc-getFC)" \
econf \
$(use_with opal) || \
die "econf failed"