summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-05 17:53:22 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-05 17:53:22 +0000
commitf0d2aac8a281dedd1ed81645a27df819fb7b79e2 (patch)
tree525f3b34299ff96e132f004ca82441d2863d10c8 /sci-chemistry/mopac7
parentMarked ~amd64. (diff)
downloadgentoo-2-f0d2aac8a281dedd1ed81645a27df819fb7b79e2.tar.gz
gentoo-2-f0d2aac8a281dedd1ed81645a27df819fb7b79e2.tar.bz2
gentoo-2-f0d2aac8a281dedd1ed81645a27df819fb7b79e2.zip
(#101288) Fix run_mopac7 shell script, courtesy of Mathias Weigt <m.weigt@uni-bonn.de>.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog9
-rw-r--r--sci-chemistry/mopac7/files/digest-mopac7-1.00-r11
-rw-r--r--sci-chemistry/mopac7/mopac7-1.00-r1.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index fe0d597c82dd..a3b0310e9340 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/mopac7
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.3 2005/07/10 06:01:35 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.4 2005/08/05 17:53:22 spyderous Exp $
+
+*mopac7-1.00-r1 (05 Aug 2005)
+
+ 05 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +mopac7-1.00-r1.ebuild:
+ (#101288) Fix run_mopac7 shell script, courtesy of Mathias Weigt
+ <m.weigt@uni-bonn.de>.
10 Jul 2005; Donnie Berkholz <spyderous@gentoo.org>; mopac7-1.00.ebuild:
(#98457) Parallel build broken.
diff --git a/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1 b/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1
new file mode 100644
index 000000000000..dacf853ca0d4
--- /dev/null
+++ b/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1
@@ -0,0 +1 @@
+MD5 d556f7166bcc809dd84ee93c8d874fa2 mopac7-1.00.tgz 1184447
diff --git a/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild
new file mode 100644
index 000000000000..e4f62f3e9385
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild,v 1.1 2005/08/05 17:53:22 spyderous Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-libs/libf2c
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+RDEPEND="dev-libs/libf2c"
+
+src_compile() {
+ libtoolize --copy --force
+
+ # This is absolutely required to avoid odd errors on MAIN__() not existing
+ # and to build the mopac7 binary, not just the library.
+ einfo "Adding required LDFLAGS for configure"
+ econf LDFLAGS="-Xlinker -defsym -Xlinker MAIN__=main" || die "econf failed"
+
+ # We need the appended LDFLAGS to activate building of the mopac7 binary,
+ # but they break the actual linking of it. Something's obviously broken.
+ einfo "Removing LDFLAGS, as they break the build"
+ sed -i "/^LDFLAGS/d" src/Makefile.in
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+ dobin run_mopac7 src/.libs/mopac7
+ dodoc AUTHORS README ChangeLog
+}