summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-15 22:44:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-15 22:44:29 +0000
commit8d23f3a770a6bc91640a754a5fc0cdf1070fa53d (patch)
treee3fe827dee77e3f3954f6b77519e1920cbbe6410 /sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
parentFix building on ppc64, bug #342535. Require agg for fbcon, bug #340567. (diff)
downloadgentoo-2-8d23f3a770a6bc91640a754a5fc0cdf1070fa53d.tar.gz
gentoo-2-8d23f3a770a6bc91640a754a5fc0cdf1070fa53d.tar.bz2
gentoo-2-8d23f3a770a6bc91640a754a5fc0cdf1070fa53d.zip
Fix prll compilation
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molscript/molscript-2.1.2-r1.ebuild')
-rw-r--r--sci-chemistry/molscript/molscript-2.1.2-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
index f6592f9bd59d..967ce690880d 100644
--- a/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
+++ b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild,v 1.5 2010/11/08 17:16:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild,v 1.6 2010/11/15 22:44:29 jlec Exp $
EAPI="3"
@@ -33,15 +33,17 @@ pkg_nofetch() {
}
src_prepare() {
- epatch "${FILESDIR}"/fix-makefile-shared.patch
- epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch \
+ "${FILESDIR}"/fix-makefile-shared.patch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-prll.patch
# Provide glutbitmap.h, because freeglut doesn't have it
cp "${FILESDIR}"/glutbitmap.h "${S}"/clib/
# Stop an incredibly hacky include
sed -i -e 's:<../lib/glut/glutbitmap.h>:"glutbitmap.h":g' \
- "${S}"/clib/ogl_bitmap_character.c
+ "${S}"/clib/ogl_bitmap_character.c || die
}
src_compile() {