summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-11-21 20:44:37 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-11-21 20:44:37 +0000
commit0b04380a259adbc9e245494bc4be3b4827e5deb7 (patch)
treef688fb08e15e33ded2952c1f94e93921311b818a /sci-chemistry/molscript/files
parentNew license for sci-chemistry/molscript. (diff)
downloadgentoo-2-0b04380a259adbc9e245494bc4be3b4827e5deb7.tar.gz
gentoo-2-0b04380a259adbc9e245494bc4be3b4827e5deb7.tar.bz2
gentoo-2-0b04380a259adbc9e245494bc4be3b4827e5deb7.zip
New molecular graphics package. GLUT license is for files/glutbitmap.h.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-chemistry/molscript/files')
-rw-r--r--sci-chemistry/molscript/files/digest-molscript-2.1.21
-rw-r--r--sci-chemistry/molscript/files/fix-makefile-shared.patch62
-rw-r--r--sci-chemistry/molscript/files/glutbitmap.h32
3 files changed, 95 insertions, 0 deletions
diff --git a/sci-chemistry/molscript/files/digest-molscript-2.1.2 b/sci-chemistry/molscript/files/digest-molscript-2.1.2
new file mode 100644
index 000000000000..e328ff13ef18
--- /dev/null
+++ b/sci-chemistry/molscript/files/digest-molscript-2.1.2
@@ -0,0 +1 @@
+MD5 bfd8ff54d22afe200f050829ee41e197 molscript-2.1.2.tar.gz 412497
diff --git a/sci-chemistry/molscript/files/fix-makefile-shared.patch b/sci-chemistry/molscript/files/fix-makefile-shared.patch
new file mode 100644
index 000000000000..b718b07bda5d
--- /dev/null
+++ b/sci-chemistry/molscript/files/fix-makefile-shared.patch
@@ -0,0 +1,62 @@
+diff -urN molscript-2.1.2.orig/Makefile.complete molscript-2.1.2/Makefile.complete
+--- molscript-2.1.2.orig/Makefile.complete 1998-11-25 01:04:39.000000000 -0800
++++ molscript-2.1.2/Makefile.complete 2005-11-21 12:28:06.000000000 -0800
+@@ -23,9 +23,9 @@
+
+ # OpenGL and GLUT for X (UNIX).
+ # Must be modified for Windows 95/NT. <---
+-GLUTDIR = $(FREEWAREDIR)/glut
+-GLUTLINK = $(GLUTDIR)/lib/glut/libglut.a -lGLU -lGL -lXmu -lXext -lX11
+-OPENGLFLAG = -DOPENGL_SUPPORT -I$(GLUTDIR)/include
++GLUTDIR = $(FREEWAREDIR)
++GLUTLINK = -lglut -lGLU -lGL -lXmu -lXext -lX11
++OPENGLFLAG = -DOPENGL_SUPPORT -I$(GLUTDIR)/include/GL
+ OPENGLOBJ = opengl.o
+ OPENGLCLIBOBJ = ogl_utils.o ogl_body.o ogl_bitmap_character.o
+
+@@ -35,25 +35,25 @@
+
+ # JPEG image file format; requires the JPEG library.
+ # Comment out these lines if the JPEG library is not available. <---
+-JPEGDIR = $(FREEWAREDIR)/jpeg
+-JPEGLINK = $(JPEGDIR)/libjpeg.a
+-JPEGFLAG = -DJPEG_SUPPORT -I$(JPEGDIR)
++JPEGDIR = $(FREEWAREDIR)
++JPEGLINK = -ljpeg
++JPEGFLAG = -DJPEG_SUPPORT
+ JPEGOBJ = jpeg_img.o
+
+ # PNG image file format; requires the PNG library and the zlib library.
+ # Comment out these lines if the PNG and zlib libraries are not available. <---
+-ZLIBDIR = $(FREEWAREDIR)/zlib
+-ZLIBLINK = $(ZLIBDIR)/libz.a
+-PNGDIR = $(FREEWAREDIR)/libpng
+-PNGLINK = $(PNGDIR)/libpng.a
+-PNGFLAG = -DPNG_SUPPORT -I$(PNGDIR) -I$(ZLIBDIR)
++ZLIBDIR = $(FREEWAREDIR)
++ZLIBLINK = -lz
++PNGDIR = $(FREEWAREDIR)
++PNGLINK = -lpng
++PNGFLAG = -DPNG_SUPPORT
+ PNGOBJ = png_img.o
+
+ # GIF image file format; requires the gd 1.3 library.
+ # Comment out these lines if the gd 1.3 library is not available. <---
+-GIFDIR = $(FREEWAREDIR)/gd
+-GIFLINK = $(GIFDIR)/libgd.a
+-GIFFLAG = -DGIF_SUPPORT -I$(GIFDIR)
++GIFDIR = $(FREEWAREDIR)
++GIFLINK = -lgd
++GIFFLAG = -DGIF_SUPPORT
+ GIFOBJ = gif_img.o
+
+ # SGI IRIX's C compiler.
+@@ -62,7 +62,7 @@
+ COPT = -O1
+ # Correctness flags:
+ #CCHECK = -ansi -fullwarn -g -DSELECT_DEBUG
+-CCHECK = -ansi -fullwarn
++CCHECK = -ansi -Wall
+ #CCHECK = -ansi -fullwarn -DNDEBUG
+
+ # General cc compile flags.
diff --git a/sci-chemistry/molscript/files/glutbitmap.h b/sci-chemistry/molscript/files/glutbitmap.h
new file mode 100644
index 000000000000..9584bb129daa
--- /dev/null
+++ b/sci-chemistry/molscript/files/glutbitmap.h
@@ -0,0 +1,32 @@
+#ifndef __glutbitmap_h__
+#define __glutbitmap_h__
+
+/* Copyright (c) Mark J. Kilgard, 1994, 1998. */
+
+/* This program is freely distributable without licensing fees
+ and is provided without guarantee or warrantee expressed or
+ implied. This program is -not- in the public domain. */
+
+#define GLUT_NO_LIB_PRAGMA /* Avoid auto library linking when building
+ the GLUT library itself. */
+#include <GL/glut.h>
+
+typedef struct {
+ const GLsizei width;
+ const GLsizei height;
+ const GLfloat xorig;
+ const GLfloat yorig;
+ const GLfloat advance;
+ const GLubyte *bitmap;
+} BitmapCharRec, *BitmapCharPtr;
+
+typedef struct {
+ const char *name;
+ const int num_chars;
+ const int first;
+ const BitmapCharRec * const *ch;
+} BitmapFontRec, *BitmapFontPtr;
+
+typedef void *GLUTbitmapFont;
+
+#endif /* __glutbitmap_h__ */