summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-20 04:19:43 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-20 04:19:43 +0000
commit9736725d33bb22aae67940130c30e2c7391b2e46 (patch)
tree045da6a8db048642c004ca95ae944e56f8d659a4 /sci-chemistry/maxit/maxit-8.2.ebuild
parentremove outdated skencil ebuild (diff)
downloadgentoo-2-9736725d33bb22aae67940130c30e2c7391b2e46.tar.gz
gentoo-2-9736725d33bb22aae67940130c30e2c7391b2e46.tar.bz2
gentoo-2-9736725d33bb22aae67940130c30e2c7391b2e46.zip
An application for processing and curation of macromolecular structure data.
(Portage version: 2.1_pre1)
Diffstat (limited to 'sci-chemistry/maxit/maxit-8.2.ebuild')
-rw-r--r--sci-chemistry/maxit/maxit-8.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-chemistry/maxit/maxit-8.2.ebuild b/sci-chemistry/maxit/maxit-8.2.ebuild
new file mode 100644
index 000000000000..221061d6a360
--- /dev/null
+++ b/sci-chemistry/maxit/maxit-8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/maxit/maxit-8.2.ebuild,v 1.1 2005/12/20 04:19:43 spyderous Exp $
+
+inherit eutils toolchain-funcs multilib
+
+# pdb-extract includes a newer 'validation' than 'validation' tarball does,
+# and the filterlib from pdb-extract is incompatible with the validation tarball
+MY_PN="pdb-extract"
+MY_PV="1.700"
+MY_P="${MY_PN}-v${MY_PV}-prod-src"
+DESCRIPTION="An application for processing and curation of macromolecular structure data"
+HOMEPAGE="http://sw-tools.pdb.org/apps/MAXIT/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/PDB_EXTRACT/${MY_P}.tar.gz"
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="sci-libs/rcsb-data"
+DEPEND="${RDEPEND}
+ sci-chemistry/pdb-extract
+ sci-chemistry/validation"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/respect-cflags-and-fix-install.patch
+ cd ${S}
+
+ # Get rid of unneeded directories, to make sure we use system files
+ ebegin "Deleting redundant directories"
+ rm -rf btree-obj* ciflib-common* cifobj-common* cif-table-obj* misclib* \
+ regex* pdb-extract* validation*
+ eend
+
+ sed -i \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ -e "s:^\(GINCLUDE=\).*:\1-I${ROOT}usr/include/rcsb:g" \
+ -e "s:^\(LIBDIR=\).*:\1${ROOT}usr/$(get_libdir):g" \
+ ${S}/etc/make.*
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/*
+ dolib.a lib/*
+ dodoc ${FILESDIR}/README*
+}