summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-06 12:04:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-06 12:04:07 +0000
commita8a2755e50f24b322abbe6201e4136a67cdee95d (patch)
tree61d1f463983e16c39ed4ce684efa87465711518c /sci-chemistry/coot
parentBumped all ebuilds to EAPI-4 (diff)
downloadgentoo-2-a8a2755e50f24b322abbe6201e4136a67cdee95d.tar.gz
gentoo-2-a8a2755e50f24b322abbe6201e4136a67cdee95d.tar.bz2
gentoo-2-a8a2755e50f24b322abbe6201e4136a67cdee95d.zip
Pass -Wl,--no-as-needed with USE="openmp" and <sys-devel/libtool-2.4-r2 wrt #385813 by Agostino Sarubbo
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/coot')
-rw-r--r--sci-chemistry/coot/ChangeLog6
-rw-r--r--sci-chemistry/coot/coot-0.6.2.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 1acf5e8193ed..41fde89bbf92 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.42 2011/09/14 17:49:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.43 2011/10/06 12:04:07 ssuominen Exp $
+
+ 06 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> coot-0.6.2.ebuild:
+ Pass -Wl,--no-as-needed with USE="openmp" and <sys-devel/libtool-2.4-r2 wrt
+ #385813 by Agostino Sarubbo
14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+files/0.6.2-libpng15.patch, coot-0.6.2.ebuild:
diff --git a/sci-chemistry/coot/coot-0.6.2.ebuild b/sci-chemistry/coot/coot-0.6.2.ebuild
index 4fe66230d07f..acabb6d7ded7 100644
--- a/sci-chemistry/coot/coot-0.6.2.ebuild
+++ b/sci-chemistry/coot/coot-0.6.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.5 2011/09/14 17:49:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.6 2011/10/06 12:04:07 ssuominen Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit autotools base eutils python toolchain-funcs versionator
+inherit autotools base eutils flag-o-matic python toolchain-funcs versionator
MY_S2_PV=$(replace_version_separator 2 - ${PV})
MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
@@ -70,6 +70,7 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use openmp; then
tc-has-openmp || die "Please use an OPENMP capable compiler"
+ has_version '<sys-devel/libtool-2.4-r2' && append-ldflags $(no-as-needed)
fi
python_set_active_version 2
}