summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-16 13:14:36 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-16 13:14:36 +0000
commit488766c9accbc5267785d43fc3aab7ab5e2034e4 (patch)
tree9df4b324e54bb1269f3bb22bb959105976c2c9a4 /sci-chemistry/coot
parentMove sci-electronics/ng-spice-rework to sci-electronics/ngspice. (diff)
downloadgentoo-2-488766c9accbc5267785d43fc3aab7ab5e2034e4.tar.gz
gentoo-2-488766c9accbc5267785d43fc3aab7ab5e2034e4.tar.bz2
gentoo-2-488766c9accbc5267785d43fc3aab7ab5e2034e4.zip
Depend on unbundled ssm
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/coot')
-rw-r--r--sci-chemistry/coot/ChangeLog6
-rw-r--r--sci-chemistry/coot/coot-0.6.2.ebuild5
-rw-r--r--sci-chemistry/coot/files/0.6.2-ssm.patch56
3 files changed, 64 insertions, 3 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index a428ef1874f5..bd364d9c8d6a 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.40 2011/06/29 13:31:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.41 2011/07/16 13:14:36 jlec Exp $
+
+ 16 Jul 2011; Justin Lecher <jlec@gentoo.org> +files/0.6.2-ssm.patch,
+ coot-0.6.2.ebuild:
+ Depend on unbundled ssm
29 Jun 2011; Justin Lecher <jlec@gentoo.org> coot-0.6.2.ebuild:
Fix mmdb dep version
diff --git a/sci-chemistry/coot/coot-0.6.2.ebuild b/sci-chemistry/coot/coot-0.6.2.ebuild
index 4e2227b8d0c0..30ae440df979 100644
--- a/sci-chemistry/coot/coot-0.6.2.ebuild
+++ b/sci-chemistry/coot/coot-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.3 2011/06/29 13:31:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.4 2011/07/16 13:14:36 jlec Exp $
EAPI=3
@@ -31,6 +31,7 @@ SCIDEPS="
>=sci-libs/coot-data-2
>=sci-libs/gsl-1.3
>=sci-libs/mmdb-1.23
+ sci-libs/ssm
<sci-libs/monomer-db-1
sci-chemistry/reduce
<sci-chemistry/refmac-5.6
@@ -78,6 +79,7 @@ PATCHES=(
"${FILESDIR}"/${PV}-mmdb-config.patch
"${FILESDIR}"/${PV}-gl.patch
"${FILESDIR}"/${PV}-test.patch
+ "${FILESDIR}"/${PV}-ssm.patch
)
src_prepare() {
@@ -92,7 +94,6 @@ src_configure() {
econf \
--includedir='${prefix}/include/coot' \
--with-gtkcanvas-prefix="${EPREFIX}/usr" \
- --with-ssmlib-prefix="${EPREFIX}/usr" \
--with-gtkgl-prefix="${EPREFIX}/usr" \
--with-guile \
--with-python="${EPREFIX}/usr" \
diff --git a/sci-chemistry/coot/files/0.6.2-ssm.patch b/sci-chemistry/coot/files/0.6.2-ssm.patch
new file mode 100644
index 000000000000..c801da72410a
--- /dev/null
+++ b/sci-chemistry/coot/files/0.6.2-ssm.patch
@@ -0,0 +1,56 @@
+ macros/mmdb-ssm.m4 | 42 +-----------------------------------------
+ 1 files changed, 1 insertions(+), 41 deletions(-)
+
+diff --git a/macros/mmdb-ssm.m4 b/macros/mmdb-ssm.m4
+index 1937a16..6ef547c 100644
+--- a/macros/mmdb-ssm.m4
++++ b/macros/mmdb-ssm.m4
+@@ -22,47 +22,7 @@
+ AC_DEFUN([AM_WITH_MMDBSSM],
+ [AC_PROVIDE([AM_USE_MMDBSSM])
+
+-
+-AC_ARG_WITH(ssmlib-prefix,
+- AC_HELP_STRING( [--with-ssmlib-prefix=PFX], [Prefix where SSMLib has been installed] ),
+- [ with_ssmlib_prefix="$withval" ],
+- with_ssmlib_prefix="")
+-
+-AC_MSG_CHECKING([for SSMLib])
+-
+-if test x$with_ssmlib_prefix != x; then
+-
+- MMDBSSM_CXXFLAGS="-DHAVE_SSMLIB"
+- MMDBSSM_LIBS="-L$with_ssmlib_prefix/$acl_libdirstem -lssm"
+-
+-ac_mmdb_dirs='
+-.
+-include
+-include/ssm
+-include/mmdb
+-lib
+-src
+-lib/src
+-lib/src/mmdb'
+-
+- for ac_dir in $ac_mmdb_dirs; do
+- if test -r "$with_ssmlib_prefix/$ac_dir/ssm_superpose.h"; then
+- ac_MMDBSSM_CXXFLAGS="-I$with_ssmlib_prefix/$ac_dir"
+- break
+- fi
+- done
+-
+- MMDBSSM_CXXFLAGS="$MMDBSSM_CXXFLAGS $ac_MMDBSSM_CXXFLAGS"
+-
+-else
+-
+- MMDBSSM_CXXFLAGS=""
+- MMDBSSM_LIBS=""
+- with_ssmlib_prefix=no
+-
+-fi
+-
+-AC_MSG_RESULT([$with_ssmlib_prefix])
++PKG_CHECK_MODULES([MMDBSSM],[ssm])
+
+ AC_SUBST(MMDBSSM_CXXFLAGS)
+ AC_SUBST(MMDBSSM_LIBS)