summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-02-22 05:58:46 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-02-22 05:58:46 +0000
commitde29c1b3b152af033ec0d2a7d64d77a1f29d6e05 (patch)
treea66f6e87fae11b75ec172444222033579febeee7 /sci-chemistry/chemtool
parent(Portage version: 2.0.51-r15) (Manifest recommit) (diff)
downloadgentoo-2-de29c1b3b152af033ec0d2a7d64d77a1f29d6e05.tar.gz
gentoo-2-de29c1b3b152af033ec0d2a7d64d77a1f29d6e05.tar.bz2
gentoo-2-de29c1b3b152af033ec0d2a7d64d77a1f29d6e05.zip
Version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/ChangeLog7
-rw-r--r--sci-chemistry/chemtool/Manifest2
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.6.ebuild84
-rw-r--r--sci-chemistry/chemtool/files/digest-chemtool-1.6.61
4 files changed, 93 insertions, 1 deletions
diff --git a/sci-chemistry/chemtool/ChangeLog b/sci-chemistry/chemtool/ChangeLog
index ee4f184dba72..d35357a738ec 100644
--- a/sci-chemistry/chemtool/ChangeLog
+++ b/sci-chemistry/chemtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/chemtool
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.3 2005/02/04 14:08:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.4 2005/02/22 05:58:46 phosphan Exp $
+
+*chemtool-1.6.6 (22 Feb 2005)
+
+ 22 Feb 2005; Patrick Kursawe <phosphan@gentoo.org> +chemtool-1.6.6.ebuild:
+ Version bump
*chemtool-1.6.4 (04 Feb 2005)
diff --git a/sci-chemistry/chemtool/Manifest b/sci-chemistry/chemtool/Manifest
index 7c90ee4df41f..dfe99e8052fa 100644
--- a/sci-chemistry/chemtool/Manifest
+++ b/sci-chemistry/chemtool/Manifest
@@ -1,6 +1,8 @@
MD5 372559212ea87a5bd27a53e6a03fa8ea chemtool-1.6.3.ebuild 1951
MD5 9e2101d05a406781b0e7edbd09b89e15 chemtool-1.6.4.ebuild 2073
+MD5 9e2101d05a406781b0e7edbd09b89e15 chemtool-1.6.6.ebuild 2073
MD5 24bd7dbd7fe56305f0b42bb73fa8b99b ChangeLog 2843
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 4ae73ea952733fc1500a98a82b1b8f3d files/digest-chemtool-1.6.3 66
MD5 73e6d16f503d84f586445148c62e1a32 files/digest-chemtool-1.6.4 66
+MD5 5f0baeb289dacc7ef250d44bf8e2fd16 files/digest-chemtool-1.6.6 66
diff --git a/sci-chemistry/chemtool/chemtool-1.6.6.ebuild b/sci-chemistry/chemtool/chemtool-1.6.6.ebuild
new file mode 100644
index 000000000000..2931ad1364b6
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.6.ebuild,v 1.1 2005/02/22 05:58:46 phosphan Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk2 gnome kde nls"
+
+DEPEND=">=media-gfx/transfig-3.2.3d
+ || (
+ gtk2? ( =x11-libs/gtk+-2* )
+ =x11-libs/gtk+-1*
+ )
+ x86? ( >=media-libs/libemf-1.0 )"
+
+src_compile() {
+ local config_opts
+ local mycppflags
+ local mykdedir
+ if [ -z "${KDEDIR}" ]; then
+ mykdedir="bogus_kde"
+ else
+ mykdedir="${KDEDIR}"
+ fi
+ if [ ${ARCH} = "x86" ]; then
+ config_opts="--enable-emf"
+ mycppflags="${mycppflags} -I /usr/include/libEMF"
+ fi
+
+ if ! use gtk2; then
+ config_opts="${config_opts} --enable-gtk1"
+ fi
+
+ sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+ die "could not append cppflags"
+
+ if use kde; then
+ config_opts="${config_opts} --with-kdedir=${mykdedir}" ;
+ fi
+
+ if use gnome ; then
+ config_opts="${config_opts} --with-gnomedir=/usr" ;
+ else
+ config_opts="${config_opts} --without-gnomedir" ;
+ fi
+
+ econf ${config_opts} \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+
+ local mykdedir="${KDEDIR}"
+ if [ -z "${mykdedir}" ]; then mykdedir="bogus_kde"; fi
+ local sharedirs="applnk/Graphics mimelnk/application icons/hicolor/32x32/mimetypes"
+ for dir in ${sharedirs}; do
+ dodir ${mykdedir}/share/${dir}
+ done
+ dodir /usr/share/mime-types
+ dodir /usr/share/pixmaps/mc
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if ! use kde; then
+ rm -rf ${D}/${mykdedir}
+ fi
+
+ if ! use gnome; then
+ rm -rf ${D}/usr/share/pixmaps ${D}/usr/share/mime-types
+ fi
+
+ dodoc ChangeLog INSTALL README TODO
+ insinto /usr/share/${PN}/examples
+ doins ${S}/examples/*
+ if ! use nls; then rm -rf ${D}/usr/share/locale; fi
+}
diff --git a/sci-chemistry/chemtool/files/digest-chemtool-1.6.6 b/sci-chemistry/chemtool/files/digest-chemtool-1.6.6
new file mode 100644
index 000000000000..f9ea77f8e972
--- /dev/null
+++ b/sci-chemistry/chemtool/files/digest-chemtool-1.6.6
@@ -0,0 +1 @@
+MD5 f4215613f8cbdaa83aac08afcd7eb6f6 chemtool-1.6.6.tar.gz 425424