summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-31 09:15:41 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-31 09:15:41 +0000
commit325b8f1b7a1540df752fc7731a9d6aa5155d7d81 (patch)
treee20db4512a51d44fa4927adbeae5eb859de505e5 /sci-chemistry/azara
parentVersion bump (diff)
downloadgentoo-2-325b8f1b7a1540df752fc7731a9d6aa5155d7d81.tar.gz
gentoo-2-325b8f1b7a1540df752fc7731a9d6aa5155d7d81.tar.bz2
gentoo-2-325b8f1b7a1540df752fc7731a9d6aa5155d7d81.zip
More parallel fixes and impl dec QA
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/azara')
-rw-r--r--sci-chemistry/azara/ChangeLog8
-rw-r--r--sci-chemistry/azara/azara-2.8-r2.ebuild80
-rw-r--r--sci-chemistry/azara/files/2.8-impl-decng.patch205
-rw-r--r--sci-chemistry/azara/files/2.8-prllng.patch361
4 files changed, 653 insertions, 1 deletions
diff --git a/sci-chemistry/azara/ChangeLog b/sci-chemistry/azara/ChangeLog
index d693ad07a32c..f2a597c2aff5 100644
--- a/sci-chemistry/azara/ChangeLog
+++ b/sci-chemistry/azara/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/azara
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.5 2010/08/06 10:50:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.6 2010/10/31 09:15:41 jlec Exp $
+
+*azara-2.8-r2 (31 Oct 2010)
+
+ 31 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/2.8-impl-decng.patch,
+ +azara-2.8-r2.ebuild, +files/2.8-prllng.patch:
+ More parallel fixes and impl dec QA
*azara-2.8-r1 (06 Aug 2010)
*azara-2.7-r1 (06 Aug 2010)
diff --git a/sci-chemistry/azara/azara-2.8-r2.ebuild b/sci-chemistry/azara/azara-2.8-r2.ebuild
new file mode 100644
index 000000000000..dc9491d569bb
--- /dev/null
+++ b/sci-chemistry/azara/azara-2.8-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.8-r2.ebuild,v 1.1 2010/10/31 09:15:41 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="A suite of programmes to process and view NMR data"
+HOMEPAGE="http://www.bio.cam.ac.uk/azara/"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${PN}/${P}-src.tgz"
+
+LICENSE="AZARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="X xpm"
+
+RDEPEND="
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ cat > ENVIRONMENT <<- EOF
+ CC=$(tc-getCC)
+ CFLAGS=${CFLAGS}
+ LFLAGS=${LDFLAGS}
+ MATH_LIB=-lm
+ X11_INCLUDE_DIR=-I${EPREFIX}/usr/X11R6/include
+ MOTIF_INCLUDE_DIR=-I${EPREFIX}/usr/include -I../global
+ X11_LIB_DIR=-L${EPREFIX}/usr/$(get_libdir)
+ MOTIF_LIB_DIR=-L${EPREFIX}/usr/$(get_libdir)
+ X11_LIB=-lX11
+ MOTIF_LIB=-lXm -lXt
+ PYTHON_INCLUDE_DIR=$(python_get_includedir)
+ SHARED_FLAGS = -shared
+ ENDIAN_FLAG=-DLITTLE_ENDIAN_DATA
+ EOF
+
+ use xpm && echo "XPMUSE=\"XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm\"" >> ENVIRONMENT
+
+ epatch "${FILESDIR}"/${PV}-prllng.patch
+ epatch "${FILESDIR}"/${PV}-impl-decng.patch
+}
+
+src_compile() {
+ local mymake
+ local makeflags
+
+ mymake="${mymake} help nongui DataRows"
+ use X && mymake="${mymake} gui"
+
+ emake -C global || die
+ emake ${mymake} || die
+}
+
+src_install() {
+ rm bin/pythonAzara || die
+ if ! use X; then
+ rm bin/plot* || die
+ fi
+
+ dodoc CHANGES* README* || die
+ dohtml -r html/* || die
+
+ cd bin
+ for bin in *; do
+ newbin ${bin} ${PN}-${bin} || die "failed to install ${bin}"
+ done
+}
+
+pkg_postinst() {
+ einfo "Due to collision we moved all binary to azara-*"
+}
diff --git a/sci-chemistry/azara/files/2.8-impl-decng.patch b/sci-chemistry/azara/files/2.8-impl-decng.patch
new file mode 100644
index 000000000000..053d90f3c3fe
--- /dev/null
+++ b/sci-chemistry/azara/files/2.8-impl-decng.patch
@@ -0,0 +1,205 @@
+diff --git a/connect/crosspeak.c b/connect/crosspeak.c
+index 0de57bf..7b016e1 100644
+--- a/connect/crosspeak.c
++++ b/connect/crosspeak.c
+@@ -1,4 +1,5 @@
+ #include "crosspeak.h"
++#include "utility.h"
+
+ #include "atom.h"
+ #include "table.h"
+diff --git a/connect/shift.c b/connect/shift.c
+index f54ba9f..a880001 100644
+--- a/connect/shift.c
++++ b/connect/shift.c
+@@ -1,4 +1,5 @@
+ #include "shift.h"
++#include "utility.h"
+
+ #include "atom.h"
+ #include "table.h"
+diff --git a/global/macros.h b/global/macros.h
+index 43fc43e..bb1d267 100644
+--- a/global/macros.h
++++ b/global/macros.h
+@@ -8,6 +8,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <ctype.h>
+
+ #ifdef WIN32
+ #include <ctype.h>
+diff --git a/global/parser.c b/global/parser.c
+index 007d926..0f19575 100644
+--- a/global/parser.c
++++ b/global/parser.c
+@@ -1,4 +1,5 @@
+ #include "parser.h"
++#include "utility.h"
+
+ #define MAX_NARGS 20
+
+diff --git a/peak/fitter.c b/peak/fitter.c
+index ba6b175..b58f573 100644
+--- a/peak/fitter.c
++++ b/peak/fitter.c
+@@ -1,4 +1,5 @@
+ #include "fitter.h"
++#include "data.h"
+
+ #include "nonlinear_model.h"
+
+diff --git a/peak/peak_fit.c b/peak/peak_fit.c
+index 92c69a8..5b9791f 100644
+--- a/peak/peak_fit.c
++++ b/peak/peak_fit.c
+@@ -6,6 +6,7 @@
+ #include "output.h"
+ #include "ref.h"
+ #include "script_fit.h"
++#include "fitter.h"
+
+ #define MEGAWORD (1024 * 1024)
+ #define DEFAULT_STORE (2 * MEGAWORD)
+diff --git a/plot1/draw.c b/plot1/draw.c
+index 4fdce96..a2a2e8a 100644
+--- a/plot1/draw.c
++++ b/plot1/draw.c
+@@ -1,4 +1,5 @@
+ #include "draw.h"
++#include "ticks.h"
+
+ #include "color.h"
+ #include "data.h"
+diff --git a/plot1/object.c b/plot1/object.c
+index 973897c..e043a53 100644
+--- a/plot1/object.c
++++ b/plot1/object.c
+@@ -1,4 +1,5 @@
+ #include "object.h"
++#include "script.h"
+
+ #include "color.h"
+ #include "parser.h"
+diff --git a/plot1/output_popup.c b/plot1/output_popup.c
+index 0794584..e73976e 100644
+--- a/plot1/output_popup.c
++++ b/plot1/output_popup.c
+@@ -1,4 +1,5 @@
+ #include "output_popup.h"
++#include "script.h"
+
+ #include "output.hlp"
+
+diff --git a/plot1/plots.c b/plot1/plots.c
+index 3790f5b..7ac58df 100644
+--- a/plot1/plots.c
++++ b/plot1/plots.c
+@@ -1,4 +1,5 @@
+ #include "plots.h"
++#include "script.h"
+
+ #include "data.h"
+ #include "input.h"
+diff --git a/plot1/region_popup.c b/plot1/region_popup.c
+index 68b3930..f049d29 100644
+--- a/plot1/region_popup.c
++++ b/plot1/region_popup.c
+@@ -1,4 +1,5 @@
+ #include "region_popup.h"
++#include "data.h"
+
+ #include "region.hlp"
+
+diff --git a/plot2/data_popup.c b/plot2/data_popup.c
+index 851b1d4..1c9026e 100644
+--- a/plot2/data_popup.c
++++ b/plot2/data_popup.c
+@@ -1,4 +1,5 @@
+ #include "data_popup.h"
++#include "rowcol_popup.h"
+
+ #include "data.hlp"
+
+diff --git a/plot2/extract_popup.c b/plot2/extract_popup.c
+index 416aab0..a7fcbf3 100644
+--- a/plot2/extract_popup.c
++++ b/plot2/extract_popup.c
+@@ -1,4 +1,5 @@
+ #include "extract_popup.h"
++#include "script.h"
+
+ #include "extract.hlp"
+
+diff --git a/plot2/levels_popup.c b/plot2/levels_popup.c
+index 197cf2c..e1ac22c 100644
+--- a/plot2/levels_popup.c
++++ b/plot2/levels_popup.c
+@@ -1,4 +1,5 @@
+ #include "levels_popup.h"
++#include "levels_func.h"
+
+ #include "levels.hlp"
+
+diff --git a/plot2/plot2.c b/plot2/plot2.c
+index 9ca91c3..0c10d5a 100644
+--- a/plot2/plot2.c
++++ b/plot2/plot2.c
+@@ -1,4 +1,6 @@
+ #include "plot2.h"
++#include "object_popup.h"
++#include "prop_popup.h"
+
+ #include "baseline_popup.h"
+ #include "callback.h"
+diff --git a/plot2/rowcol_popup.c b/plot2/rowcol_popup.c
+index e9f4843..6c50426 100644
+--- a/plot2/rowcol_popup.c
++++ b/plot2/rowcol_popup.c
+@@ -1,4 +1,5 @@
+ #include "rowcol_popup.h"
++#include "ref_popup.h"
+
+ #include "rowcol.hlp"
+
+diff --git a/plot2/script.c b/plot2/script.c
+index 2f55182..d7d886f 100644
+--- a/plot2/script.c
++++ b/plot2/script.c
+@@ -1,4 +1,5 @@
+ #include "script.h"
++#include "macros.h"
+
+ #include "param.h"
+ #include "stack.h"
+diff --git a/plot2/slice_popup.c b/plot2/slice_popup.c
+index b601834..1b1e686 100644
+--- a/plot2/slice_popup.c
++++ b/plot2/slice_popup.c
+@@ -1,4 +1,5 @@
+ #include "slice_popup.h"
++#include "rowcol_func.h"
+
+ #include "baseline.h"
+ #include "baseline_popup.h"
+diff --git a/process/files.c b/process/files.c
+index e09127e..d95d681 100644
+--- a/process/files.c
++++ b/process/files.c
+@@ -1,4 +1,5 @@
+ #include "files.h"
++#include "macros.h"
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+diff --git a/project/project.c b/project/project.c
+index 92b70e3..a3e6d94 100644
+--- a/project/project.c
++++ b/project/project.c
+@@ -1,4 +1,5 @@
+ #include "project.h"
++#include "utility.h"
+
+ #include "block.h"
+ #include "par.h"
diff --git a/sci-chemistry/azara/files/2.8-prllng.patch b/sci-chemistry/azara/files/2.8-prllng.patch
new file mode 100644
index 000000000000..1912d00da4c8
--- /dev/null
+++ b/sci-chemistry/azara/files/2.8-prllng.patch
@@ -0,0 +1,361 @@
+diff --git a/DataRows/makefile b/DataRows/makefile
+index 587e710..4e0a312 100644
+--- a/DataRows/makefile
++++ b/DataRows/makefile
+@@ -28,7 +28,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-DataRows.so: locals globals
++DataRows.so: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) $(SHARED_FLAGS) -o $@ $(CFLAGS) $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS)
+diff --git a/azara/makefile b/azara/makefile
+index 3ba0cd9..f7b4ce5 100644
+--- a/azara/makefile
++++ b/azara/makefile
+@@ -12,7 +12,7 @@ LOCAL_OBJS = \
+ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/help.o
+
+-azara: locals globals
++azara: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/combine/makefile b/combine/makefile
+index a855236..7a83d8f 100644
+--- a/combine/makefile
++++ b/combine/makefile
+@@ -20,7 +20,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-combine: locals globals
++combine: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/connect/makefile b/connect/makefile
+index d75e7da..d238507 100644
+--- a/connect/makefile
++++ b/connect/makefile
+@@ -23,7 +23,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-connect: locals globals
++connect: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/contours/makefile b/contours/makefile
+index 5b832b8..49175dd 100644
+--- a/contours/makefile
++++ b/contours/makefile
+@@ -19,7 +19,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-contours: locals globals
++contours: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/deflate/makefile b/deflate/makefile
+index 4c4e02e..42d5c30 100644
+--- a/deflate/makefile
++++ b/deflate/makefile
+@@ -18,7 +18,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-deflate: locals globals
++deflate: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/extract/makefile b/extract/makefile
+index 3212cb9..fed874b 100644
+--- a/extract/makefile
++++ b/extract/makefile
+@@ -18,7 +18,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-extract: locals globals
++extract: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/global/makefile b/global/makefile
+index 364fa41..5272a31 100644
+--- a/global/makefile
++++ b/global/makefile
+@@ -42,6 +42,31 @@ LINPACK_OBJS = \
+ AZARA_OBJS = \
+ help.o
+
++all: \
++ azara_objects \
++ decay_objects \
++ simulate_objects \
++ viewer_objects \
++ components_objects \
++ shuffle_objects \
++ connect_objects \
++ slides_objects \
++ peak_find_objects \
++ peak_fit_objects \
++ plot1_objects \
++ reflate_objects \
++ deflate_objects \
++ combine_objects \
++ unblock_objects \
++ extract_objects \
++ project_objects \
++ contours_objects \
++ plot2_nog_objects \
++ plot2_objects \
++ process_objects \
++ python_objects \
++ integrate_objects
++
+ azara_objects: $(AZARA_OBJS)
+
+ DECAY_OBJS = \
+diff --git a/help/makefile b/help/makefile
+index 9e99a7c..59a86a3 100644
+--- a/help/makefile
++++ b/help/makefile
+@@ -39,7 +39,7 @@ globals:
+
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+-hlp:
++hlp: txt2hlp
+ $(TXT2HLP) azara
+ $(TXT2HLP) combine
+ $(TXT2HLP) connect
+@@ -78,7 +78,7 @@ hlp:
+ $(TXT2HLP) plot1/text
+ $(TXT2HLP) DataRows
+
+-html:
++html: txt2html
+ $(TXT2HTML) azara
+ $(TXT2HTML) combine
+ $(TXT2HTML) connect
+diff --git a/makefile b/makefile
+index 9965b07..6f3bdd0 100644
+--- a/makefile
++++ b/makefile
+@@ -14,7 +14,7 @@ all: help nongui DataRows gui
+ help: \
+ help_program
+
+-nongui: \
++nongui: help \
+ process_program \
+ plot2_nog_program \
+ peak_program \
+@@ -29,63 +29,63 @@ nongui: \
+ connect_program \
+ azara_program
+
+-gui: \
++gui: help \
+ plot2_program \
+ plot1_program
+
+-DataRows: \
++DataRows: help \
+ DataRows
+
+ process_program:
+- cd process; $(MAKE)
++ $(MAKE) -C process
+
+ plot2_program:
+- cd plot2; $(MAKE) plot2
++ $(MAKE) -C plot2
+
+ plot2_nog_program:
+- cd plot2; $(MAKE) plot2_nog
++ $(MAKE) -C plot2 plot2_nog
+
+ plot1_program:
+- cd plot1; $(MAKE)
++ $(MAKE) -C plot1
+
+ peak_program:
+- cd peak; $(MAKE)
++ $(MAKE) -C peak
+
+ extract_program:
+- cd extract; $(MAKE)
++ $(MAKE) -C extract
+
+ project_program:
+- cd project; $(MAKE)
++ $(MAKE) -C project
+
+ unblock_program:
+- cd unblock; $(MAKE)
++ $(MAKE) -C unblock
+
+ contours_program:
+- cd contours; $(MAKE)
++ $(MAKE) -C contours
+
+ combine_program:
+- cd combine; $(MAKE)
++ $(MAKE) -C combine
+
+ deflate_program:
+- cd deflate; $(MAKE)
++ $(MAKE) -C deflate
+
+ reflate_program:
+- cd reflate; $(MAKE)
++ $(MAKE) -C reflate
+
+ utility_program:
+- cd utility; $(MAKE)
++ $(MAKE) -C utility
+
+ connect_program:
+- cd connect; $(MAKE)
++ $(MAKE) -C connect
+
+ help_program:
+- cd help; $(MAKE)
++ $(MAKE) -C help
+
+ azara_program:
+- cd azara; $(MAKE)
++ $(MAKE) -C azara
+
+ DataRows:
+- cd DataRows; $(MAKE)
++ $(MAKE) -C DataRows
+
+ clean: \
+ global_clean \
+diff --git a/peak/makefile b/peak/makefile
+index f3c13b7..4211221 100644
+--- a/peak/makefile
++++ b/peak/makefile
+@@ -97,13 +97,13 @@ COMMAND_OBJS = \
+
+ all: peak_find peak_fit
+
+-peak_find: local_find global_find
++peak_find: $(LOCAL_FIND_OBJS) $(GLOBAL_FIND_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_FIND_OBJS) \
+ $(GLOBAL_FIND_OBJS) \
+ $(LIB) $(MATH_LIB)
+
+-peak_fit: local_fit global_fit commands
++peak_fit: $(LOCAL_FIT_OBJS) $(GLOBAL_FIT_OBJS) $(COMMAND_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_FIT_OBJS) \
+ $(GLOBAL_FIT_OBJS) \
+diff --git a/plot1/makefile b/plot1/makefile
+index d1dce2d..e729443 100644
+--- a/plot1/makefile
++++ b/plot1/makefile
+@@ -95,7 +95,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/utility.o \
+ $(GLOBAL_DIR)/window.o
+
+-plot1: locals globals
++plot1: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+@@ -110,7 +110,7 @@ locals:
+ globals:
+ cd $(GLOBAL_DIR); $(MAKE) plot1_objects
+
+-.c.o:; $(CC) $(X11_INCLUDE_DIR) $(MOTIF_INCLUDE_DIR) -c $(CFLAGS) $<
++.c.o:; $(CC) $(X11_INCLUDE_DIR) $(MOTIF_INCLUDE_DIR) -c $(CFLAGS) -I../plot2 $<
+
+ clean:
+ rm -f *.o
+diff --git a/plot2/makefile b/plot2/makefile
+index a6b7b4a..98e286e 100644
+--- a/plot2/makefile
++++ b/plot2/makefile
+@@ -129,7 +129,7 @@ GLOBAL_PLOT2_NOG_OBJS = \
+
+ all: plot2 plot2_nog
+
+-plot2: local_plot2 global_plot2
++plot2: $(LOCAL_PLOT2_OBJS) $(GLOBAL_PLOT2_OBJS)
+ $(CC) -o $@ $(CFLAGS) $(LFLAGS) \
+ $(LOCAL_PLOT2_OBJS) \
+ $(GLOBAL_PLOT2_OBJS) \
+@@ -137,7 +137,7 @@ plot2: local_plot2 global_plot2
+ $(LIB) $(MATH_LIB) \
+ $(MOTIF_LIB) $(X11_LIB) $(XPM_LIB)
+
+-plot2_nog: local_plot2_nog global_plot2_nog
++plot2_nog: $(LOCAL_PLOT2_NOG_OBJS) $(GLOBAL_PLOT2_NOG_OBJS)
+ $(CC) -o $@ $(CFLAGS) $(LFLAGS) \
+ $(LOCAL_PLOT2_NOG_OBJS) \
+ $(GLOBAL_PLOT2_NOG_OBJS) \
+diff --git a/process/makefile b/process/makefile
+index 22ceeed..72d587b 100644
+--- a/process/makefile
++++ b/process/makefile
+@@ -72,7 +72,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/utility.o \
+ $(LINPACK_OBJS)
+
+-process: locals globals
++process: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/project/makefile b/project/makefile
+index 78143fc..ed0f296 100644
+--- a/project/makefile
++++ b/project/makefile
+@@ -18,7 +18,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-project: locals globals
++project: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/reflate/makefile b/reflate/makefile
+index 079a3fc..01ec311 100644
+--- a/reflate/makefile
++++ b/reflate/makefile
+@@ -18,7 +18,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-reflate: locals globals
++reflate: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \
+diff --git a/unblock/makefile b/unblock/makefile
+index 510dc9e..d9a0f2b 100644
+--- a/unblock/makefile
++++ b/unblock/makefile
+@@ -18,7 +18,7 @@ GLOBAL_OBJS = \
+ $(GLOBAL_DIR)/ref.o \
+ $(GLOBAL_DIR)/utility.o
+
+-unblock: locals globals
++unblock: $(LOCAL_OBJS) $(GLOBAL_OBJS)
+ $(CC) -o $@ $(LFLAGS) \
+ $(LOCAL_OBJS) \
+ $(GLOBAL_OBJS) \