summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-24 12:22:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-24 12:22:37 +0000
commitaf534542de2939cecedc1bece772f2d33b005fcd (patch)
tree3794ac7dcd59386d13e2388a4ade40136833b0e6 /sci-calculators
parentVersion bump (diff)
downloadgentoo-2-af534542de2939cecedc1bece772f2d33b005fcd.tar.gz
gentoo-2-af534542de2939cecedc1bece772f2d33b005fcd.tar.bz2
gentoo-2-af534542de2939cecedc1bece772f2d33b005fcd.zip
Version bump
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tiemu/ChangeLog7
-rw-r--r--sci-calculators/tiemu/tiemu-3.03.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-calculators/tiemu/ChangeLog b/sci-calculators/tiemu/ChangeLog
index 526a5b3768b0..8b30aa3cd944 100644
--- a/sci-calculators/tiemu/ChangeLog
+++ b/sci-calculators/tiemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-calculators/tiemu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.1 2009/02/03 15:49:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.2 2009/03/24 12:22:37 bicatali Exp $
+
+*tiemu-3.03 (24 Mar 2009)
+
+ 24 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org> +tiemu-3.03.ebuild:
+ Version bump
*tiemu-3.02 (03 Feb 2009)
diff --git a/sci-calculators/tiemu/tiemu-3.03.ebuild b/sci-calculators/tiemu/tiemu-3.03.ebuild
new file mode 100644
index 000000000000..d0402c385274
--- /dev/null
+++ b/sci-calculators/tiemu/tiemu-3.03.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.03.ebuild,v 1.1 2009/03/24 12:22:37 bicatali Exp $
+
+EAPI=2
+inherit eutils kde-functions
+
+DESCRIPTION="Texas Instruments hand-helds emulator"
+HOMEPAGE="http://lpg.ticalc.org/prj_tiemu/"
+SRC_URI="http://repo.calcforge.org/debian/source/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus kde nls sdl threads xinerama"
+
+RDEPEND="sci-libs/libticables2
+ sci-libs/libticalcs2
+ sci-libs/libtifiles2
+ sci-libs/libticonv
+ >=gnome-base/libglade-2.4.0
+ >=x11-libs/gtk+-2.6.0
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ kde? ( kde-base/kdelibs:3.5 )
+ nls? ( virtual/libintl )
+ sdl? ( media-libs/libsdl )
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ use kde && set-kdedir 3
+ econf \
+ --disable-rpath \
+ --disable-debugger \
+ --disable-gdb \
+ $(use_enable nls) \
+ $(use_enable sdl sound) \
+ $(use_enable threads) \
+ $(use_enable threads threading) \
+ $(use_with dbus) \
+ $(use_with kde) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
+ dodoc AUTHORS NEWS README README.linux RELEASE THANKS TODO *.txt
+ make_desktop_entry tiemu "TiEmu Calculator" \
+ /usr/share/tiemu/pixmaps/icon.xpm
+}