summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-04 14:06:53 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-04 14:06:53 +0000
commit6ac238c182119ad82c006abdadfce4bbf69ae90a (patch)
treede0ef3e770d1386d6ed977bb586026a49237ef7c /sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild
parentAdded patches to allow compilation against cln-1.2 (see bug #208527). (diff)
downloadgentoo-2-6ac238c182119ad82c006abdadfce4bbf69ae90a.tar.gz
gentoo-2-6ac238c182119ad82c006abdadfce4bbf69ae90a.tar.bz2
gentoo-2-6ac238c182119ad82c006abdadfce4bbf69ae90a.zip
Added patches to allow compilation against cln-1.2 (see bug #208527).
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild')
-rw-r--r--sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild b/sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild
new file mode 100644
index 000000000000..66a158cd6a95
--- /dev/null
+++ b/sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-bases/qalculate-bases-0.9.4-r2.ebuild,v 1.1 2008/02/04 14:06:52 markusle Exp $
+
+inherit autotools
+
+DESCRIPTION="A GTK+ base conversion tool"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="nls"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sci-libs/libqalculate-0.9.6-r1
+ >=x11-libs/gtk+-2.4
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cln-config.patch
+ eautoconf
+}
+
+src_compile() {
+ econf --disable-clntest || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Installation failed."
+ dodoc AUTHORS ChangeLog README || die "Failed to install documentation."
+}