summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-07-25 18:07:34 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-07-25 18:07:34 +0000
commit1b13065080a374450514fba1992a58c98112ea07 (patch)
tree2613520fcec7a39e527635a47f990b236b581cf6 /sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild
parentFix dependencies. (diff)
downloadgentoo-2-1b13065080a374450514fba1992a58c98112ea07.tar.gz
gentoo-2-1b13065080a374450514fba1992a58c98112ea07.tar.bz2
gentoo-2-1b13065080a374450514fba1992a58c98112ea07.zip
Added fix for bug #140987.
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild
new file mode 100644
index 000000000000..a0069a2dcb04
--- /dev/null
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/hexcalc/hexcalc-1.11-r1.ebuild,v 1.1 2006/07/25 18:07:34 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="A simple hex calculator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/"
+SRC_URI="ftp://ftp.x.org/R5contrib/${PN}.tar.Z"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| ( x11-libs/libXaw virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( ( x11-misc/imake app-text/rman ) virtual/x11 )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-order.diff
+}
+
+src_compile() {
+ xmkmf || die
+ make || die
+}
+
+src_install() {
+
+ dobin hexcalc
+ mv hexcalc.man hexcalc.1
+ doman hexcalc.1
+}