summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-04 09:31:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-04 09:31:27 +0000
commit7c720ba0d5bd5344d0cfac17c621fdd9e913bd64 (patch)
treea8cb19e043355a3511129a7acf426e0bcd3fa13f /sci-biology/plink
parentForgot to remove commenting after testing. (diff)
downloadgentoo-2-7c720ba0d5bd5344d0cfac17c621fdd9e913bd64.tar.gz
gentoo-2-7c720ba0d5bd5344d0cfac17c621fdd9e913bd64.tar.bz2
gentoo-2-7c720ba0d5bd5344d0cfac17c621fdd9e913bd64.zip
sci-biology/plink: Moved to EAPI=4, add fix for building with gcc-4.7, #424709
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/plink')
-rw-r--r--sci-biology/plink/ChangeLog8
-rw-r--r--sci-biology/plink/files/plink-1.07-gcc47.patch64
-rw-r--r--sci-biology/plink/plink-1.07-r1.ebuild17
3 files changed, 79 insertions, 10 deletions
diff --git a/sci-biology/plink/ChangeLog b/sci-biology/plink/ChangeLog
index ea9fc7da651e..7de52d937314 100644
--- a/sci-biology/plink/ChangeLog
+++ b/sci-biology/plink/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/plink
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/ChangeLog,v 1.11 2011/12/13 23:38:07 ago Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/ChangeLog,v 1.12 2012/07/04 09:31:26 jlec Exp $
+
+ 04 Jul 2012; Justin Lecher <jlec@gentoo.org> plink-1.07-r1.ebuild,
+ +files/plink-1.07-gcc47.patch:
+ Moved to EAPI=4, add fix for building with gcc-4.7, #424709
13 Dec 2011; Agostino Sarubbo <ago@gentoo.org> plink-1.07-r1.ebuild:
Stable for AMD64, wrt bug #392783
diff --git a/sci-biology/plink/files/plink-1.07-gcc47.patch b/sci-biology/plink/files/plink-1.07-gcc47.patch
new file mode 100644
index 000000000000..6c289edae153
--- /dev/null
+++ b/sci-biology/plink/files/plink-1.07-gcc47.patch
@@ -0,0 +1,64 @@
+ elf.cpp | 6 +++---
+ idhelp.cpp | 8 ++++----
+ sets.cpp | 8 ++++----
+ 3 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/elf.cpp b/elf.cpp
+index ec2ed3d..a57665f 100644
+--- a/elf.cpp
++++ b/elf.cpp
+@@ -1175,10 +1175,10 @@ void Plink::elfBaseline()
+ << setw(8) << gcnt << " "
+ << setw(8) << (double)cnt / (double)gcnt << "\n";
+
+- map<int,int>::iterator i = chr_cnt.begin();
+- while ( i != chr_cnt.end() )
++ map<int,int>::iterator j = chr_cnt.begin();
++ while ( j != chr_cnt.end() )
+ {
+- int c = i->first;
++ int c = j->first;
+ int x = chr_cnt.find( c )->second;
+ int y = chr_gcnt.find( c )->second;
+
+diff --git a/idhelp.cpp b/idhelp.cpp
+index a9244fa..8882097 100644
+--- a/idhelp.cpp
++++ b/idhelp.cpp
+@@ -772,12 +772,12 @@ void IDHelper::idHelp()
+ for (int j = 0 ; j < jointField.size(); j++ )
+ {
+ set<IDField*> & jf = jointField[j];
+- set<IDField*>::iterator j = jf.begin();
++ set<IDField*>::iterator k = jf.begin();
+ PP->printLOG(" { ");
+- while ( j != jf.end() )
++ while ( k != jf.end() )
+ {
+- PP->printLOG( (*j)->name + " " );
+- ++j;
++ PP->printLOG( (*k)->name + " " );
++ ++k;
+ }
+ PP->printLOG(" }");
+ }
+diff --git a/sets.cpp b/sets.cpp
+index 3a8f92f..66787e8 100644
+--- a/sets.cpp
++++ b/sets.cpp
+@@ -768,11 +768,11 @@ vector_t Set::profileTestScore()
+ //////////////////////////////////////////////
+ // Reset original missing status
+
+- vector<Individual*>::iterator i = PP->sample.begin();
+- while ( i != PP->sample.end() )
++ vector<Individual*>::iterator j = PP->sample.begin();
++ while ( j != PP->sample.end() )
+ {
+- (*i)->missing = (*i)->flag;
+- ++i;
++ (*j)->missing = (*j)->flag;
++ ++j;
+ }
+
+ ////////////////////////////////////////////////
diff --git a/sci-biology/plink/plink-1.07-r1.ebuild b/sci-biology/plink/plink-1.07-r1.ebuild
index 96e64d95b785..6f0e5a4233d8 100644
--- a/sci-biology/plink/plink-1.07-r1.ebuild
+++ b/sci-biology/plink/plink-1.07-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.07-r1.ebuild,v 1.4 2011/12/13 23:38:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.07-r1.ebuild,v 1.5 2012/07/04 09:31:26 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils toolchain-funcs
@@ -26,7 +26,9 @@ S="${WORKDIR}/${P}-src"
# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
src_prepare() {
- epatch "${FILESDIR}"/${PV}-flags.patch
+ epatch \
+ "${FILESDIR}"/${PV}-flags.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
use webcheck || sed -i '/WITH_WEBCHECK =/ s/^/#/' "${S}/Makefile" || die
use R || sed -i '/WITH_R_PLUGINS =/ s/^/#/' "${S}/Makefile" || die
use lapack || sed -i '/WITH_LAPACK =/ s/^/#/' "${S}/Makefile" || die
@@ -34,11 +36,10 @@ src_prepare() {
src_compile() {
emake \
- CXX_UNIX=$(tc-getCXX) \
- || die
+ CXX_UNIX=$(tc-getCXX)
}
src_install() {
- newbin plink p-link || die
- dodoc README.txt || die
+ newbin plink p-link
+ dodoc README.txt
}