summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-26 11:04:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-26 11:04:59 +0000
commit21354bbf8205aa1ce2e6659b32935ee66ee77455 (patch)
tree04b1e338fd77cb29b7f8ded400d645c13d6c2a51 /sci-biology/ncbi-tools++
parentFixed src_test, #277097 (diff)
downloadgentoo-2-21354bbf8205aa1ce2e6659b32935ee66ee77455.tar.gz
gentoo-2-21354bbf8205aa1ce2e6659b32935ee66ee77455.tar.bz2
gentoo-2-21354bbf8205aa1ce2e6659b32935ee66ee77455.zip
Fixed as-needed problem
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/ncbi-tools++')
-rw-r--r--sci-biology/ncbi-tools++/ChangeLog9
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-2009.05.15-asneeded.patch123
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r6.ebuild (renamed from sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r5.ebuild)12
3 files changed, 137 insertions, 7 deletions
diff --git a/sci-biology/ncbi-tools++/ChangeLog b/sci-biology/ncbi-tools++/ChangeLog
index 1a8fdbbd3898..05f5be575736 100644
--- a/sci-biology/ncbi-tools++/ChangeLog
+++ b/sci-biology/ncbi-tools++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/ncbi-tools++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ChangeLog,v 1.15 2010/06/26 07:28:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ChangeLog,v 1.16 2010/06/26 11:04:59 jlec Exp $
+
+*ncbi-tools++-2009.05.15-r6 (26 Jun 2010)
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ -ncbi-tools++-2009.05.15-r5.ebuild, +ncbi-tools++-2009.05.15-r6.ebuild,
+ +files/ncbi-tools++-2009.05.15-asneeded.patch:
+ Fixed as-needed problem
26 Jun 2010; Justin Lecher <jlec@gentoo.org>
ncbi-tools++-2009.05.15-r5.ebuild:
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-2009.05.15-asneeded.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-2009.05.15-asneeded.patch
new file mode 100644
index 000000000000..fde794b1a20e
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-2009.05.15-asneeded.patch
@@ -0,0 +1,123 @@
+--- src/build-system/Makefile.mk.in
++++ src/build-system/Makefile.mk.in
+@@ -547,7 +547,7 @@
+ #################################
+ # Useful sets of object libraries
+ # Interdependent sequence libraries + seqcode. Does not include seqset.
+-COMPRESS_LDEP = $(CMPRS_LIB)
++COMPRESS_LDEP = $(CMPRS_LIB) xutil xncbi
+ COMPRESS_LIBS = xcompress $(COMPRESS_LDEP)
+
+ GENBANK_LDEP = \
+--- src/util/compress/Makefile.compress.lib
++++ src/util/compress/Makefile.compress.lib
+@@ -4,7 +4,7 @@
+
+ LIB = xcompress
+
+-DLL_LIB =
+-#$(COMPRESS_LDEP)
++DLL_LIB = $(COMPRESS_LDEP)
++LIBS = $(CMPRS_LIBS)
+
+ CPPFLAGS = $(ORIG_CPPFLAGS) $(CMPRS_INCLUDE)
+--- src/serial/Makefile.serial.lib
++++ src/serial/Makefile.serial.lib
+@@ -17,3 +17,5 @@
+ objostrjson serializable serialobject pathhook
+
+ LIB = xser
++
++DLL_LIB = xutil xncbi
+--- src/objtools/data_loaders/genbank/Makefile.ncbi_xreader.lib
++++ src/objtools/data_loaders/genbank/Makefile.ncbi_xreader.lib
+@@ -12,4 +12,4 @@
+ LIB_OR_DLL = both
+
+ # Dependencies for shared library
+-DLL_LIB =
++DLL_LIB = xcompress
+--- src/objtools/readers/Makefile.xobjread.lib
++++ src/objtools/readers/Makefile.xobjread.lib
+@@ -8,4 +8,4 @@
+ wiggle_reader wiggle_data gff3_reader \
+ ucscid idmap idmapper idmapper_builtin idmapper_user idmapper_site \
+ idmapper_database
+-DLL_LIB = creaders
++DLL_LIB = creaders seq seqset
+--- src/objects/seq/Makefile.seq.lib
++++ src/objects/seq/Makefile.seq.lib
+@@ -10,3 +10,5 @@
+ SRC = $(ASN:%=%__) $(ASN:%=%___) seqport_util \
+ seq_id_tree seq_id_handle seq_id_mapper \
+ seq_loc_mapper_base seq_align_mapper_base
++
++DLL_LIB = biblio general pub seqcode sequtil xncbi
+--- src/objects/pub/Makefile.pub.lib
++++ src/objects/pub/Makefile.pub.lib
+@@ -1,2 +1,4 @@
+ LIB = pub
+ SRC = pub__ pub___
++
++DLL_LIB = medline
+--- src/objects/general/Makefile.general.lib
++++ src/objects/general/Makefile.general.lib
+@@ -1,2 +1,4 @@
+ LIB = general
+ SRC = general__ general___ uoconv
++
++DLL_LIB = xsoap xser
+--- src/objects/omssa/Makefile.omssa.lib
++++ src/objects/omssa/Makefile.omssa.lib
+@@ -2,3 +2,5 @@
+
+ LIB = omssa
+ SRC = omssa__ omssa___
++
++DLL_LIB = seq
+--- src/algo/blast/api/Makefile.xblast.lib
++++ src/algo/blast/api/Makefile.xblast.lib
+@@ -73,7 +73,8 @@
+
+ LIB = xblast
+
+-DLL_LIB = xalgodustmask xobjutil $(OBJMGR_LIBS)
++DLL_LIB = xalgodustmask xalgowinmask xobjutil xnetblast xnetblastcli blastdb composition_adjustment \
++ blast tables xalgoblastdbindex_search xalgoblastdbindex $(OBJMGR_LIBS)
+
+ CFLAGS = $(FAST_CFLAGS)
+ # Strict gcc flags
+--- src/algo/blast/dbindex/Makefile.xalgoblastdbindex.lib
++++ src/algo/blast/dbindex/Makefile.xalgoblastdbindex.lib
+@@ -12,3 +12,4 @@
+ LDFLAGS = $(FAST_LDFLAGS)
+
+ ASN_DEP = seqset
++DLL_LIB = xobjread
+--- src/objects/biblio/Makefile.biblio.lib
++++ src/objects/biblio/Makefile.biblio.lib
+@@ -1,2 +1,4 @@
+ LIB = biblio
+ SRC = biblio__ biblio___ label_util
++
++DLL_LIB = general
+--- src/objects/medline/Makefile.medline.lib
++++ src/objects/medline/Makefile.medline.lib
+@@ -1,2 +1,4 @@
+ LIB = medline
+ SRC = medline__ medline___
++
++DLL_LIB = biblio
+--- src/objects/Makefile.in
++++ src/objects/Makefile.in
+@@ -5,8 +5,8 @@
+
+ USR_PROJ = sources
+
+-SUB_PROJ = tinyseq omssa general biblio medline pub pubmed \
+- featdef seqcode seqset seq genomecoll biotree \
++SUB_PROJ = tinyseq general biblio medline pub pubmed \
++ featdef seqcode seqset seq omssa genomecoll biotree \
+ id1 id2 gbseq insdseq entrez2 submit medlars mla proj mmdb \
+ cdd cn3d scoremat ncbimime access objprt docsum taxon1 mim \
+ entrezgene blast blastdb blastxml pcsubstance pcassay remap \
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r5.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r6.ebuild
index b29b6fad8f13..576abdf21470 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r5.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r5.ebuild,v 1.2 2010/06/26 07:28:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ncbi-tools++-2009.05.15-r6.ebuild,v 1.1 2010/06/26 11:04:59 jlec Exp $
EAPI="3"
-inherit eutils multilib
+inherit eutils flag-o-matic multilib toolchain-funcs
MY_TAG="May_15_2009"
MY_Y="${MY_TAG/*_/}"
@@ -47,7 +47,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
sed -i -e 's/-print-file-name=libstdc++.a//' \
-e '/sed/ s/\([gO]\[0-9\]\)\*/\1\\+/' \
src/build-system/configure || die
@@ -55,10 +56,9 @@ src_prepare() {
src_configure() {
# required with gcc-4.4 and code turned on by --with-mt
- export CPPFLAGS="${CPPFLAGS} -fpermissive"
+ append-cxxflags -fpermissive
- # I add this until the as-needed fix is in the tree
- append-ldflags $(no-as-needed)
+ tc-export CXX CC
# econf fails
# --with-bin-release and --without-ftds are workarounds for build system bugs