summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-03-16 23:29:10 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-03-16 23:29:10 +0000
commit1af7928a2e24e394ae7a12b92a09eaaed9a2d7e9 (patch)
tree7e3bbbcefc555f3277ac5b3ecae60452749c4a38 /sci-biology/bioperl-run
parentVersion bump. Enables passive scanning on a wider spectrum in the world domain. (diff)
downloadgentoo-2-1af7928a2e24e394ae7a12b92a09eaaed9a2d7e9.tar.gz
gentoo-2-1af7928a2e24e394ae7a12b92a09eaaed9a2d7e9.tar.bz2
gentoo-2-1af7928a2e24e394ae7a12b92a09eaaed9a2d7e9.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'sci-biology/bioperl-run')
-rw-r--r--sci-biology/bioperl-run/ChangeLog11
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.6.1.ebuild40
-rw-r--r--sci-biology/bioperl-run/bioperl-run-9999.ebuild39
3 files changed, 88 insertions, 2 deletions
diff --git a/sci-biology/bioperl-run/ChangeLog b/sci-biology/bioperl-run/ChangeLog
index 0c7cac03f87a..0fe2442c1c98 100644
--- a/sci-biology/bioperl-run/ChangeLog
+++ b/sci-biology/bioperl-run/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/bioperl-run
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-run/ChangeLog,v 1.13 2007/02/22 01:24:25 jokey Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-run/ChangeLog,v 1.14 2009/03/16 23:29:10 weaver Exp $
+
+*bioperl-run-9999 (16 Mar 2009)
+*bioperl-run-1.6.1 (16 Mar 2009)
+
+ 16 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> +bioperl-run-1.6.1.ebuild,
+ +bioperl-run-9999.ebuild:
+ Version bump
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-biology/bioperl-run/bioperl-run-1.6.1.ebuild b/sci-biology/bioperl-run/bioperl-run-1.6.1.ebuild
new file mode 100644
index 000000000000..3aae144c01b4
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-run/bioperl-run-1.6.1.ebuild,v 1.1 2009/03/16 23:29:10 weaver Exp $
+
+EAPI="2"
+
+inherit perl-module
+
+MY_PV="1.6.0"
+
+DESCRIPTION="Perl tools for bioinformatics - Wrapper modules around key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+SRC_URI="http://bioperl.org/DIST/BioPerl-run-${PV}.tar.bz2"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-minimal test"
+SRC_TEST="do"
+
+DEPEND="virtual/perl-Module-Build
+ >=sci-biology/bioperl-${MY_PV}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/BioPerl-run-${MY_PV}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
+ # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
+ find "${D}" -name '*ConfigData*' -print -delete
+}
diff --git a/sci-biology/bioperl-run/bioperl-run-9999.ebuild b/sci-biology/bioperl-run/bioperl-run-9999.ebuild
new file mode 100644
index 000000000000..ae945be7175e
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-run/bioperl-run-9999.ebuild,v 1.1 2009/03/16 23:29:10 weaver Exp $
+
+EAPI="2"
+
+inherit perl-module subversion
+
+DESCRIPTION="Perl tools for bioinformatics - Wrapper modules around key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+SRC_URI=""
+ESVN_REPO_URI="svn://code.open-bio.org/bioperl/${PN}/trunk"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="-minimal test"
+SRC_TEST="do"
+
+DEPEND="virtual/perl-Module-Build
+ >=sci-biology/bioperl-${PV}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/BioPerl-run-${PV}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
+ # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
+ find "${D}" -name '*ConfigData*' -print -delete
+}