summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-01-26 20:43:21 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-01-26 20:43:21 +0000
commitb7c6044d9ed9806ac5510e5d6422863d7fce9bb8 (patch)
treef8172c9116ce54d274cfa0853ac8f320a22dc5c3 /sci-biology/allpaths
parentVersion bump. (diff)
downloadgentoo-2-b7c6044d9ed9806ac5510e5d6422863d7fce9bb8.tar.gz
gentoo-2-b7c6044d9ed9806ac5510e5d6422863d7fce9bb8.tar.bz2
gentoo-2-b7c6044d9ed9806ac5510e5d6422863d7fce9bb8.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-biology/allpaths')
-rw-r--r--sci-biology/allpaths/ChangeLog7
-rw-r--r--sci-biology/allpaths/allpaths-3.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-biology/allpaths/ChangeLog b/sci-biology/allpaths/ChangeLog
index 27d5a02e5708..521be3cf8b2a 100644
--- a/sci-biology/allpaths/ChangeLog
+++ b/sci-biology/allpaths/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/allpaths
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/ChangeLog,v 1.5 2010/01/03 14:08:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/ChangeLog,v 1.6 2010/01/26 20:43:21 weaver Exp $
+
+*allpaths-3.1 (26 Jan 2010)
+
+ 26 Jan 2010; Andrey Kislyuk <weaver@gentoo.org> +allpaths-3.1.ebuild:
+ Version bump
03 Jan 2010; Pacho Ramos <pacho@gentoo.org> allpaths-2.0.ebuild:
amd64 stable, bug 290927
diff --git a/sci-biology/allpaths/allpaths-3.1.ebuild b/sci-biology/allpaths/allpaths-3.1.ebuild
new file mode 100644
index 000000000000..31ac65d432a1
--- /dev/null
+++ b/sci-biology/allpaths/allpaths-3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/allpaths-3.1.ebuild,v 1.1 2010/01/26 20:43:21 weaver Exp $
+
+EAPI="2"
+
+inherit base
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-3-0/allpaths-${PV}.tgz
+ ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-3-0/AllPathsV3_Manual_r1.0.docx"
+
+LICENSE="Whitehead-MIT"
+SLOT="3"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND=">=sys-devel/gcc-4.3.2"
+RDEPEND=""
+
+S="${WORKDIR}/AllPaths"
+
+src_compile() {
+ base_src_compile
+ emake install_scripts || die
+}
+
+src_install() {
+ exeinto /usr/share/${P}/bin
+ find bin -type f -executable | xargs doexe || die
+ echo "PATH=\"/usr/share/${P}/bin\"" > "${S}/99${P}"
+ doenvd "${S}/99${P}" || die
+ dosym /usr/share/${P}/bin/RunAllPaths3G /usr/bin/RunAllPaths3G || die
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/AllPathsV3_Manual_r1.0.docx"
+}