summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-11-29 15:22:44 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-11-29 15:22:44 +0000
commitd7a419394d68f8ec22ea3666cf9fac593cf98f35 (patch)
treeea7bdf5dd1a17f4b1146c97585281a93eb517e9e /sci-astronomy
parentStable on sparc wrt #155882 (diff)
downloadgentoo-2-d7a419394d68f8ec22ea3666cf9fac593cf98f35.tar.gz
gentoo-2-d7a419394d68f8ec22ea3666cf9fac593cf98f35.tar.bz2
gentoo-2-d7a419394d68f8ec22ea3666cf9fac593cf98f35.zip
Version bump, bug #156581. Added a patch for problems linking with lesstif and some minor compile problem.
(Portage version: 2.1.1)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/xephem/ChangeLog9
-rw-r--r--sci-astronomy/xephem/files/3.7.2.patch31
-rw-r--r--sci-astronomy/xephem/files/digest-xephem-3.7.23
-rw-r--r--sci-astronomy/xephem/xephem-3.7.2.ebuild71
4 files changed, 113 insertions, 1 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index b2abceebb22b..dd234608c0a2 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.11 2006/07/28 14:56:59 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.12 2006/11/29 15:22:44 phosphan Exp $
+
+*xephem-3.7.2 (29 Nov 2006)
+
+ 29 Nov 2006; Patrick Kursawe <phosphan@gentoo.org> +files/3.7.2.patch,
+ +xephem-3.7.2.ebuild:
+ Version bump, bug #156581. Added a patch for problems linking with lesstif
+ and some minor compile problem.
*xephem-3.7.1 (28 Jul 2006)
diff --git a/sci-astronomy/xephem/files/3.7.2.patch b/sci-astronomy/xephem/files/3.7.2.patch
new file mode 100644
index 000000000000..968d5c7df36a
--- /dev/null
+++ b/sci-astronomy/xephem/files/3.7.2.patch
@@ -0,0 +1,31 @@
+--- GUI/xephem/tools/xephemdbd/request.c 2006-11-29 14:43:38.000000000 +0100
++++ GUI/xephem/tools/xephemdbd/request.c.fixed 2006-04-10 11:01:17.000000000 +0200
+@@ -155,7 +155,7 @@
+ {
+ char str1[32], str2[32];
+
+- fs_date (str1, mjd_day(mjd));
++ fs_date (str1, pref_get(PREF_DATE_FORMAT), mjd_day(mjd));
+ fs_sexa (str2, mjd_hr(mjd), 2, 3600);
+ printf ("UTC Time: %s %s JD %13.5f\n", str1, str2, mjd+MJD0);
+
+--- GUI/xephem/Makefile 2006-11-29 16:08:02.000000000 +0100
++++ GUI.new/xephem/Makefile 2006-11-29 16:08:56.000000000 +0100
+@@ -15,7 +15,7 @@
+ LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
+
+ # MOTIFI is the directory containing the Xm directory of include files.
+-# MOTIFL is the directory containing the libXm.a library.
++# MOTIFL is the directory containing libXm
+ # MOTIF can be used to set one common directory if desired.
+ # Defaults work ok for Linux and Mac OS X.
+ ifdef MOTIF
+@@ -34,7 +34,7 @@
+ CLDFLAGS = -g
+ CFLAGS= $(LIBINC) -Wall -I$(MOTIFI) -I/usr/X11R6/include -march=athlon-xp -O2 -pipe
+ LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
+-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
++XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11
+ LIBS = $(XLIBS) $(LIBLIB) -lm
+
+ # for ppc Apple OS X to make universal (i386 and ppc binary), requires
diff --git a/sci-astronomy/xephem/files/digest-xephem-3.7.2 b/sci-astronomy/xephem/files/digest-xephem-3.7.2
new file mode 100644
index 000000000000..110bf20d4480
--- /dev/null
+++ b/sci-astronomy/xephem/files/digest-xephem-3.7.2
@@ -0,0 +1,3 @@
+MD5 1074e04b9a89302d9f2bad7107674311 xephem-3.7.2.tar.gz 19369598
+RMD160 585ed51d167869919b512561714d380c83db8865 xephem-3.7.2.tar.gz 19369598
+SHA256 51697f36e08000fc5f8f5e5edc570f82c92d0b323331291877814410396d0354 xephem-3.7.2.tar.gz 19369598
diff --git a/sci-astronomy/xephem/xephem-3.7.2.ebuild b/sci-astronomy/xephem/xephem-3.7.2.ebuild
new file mode 100644
index 000000000000..326568be810b
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-3.7.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.2.ebuild,v 1.1 2006/11/29 15:22:44 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
+SRC_URI="http://www.clearskyinstitute.com/xephem/${P}.tar.gz"
+HOMEPAGE="http://www.clearskyinstitute.com/xephem"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+SLOT="0"
+LICENSE="as-is"
+DEPEND="virtual/motif"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}.patch
+ for i in libastro/Makefile libip/Makefile libjpegd/Makefile \
+ liblilxml/Makefile GUI/xephem/Makefile GUI/xephem/tools/*/Makefile ; do
+ einfo "Fixing CFLAGS in ${i}"
+ sed -e "s~^CFLAGS[ ]*=\(.*\)-O2\(.*\)~CFLAGS= \1 \2 ${CFLAGS}~" -i ${i} \
+ || die "sed failed"
+ done
+ sed -e 's~^CFLAGS[ ]*=\(.*\)$(CLDFLAGS)\(.*\)~CFLAGS=\1 \2~' \
+ -i GUI/xephem/Makefile
+}
+
+src_compile() {
+
+ cd libastro
+ emake || die
+ local myldflags
+ cd ${S}
+ for dir in libip liblilxml libjpegd GUI/xephem/tools/* GUI/xephem; do
+ echo "going into ${dir}"
+ cd ${S}/${dir}
+ if [ ${dir:0:3} = "lib" ]; then
+ myldflags=""
+ else
+ myldflags="${CLDFLAGS}"
+ fi
+ emake MOTIFI="/usr/include" MOTIFL="/usr/lib" CLDFLAGS="${myldflags}" || die
+ done
+}
+
+src_install() {
+
+ into /usr
+ cd ${S}/GUI/xephem
+ dobin xephem
+ for file in tools/indi/{evalINDI,getINDI,setINDI,tmount,ota,wx,cam,security,indiserver} \
+ tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
+ dobin ${file}
+ done
+ doman xephem.1 tools/*/*.1
+ mv tools .. # do not install tool sources into share directory
+ for i in $(find . -type d -mindepth 1); do
+ insinto /usr/share/${PN}/${i}
+ doins ${i}/*
+ done
+
+ echo > ${S}/XEphem "XEphem.ShareDir: /usr/share/${PN}"
+ insinto /usr/lib/X11/app-defaults/
+ doins ${S}/XEphem
+
+ cd ${S}
+ dodoc Copyright README INSTALL
+}